Message ID | 20210925114205.11377-1-len.baker@gmx.com (mailing list archive) |
---|---|
State | Handled Elsewhere |
Headers | show |
Series | [v2] scsi: advansys: Prefer struct_size over open coded arithmetic | expand |
On Sat, Sep 25, 2021 at 01:42:05PM +0200, Len Baker wrote: > As noted in the "Deprecated Interfaces, Language Features, Attributes, > and Conventions" documentation [1], size calculations (especially > multiplication) should not be performed in memory allocator (or similar) > function arguments due to the risk of them overflowing. This could lead > to values wrapping around and a smaller allocation being made than the > caller was expecting. Using those allocations could lead to linear > overflows of heap memory and other misbehaviors. > > So, use the struct_size() helper to do the arithmetic instead of the > argument "size + count * size" in the kzalloc() function. > > This code was detected with the help of Coccinelle and audited and fixed > manually. > > [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments > > Signed-off-by: Len Baker <len.baker@gmx.com> Reviewed-by: Gustavo A. R. Silva <gustavoars@kernel.org> > --- > Changelog v1 -> v2 > - Rebase against v5.15-rc2 Don't use mainline for these sorts of patches . Use linux-next instead: https://www.kernel.org/doc/man-pages/linux-next.html Thanks -- Gustavo > - Remove the unnecessary "size" variable (Gustavo A. R. Silva). > - Update the commit changelog to inform that this code was detected > using a Coccinelle script (Gustavo A. R. Silva). > > drivers/scsi/advansys.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/scsi/advansys.c b/drivers/scsi/advansys.c > index ffb391967573..e341b3372482 100644 > --- a/drivers/scsi/advansys.c > +++ b/drivers/scsi/advansys.c > @@ -7477,8 +7477,8 @@ static int asc_build_req(struct asc_board *boardp, struct scsi_cmnd *scp, > return ASC_ERROR; > } > > - asc_sg_head = kzalloc(sizeof(asc_scsi_q->sg_head) + > - use_sg * sizeof(struct asc_sg_list), GFP_ATOMIC); > + asc_sg_head = kzalloc(struct_size(asc_sg_head, sg_list, use_sg), > + GFP_ATOMIC); > if (!asc_sg_head) { > scsi_dma_unmap(scp); > set_host_byte(scp, DID_SOFT_ERROR); > -- > 2.25.1 >
Len, > As noted in the "Deprecated Interfaces, Language Features, Attributes, > and Conventions" documentation [1], size calculations (especially > multiplication) should not be performed in memory allocator (or > similar) function arguments due to the risk of them overflowing. This > could lead to values wrapping around and a smaller allocation being > made than the caller was expecting. Using those allocations could lead > to linear overflows of heap memory and other misbehaviors. Applied to 5.16/scsi-staging, thanks!
On Sat, 25 Sep 2021 13:42:05 +0200, Len Baker wrote: > As noted in the "Deprecated Interfaces, Language Features, Attributes, > and Conventions" documentation [1], size calculations (especially > multiplication) should not be performed in memory allocator (or similar) > function arguments due to the risk of them overflowing. This could lead > to values wrapping around and a smaller allocation being made than the > caller was expecting. Using those allocations could lead to linear > overflows of heap memory and other misbehaviors. > > [...] Applied to 5.16/scsi-queue, thanks! [1/1] scsi: advansys: Prefer struct_size over open coded arithmetic https://git.kernel.org/mkp/scsi/c/568778f5572a
diff --git a/drivers/scsi/advansys.c b/drivers/scsi/advansys.c index ffb391967573..e341b3372482 100644 --- a/drivers/scsi/advansys.c +++ b/drivers/scsi/advansys.c @@ -7477,8 +7477,8 @@ static int asc_build_req(struct asc_board *boardp, struct scsi_cmnd *scp, return ASC_ERROR; } - asc_sg_head = kzalloc(sizeof(asc_scsi_q->sg_head) + - use_sg * sizeof(struct asc_sg_list), GFP_ATOMIC); + asc_sg_head = kzalloc(struct_size(asc_sg_head, sg_list, use_sg), + GFP_ATOMIC); if (!asc_sg_head) { scsi_dma_unmap(scp); set_host_byte(scp, DID_SOFT_ERROR);
As noted in the "Deprecated Interfaces, Language Features, Attributes, and Conventions" documentation [1], size calculations (especially multiplication) should not be performed in memory allocator (or similar) function arguments due to the risk of them overflowing. This could lead to values wrapping around and a smaller allocation being made than the caller was expecting. Using those allocations could lead to linear overflows of heap memory and other misbehaviors. So, use the struct_size() helper to do the arithmetic instead of the argument "size + count * size" in the kzalloc() function. This code was detected with the help of Coccinelle and audited and fixed manually. [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments Signed-off-by: Len Baker <len.baker@gmx.com> --- Changelog v1 -> v2 - Rebase against v5.15-rc2 - Remove the unnecessary "size" variable (Gustavo A. R. Silva). - Update the commit changelog to inform that this code was detected using a Coccinelle script (Gustavo A. R. Silva). drivers/scsi/advansys.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) -- 2.25.1