Message ID | 20211028003526.7117-1-yang.guang5@zte.com.cn (mailing list archive) |
---|---|
State | Changes Requested |
Delegated to: | Kees Cook |
Headers | show |
Series | gcc-plugins: use swap() to make code cleaner | expand |
On Thu, Oct 28, 2021 at 12:35:26AM +0000, Yang Guang wrote: > Using swap() make it more readable. > > Reported-by: Zeal Robot <zealci@zte.com.cn> > Signed-off-by: Yang Guang <yang.guang5@zte.com.cn> > --- > scripts/gcc-plugins/randomize_layout_plugin.c | 5 +---- > 1 file changed, 1 insertion(+), 4 deletions(-) > > diff --git a/scripts/gcc-plugins/randomize_layout_plugin.c b/scripts/gcc-plugins/randomize_layout_plugin.c > index 334741a31d0a..feee5ba8fa2b 100644 > --- a/scripts/gcc-plugins/randomize_layout_plugin.c > +++ b/scripts/gcc-plugins/randomize_layout_plugin.c > @@ -244,11 +244,8 @@ static void full_shuffle(tree *newtree, unsigned long length, ranctx *prng_state > unsigned long i, randnum; > > for (i = length - 1; i > 0; i--) { > - tree tmp; > randnum = ranval(prng_state) % (i + 1); > - tmp = newtree[i]; > - newtree[i] = newtree[randnum]; > - newtree[randnum] = tmp; > + swap(newtree[i], newtree[randnum]); > } > } Hmm, I don't think you compile-tested this? The gcc plugins are build in userspace without the kernel headers (i.e. no "swap" macro). I'd be happy to avoid open-coding this, but that would require a new macro specific to the gcc plugins (to avoid std::swap). Also, there are two other open-coded swaps in here that could be changed too. :) -Kees
diff --git a/scripts/gcc-plugins/randomize_layout_plugin.c b/scripts/gcc-plugins/randomize_layout_plugin.c index 334741a31d0a..feee5ba8fa2b 100644 --- a/scripts/gcc-plugins/randomize_layout_plugin.c +++ b/scripts/gcc-plugins/randomize_layout_plugin.c @@ -244,11 +244,8 @@ static void full_shuffle(tree *newtree, unsigned long length, ranctx *prng_state unsigned long i, randnum; for (i = length - 1; i > 0; i--) { - tree tmp; randnum = ranval(prng_state) % (i + 1); - tmp = newtree[i]; - newtree[i] = newtree[randnum]; - newtree[randnum] = tmp; + swap(newtree[i], newtree[randnum]); } }
Using swap() make it more readable. Reported-by: Zeal Robot <zealci@zte.com.cn> Signed-off-by: Yang Guang <yang.guang5@zte.com.cn> --- scripts/gcc-plugins/randomize_layout_plugin.c | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-)