Message ID | 20211118183700.1282181-1-keescook@chromium.org (mailing list archive) |
---|---|
State | Handled Elsewhere |
Headers | show |
Series | mwl8k: Use struct_group() for memcpy() region | expand |
On Thu, 2021-11-18 at 10:37 -0800, Kees Cook wrote: > > - __u8 key_material[MAX_ENCR_KEY_LENGTH]; > - __u8 tkip_tx_mic_key[MIC_KEY_LENGTH]; > - __u8 tkip_rx_mic_key[MIC_KEY_LENGTH]; > + struct { > + __u8 key_material[MAX_ENCR_KEY_LENGTH]; > That got one tab too many? johannes
On Thu, Nov 18, 2021 at 08:45:22PM +0100, Johannes Berg wrote: > On Thu, 2021-11-18 at 10:37 -0800, Kees Cook wrote: > > > > - __u8 key_material[MAX_ENCR_KEY_LENGTH]; > > - __u8 tkip_tx_mic_key[MIC_KEY_LENGTH]; > > - __u8 tkip_rx_mic_key[MIC_KEY_LENGTH]; > > + struct { > > + __u8 key_material[MAX_ENCR_KEY_LENGTH]; > > > > That got one tab too many? Whoops! Thanks, I will adjust. :)
diff --git a/drivers/net/wireless/marvell/mwl8k.c b/drivers/net/wireless/marvell/mwl8k.c index 529e325498cd..90e881655fb2 100644 --- a/drivers/net/wireless/marvell/mwl8k.c +++ b/drivers/net/wireless/marvell/mwl8k.c @@ -4225,9 +4225,11 @@ struct mwl8k_cmd_set_key { __le32 key_info; __le32 key_id; __le16 key_len; - __u8 key_material[MAX_ENCR_KEY_LENGTH]; - __u8 tkip_tx_mic_key[MIC_KEY_LENGTH]; - __u8 tkip_rx_mic_key[MIC_KEY_LENGTH]; + struct { + __u8 key_material[MAX_ENCR_KEY_LENGTH]; + __u8 tkip_tx_mic_key[MIC_KEY_LENGTH]; + __u8 tkip_rx_mic_key[MIC_KEY_LENGTH]; + } tkip; __le16 tkip_rsc_low; __le32 tkip_rsc_high; __le16 tkip_tsc_low; @@ -4375,7 +4377,7 @@ static int mwl8k_cmd_encryption_set_key(struct ieee80211_hw *hw, goto done; } - memcpy(cmd->key_material, key->key, keymlen); + memcpy(&cmd->tkip, key->key, keymlen); cmd->action = cpu_to_le32(action); rc = mwl8k_post_pervif_cmd(hw, vif, &cmd->header);
In preparation for FORTIFY_SOURCE performing compile-time and run-time field bounds checking for memcpy(), memmove(), and memset(), avoid intentionally writing across neighboring fields. Use struct_group() in struct mwl8k_cmd_set_key around members key_material, tkip_tx_mic_key, and tkip_rx_mic_key so they can be referenced together. This will allow memcpy() and sizeof() to more easily reason about sizes, improve readability, and avoid future warnings about writing beyond the end of key_material. "pahole" shows no size nor member offset changes to struct mwl8k_cmd_set_key. "objdump -d" shows no object code changes. Signed-off-by: Kees Cook <keescook@chromium.org> --- drivers/net/wireless/marvell/mwl8k.c | 10 ++++++---- 1 file changed, 6 insertions(+), 4 deletions(-)