diff mbox series

[next] mlxsw: spectrum_kvdl: Use struct_size() helper in kzalloc()

Message ID 20220125170128.GA60918@embeddedor (mailing list archive)
State Mainlined
Commit 70b3c38b4c83386b714935489cf99359dc6f0da4
Delegated to: Gustavo A. R. Silva
Headers show
Series [next] mlxsw: spectrum_kvdl: Use struct_size() helper in kzalloc() | expand

Commit Message

Gustavo A. R. Silva Jan. 25, 2022, 5:01 p.m. UTC
Make use of the struct_size() helper instead of an open-coded version,
in order to avoid any potential type mistakes or integer overflows that,
in the worst scenario, could lead to heap overflows.

Also, address the following sparse warnings:
drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c:229:24: warning: using sizeof on a flexible structure

Link: https://github.com/KSPP/linux/issues/174
Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
---
 drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

Comments

Ido Schimmel Jan. 26, 2022, 7:54 a.m. UTC | #1
On Tue, Jan 25, 2022 at 11:01:28AM -0600, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version,
> in order to avoid any potential type mistakes or integer overflows that,
> in the worst scenario, could lead to heap overflows.
> 
> Also, address the following sparse warnings:
> drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c:229:24: warning: using sizeof on a flexible structure
> 
> Link: https://github.com/KSPP/linux/issues/174
> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>

Reviewed-by: Ido Schimmel <idosch@nvidia.com>

Thanks
Petr Machata Jan. 26, 2022, 10:55 a.m. UTC | #2
"Gustavo A. R. Silva" <gustavoars@kernel.org> writes:

> Make use of the struct_size() helper instead of an open-coded version,
> in order to avoid any potential type mistakes or integer overflows that,
> in the worst scenario, could lead to heap overflows.
>
> Also, address the following sparse warnings:
> drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c:229:24: warning: using sizeof on a flexible structure
>
> Link: https://github.com/KSPP/linux/issues/174
> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
> ---
>  drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c b/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
> index a9fff8adc75e..d20e794e01ca 100644
> --- a/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
> +++ b/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
> @@ -213,7 +213,6 @@ mlxsw_sp1_kvdl_part_init(struct mlxsw_sp *mlxsw_sp,
>  	struct mlxsw_sp1_kvdl_part *part;
>  	bool need_update = true;
>  	unsigned int nr_entries;
> -	size_t usage_size;
>  	u64 resource_size;
>  	int err;
>  
> @@ -225,8 +224,8 @@ mlxsw_sp1_kvdl_part_init(struct mlxsw_sp *mlxsw_sp,
>  	}
>  
>  	nr_entries = div_u64(resource_size, info->alloc_size);
> -	usage_size = BITS_TO_LONGS(nr_entries) * sizeof(unsigned long);
> -	part = kzalloc(sizeof(*part) + usage_size, GFP_KERNEL);
> +	part = kzalloc(struct_size(part, usage, BITS_TO_LONGS(nr_entries)),
> +		       GFP_KERNEL);
>  	if (!part)
>  		return ERR_PTR(-ENOMEM);

Reviewed-by: Petr Machata <petrm@nvidia.com>
diff mbox series

Patch

diff --git a/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c b/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
index a9fff8adc75e..d20e794e01ca 100644
--- a/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
+++ b/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
@@ -213,7 +213,6 @@  mlxsw_sp1_kvdl_part_init(struct mlxsw_sp *mlxsw_sp,
 	struct mlxsw_sp1_kvdl_part *part;
 	bool need_update = true;
 	unsigned int nr_entries;
-	size_t usage_size;
 	u64 resource_size;
 	int err;
 
@@ -225,8 +224,8 @@  mlxsw_sp1_kvdl_part_init(struct mlxsw_sp *mlxsw_sp,
 	}
 
 	nr_entries = div_u64(resource_size, info->alloc_size);
-	usage_size = BITS_TO_LONGS(nr_entries) * sizeof(unsigned long);
-	part = kzalloc(sizeof(*part) + usage_size, GFP_KERNEL);
+	part = kzalloc(struct_size(part, usage, BITS_TO_LONGS(nr_entries)),
+		       GFP_KERNEL);
 	if (!part)
 		return ERR_PTR(-ENOMEM);