Message ID | 20220125223443.GA76937@embeddedor (mailing list archive) |
---|---|
State | Mainlined |
Commit | 94106f6c21e58900badfeeef5acadf0d6cae7f68 |
Headers | show |
Series | [next] staging: unisys: visorinput: Use struct_size() helper in kzalloc() | expand |
diff --git a/drivers/staging/unisys/visorinput/visorinput.c b/drivers/staging/unisys/visorinput/visorinput.c index 426deab22d62..dffa71ac3cc5 100644 --- a/drivers/staging/unisys/visorinput/visorinput.c +++ b/drivers/staging/unisys/visorinput/visorinput.c @@ -406,7 +406,8 @@ static struct visorinput_devdata *devdata_create(struct visor_device *dev, if (dtype == visorinput_keyboard) /* allocate room for devdata->keycode_table, filled in below */ extra_bytes = KEYCODE_TABLE_BYTES * 2; - devdata = kzalloc(sizeof(*devdata) + extra_bytes, GFP_KERNEL); + devdata = kzalloc(struct_size(devdata, keycode_table, extra_bytes), + GFP_KERNEL); if (!devdata) return NULL; mutex_init(&devdata->lock_visor_dev);
Make use of the struct_size() helper instead of an open-coded version, in order to avoid any potential type mistakes or integer overflows that, in the worst scenario, could lead to heap overflows. Also, address the following sparse warnings: drivers/staging/unisys/visorinput/visorinput.c:409:27: warning: using sizeof on a flexible structure Link: https://github.com/KSPP/linux/issues/174 Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org> --- drivers/staging/unisys/visorinput/visorinput.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-)