diff mbox series

[next] hwspinlock: sprd: Use struct_size() helper in devm_kzalloc()

Message ID 20220125225723.GA78256@embeddedor (mailing list archive)
State Mainlined
Commit 9a41358972eb35e6e45327035a67adfa4a223ed2
Delegated to: Gustavo A. R. Silva
Headers show
Series [next] hwspinlock: sprd: Use struct_size() helper in devm_kzalloc() | expand

Commit Message

Gustavo A. R. Silva Jan. 25, 2022, 10:57 p.m. UTC
Make use of the struct_size() helper instead of an open-coded version,
in order to avoid any potential type mistakes or integer overflows that,
in the worst scenario, could lead to heap overflows.

Also, address the following sparse warnings:
drivers/hwspinlock/sprd_hwspinlock.c:96:36: warning: using sizeof on a flexible structure

Link: https://github.com/KSPP/linux/issues/174
Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
---
 drivers/hwspinlock/sprd_hwspinlock.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Baolin Wang Jan. 26, 2022, 3:31 a.m. UTC | #1
On Wed, Jan 26, 2022 at 6:50 AM Gustavo A. R. Silva
<gustavoars@kernel.org> wrote:
>
> Make use of the struct_size() helper instead of an open-coded version,
> in order to avoid any potential type mistakes or integer overflows that,
> in the worst scenario, could lead to heap overflows.
>
> Also, address the following sparse warnings:
> drivers/hwspinlock/sprd_hwspinlock.c:96:36: warning: using sizeof on a flexible structure
>
> Link: https://github.com/KSPP/linux/issues/174
> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>

LGTM.
Reviewed-by: Baolin Wang <baolin.wang7@gmail.com>

> ---
>  drivers/hwspinlock/sprd_hwspinlock.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/hwspinlock/sprd_hwspinlock.c b/drivers/hwspinlock/sprd_hwspinlock.c
> index d221fc9d756d..22e2ffb91743 100644
> --- a/drivers/hwspinlock/sprd_hwspinlock.c
> +++ b/drivers/hwspinlock/sprd_hwspinlock.c
> @@ -93,8 +93,7 @@ static int sprd_hwspinlock_probe(struct platform_device *pdev)
>                 return -ENODEV;
>
>         sprd_hwlock = devm_kzalloc(&pdev->dev,
> -                                  sizeof(struct sprd_hwspinlock_dev) +
> -                                  SPRD_HWLOCKS_NUM * sizeof(*lock),
> +                                  struct_size(sprd_hwlock, bank.lock, SPRD_HWLOCKS_NUM),
>                                    GFP_KERNEL);
>         if (!sprd_hwlock)
>                 return -ENOMEM;
> --
> 2.27.0
>
diff mbox series

Patch

diff --git a/drivers/hwspinlock/sprd_hwspinlock.c b/drivers/hwspinlock/sprd_hwspinlock.c
index d221fc9d756d..22e2ffb91743 100644
--- a/drivers/hwspinlock/sprd_hwspinlock.c
+++ b/drivers/hwspinlock/sprd_hwspinlock.c
@@ -93,8 +93,7 @@  static int sprd_hwspinlock_probe(struct platform_device *pdev)
 		return -ENODEV;
 
 	sprd_hwlock = devm_kzalloc(&pdev->dev,
-				   sizeof(struct sprd_hwspinlock_dev) +
-				   SPRD_HWLOCKS_NUM * sizeof(*lock),
+				   struct_size(sprd_hwlock, bank.lock, SPRD_HWLOCKS_NUM),
 				   GFP_KERNEL);
 	if (!sprd_hwlock)
 		return -ENOMEM;