Message ID | 20240317164442.6729-1-erick.archer@gmx.com (mailing list archive) |
---|---|
State | Mainlined |
Commit | dfbc411e0a5ea72fdd563b2c7d627e9d993d865c |
Headers | show |
Series | perf/x86/rapl: Prefer struct_size over open coded arithmetic | expand |
On 3/17/24 10:44, Erick Archer wrote: > This is an effort to get rid of all multiplications from allocation > functions in order to prevent integer overflows [1][2]. > > As the "rapl_pmus" variable is a pointer to "struct rapl_pmus" and > this structure ends in a flexible array: > > struct rapl_pmus { > [...] > struct rapl_pmu *pmus[] __counted_by(maxdie); > }; > > the preferred way in the kernel is to use the struct_size() helper to > do the arithmetic instead of the calculation "size + count * size" in > the kzalloc() function. > > This way, the code is more readable and safer. > > Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1] > Link: https://github.com/KSPP/linux/issues/160 [2] > Signed-off-by: Erick Archer <erick.archer@gmx.com> LGTM: Reviewed-by: Gustavo A. R. Silva <gustavoars@kernel.org> Thanks! -- Gustavo > --- > arch/x86/events/rapl.c | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff --git a/arch/x86/events/rapl.c b/arch/x86/events/rapl.c > index fb2b1961e5a3..8ef08b5d55a7 100644 > --- a/arch/x86/events/rapl.c > +++ b/arch/x86/events/rapl.c > @@ -675,10 +675,8 @@ static const struct attribute_group *rapl_attr_update[] = { > static int __init init_rapl_pmus(void) > { > int maxdie = topology_max_packages() * topology_max_dies_per_package(); > - size_t size; > > - size = sizeof(*rapl_pmus) + maxdie * sizeof(struct rapl_pmu *); > - rapl_pmus = kzalloc(size, GFP_KERNEL); > + rapl_pmus = kzalloc(struct_size(rapl_pmus, pmus, maxdie), GFP_KERNEL); > if (!rapl_pmus) > return -ENOMEM; > > -- > 2.25.1 > >
On Sun, Mar 17, 2024 at 05:44:42PM +0100, Erick Archer wrote: > This is an effort to get rid of all multiplications from allocation > functions in order to prevent integer overflows [1][2]. > > As the "rapl_pmus" variable is a pointer to "struct rapl_pmus" and > this structure ends in a flexible array: > > struct rapl_pmus { > [...] > struct rapl_pmu *pmus[] __counted_by(maxdie); > }; > > the preferred way in the kernel is to use the struct_size() helper to > do the arithmetic instead of the calculation "size + count * size" in > the kzalloc() function. > > This way, the code is more readable and safer. > > Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1] > Link: https://github.com/KSPP/linux/issues/160 [2] > Signed-off-by: Erick Archer <erick.archer@gmx.com> Thanks! Reviewed-by: Kees Cook <keescook@chromium.org> I was inspired to come up with a Coccinelle script to find this pattern. This seems to do it, though it also removes the blank line. I'm not sure how to stop it from doing that. I'm running this treewide to see if I can find others... // Options: --no-includes --include-headers @allocation@ type SIZE_TYPE; identifier SIZE; type PTR_TYPE; PTR_TYPE *PTR; identifier ALLOC =~ "kmalloc|kzalloc|kmalloc_node|kzalloc_node|vmalloc|vzalloc|kvmalloc|kvzalloc"; @@ SIZE_TYPE SIZE; ... PTR = ALLOC(..., SIZE, ...) @structure@ type allocation.PTR_TYPE; type FLEX_TYPE; identifier FLEX; @@ PTR_TYPE { ... FLEX_TYPE FLEX[]; ... }; @single_shot_sizing@ type allocation.SIZE_TYPE; identifier allocation.SIZE; type allocation.PTR_TYPE; PTR_TYPE *allocation.PTR; identifier allocation.ALLOC; type structure.FLEX_TYPE; identifier structure.FLEX; expression COUNT; @@ - SIZE_TYPE SIZE; ... when != SIZE - SIZE = (\(sizeof(*PTR)\|sizeof(PTR_TYPE)\) + ((COUNT) * \(sizeof(*PTR->FLEX)\|sizeof(PTR->FLEX[0])\|sizeof(FLEX_TYPE)\))); ... when != SIZE PTR = ALLOC(..., - SIZE + struct_size(PTR, FLEX, COUNT) , ...) ... when != SIZE @reused_sizing@ type allocation.SIZE_TYPE; identifier allocation.SIZE; type allocation.PTR_TYPE; PTR_TYPE *allocation.PTR; identifier allocation.ALLOC; type structure.FLEX_TYPE; identifier structure.FLEX; expression COUNT; @@ SIZE_TYPE SIZE; ... SIZE = - (\(sizeof(*PTR)\|sizeof(PTR_TYPE)\) + ((COUNT) * \(sizeof(*PTR->FLEX)\|sizeof(PTR->FLEX[0])\|sizeof(FLEX_TYPE)\))) + struct_size(PTR, FLEX, COUNT) ; ... when != SIZE PTR = ALLOC(..., SIZE , ...)
On 18/03/24 17:40, Kees Cook wrote: > On Sun, Mar 17, 2024 at 05:44:42PM +0100, Erick Archer wrote: >> This is an effort to get rid of all multiplications from allocation >> functions in order to prevent integer overflows [1][2]. >> >> As the "rapl_pmus" variable is a pointer to "struct rapl_pmus" and >> this structure ends in a flexible array: >> >> struct rapl_pmus { >> [...] >> struct rapl_pmu *pmus[] __counted_by(maxdie); >> }; >> >> the preferred way in the kernel is to use the struct_size() helper to >> do the arithmetic instead of the calculation "size + count * size" in >> the kzalloc() function. >> >> This way, the code is more readable and safer. >> >> Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1] >> Link: https://github.com/KSPP/linux/issues/160 [2] >> Signed-off-by: Erick Archer <erick.archer@gmx.com> > > Thanks! > > Reviewed-by: Kees Cook <keescook@chromium.org> > > I was inspired to come up with a Coccinelle script to find this pattern. > This seems to do it, though it also removes the blank line. I'm not sure > how to stop it from doing that. I'm running this treewide to see if I > can find others... > > // Options: --no-includes --include-headers with --no-includes this one is missed in arch/x86/events/: diff --git a/arch/x86/events/intel/uncore.c b/arch/x86/events/intel/uncore.c index 258e2cdf28fa..213fe48f9391 100644 --- a/arch/x86/events/intel/uncore.c +++ b/arch/x86/events/intel/uncore.c @@ -350,12 +350,11 @@ static void uncore_pmu_init_hrtimer(struct intel_uncore_box *box) static struct intel_uncore_box *uncore_alloc_box(struct intel_uncore_type *type, int node) { - int i, size, numshared = type->num_shared_regs ; + int i, numshared = type->num_shared_regs ; struct intel_uncore_box *box; - size = sizeof(*box) + numshared * sizeof(struct intel_uncore_extra_reg); - - box = kzalloc_node(size, GFP_KERNEL, node); + box = kzalloc_node(struct_size(box, shared_regs, numshared), + GFP_KERNEL, node); if (!box) return NULL; Funny thing is that in this case it's quite convenient that the script removes the blank like. :P -- Gustavo
diff --git a/arch/x86/events/rapl.c b/arch/x86/events/rapl.c index fb2b1961e5a3..8ef08b5d55a7 100644 --- a/arch/x86/events/rapl.c +++ b/arch/x86/events/rapl.c @@ -675,10 +675,8 @@ static const struct attribute_group *rapl_attr_update[] = { static int __init init_rapl_pmus(void) { int maxdie = topology_max_packages() * topology_max_dies_per_package(); - size_t size; - size = sizeof(*rapl_pmus) + maxdie * sizeof(struct rapl_pmu *); - rapl_pmus = kzalloc(size, GFP_KERNEL); + rapl_pmus = kzalloc(struct_size(rapl_pmus, pmus, maxdie), GFP_KERNEL); if (!rapl_pmus) return -ENOMEM;
This is an effort to get rid of all multiplications from allocation functions in order to prevent integer overflows [1][2]. As the "rapl_pmus" variable is a pointer to "struct rapl_pmus" and this structure ends in a flexible array: struct rapl_pmus { [...] struct rapl_pmu *pmus[] __counted_by(maxdie); }; the preferred way in the kernel is to use the struct_size() helper to do the arithmetic instead of the calculation "size + count * size" in the kzalloc() function. This way, the code is more readable and safer. Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1] Link: https://github.com/KSPP/linux/issues/160 [2] Signed-off-by: Erick Archer <erick.archer@gmx.com> --- arch/x86/events/rapl.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) -- 2.25.1