mbox series

[00/17] hwmon: Use HWMON_CHANNEL_INFO macro

Message ID 1554135577-11889-1-git-send-email-linux@roeck-us.net (mailing list archive)
Headers show
Series hwmon: Use HWMON_CHANNEL_INFO macro | expand

Message

Guenter Roeck April 1, 2019, 4:19 p.m. UTC
The HWMON_CHANNEL_INFO macro simplifies the code, reduces the likelihood
of errors, and makes the code easier to read. This series converts all
hwmon drivers to use the macro if possible.

The conversion is done automatically with coccinelle. The semantic patch
used to make this change is as follows.

@r@
initializer list elements;
identifier i;
@@

-u32 i[] = {
-  elements,
-  0
-};

@s@
identifier r.i,j,ty;
@@

-struct hwmon_channel_info j = {
-       .type = ty,
-       .config = i,
-};

@script:ocaml t@
ty << s.ty;
elements << r.elements;
shorter;
elems;
@@

shorter :=
   make_ident (List.hd(List.rev (Str.split (Str.regexp "_") ty)));
elems :=
   make_ident
    (String.concat ","
     (List.map (fun x -> Printf.sprintf "\n\t\t\t   %s" x)
       (Str.split (Str.regexp " , ") elements)))

@@
identifier s.j,t.shorter;
identifier t.elems;
@@

- &j
+ HWMON_CHANNEL_INFO(shorter,elems)

The conversion does not introduce functional changes.

Many thanks to Julia Lawall for providing the semantic patch.