diff mbox series

net: phy: tja11xx: Switch to HWMON_CHANNEL_INFO()

Message ID 20190528181541.1946-1-marex@denx.de (mailing list archive)
State Not Applicable
Headers show
Series net: phy: tja11xx: Switch to HWMON_CHANNEL_INFO() | expand

Commit Message

Marek Vasut May 28, 2019, 6:15 p.m. UTC
The HWMON_CHANNEL_INFO macro simplifies the code, reduces the likelihood
of errors, and makes the code easier to read.

Signed-off-by: Marek Vasut <marex@denx.de>
Cc: Andrew Lunn <andrew@lunn.ch>
Cc: Florian Fainelli <f.fainelli@gmail.com>
Cc: Guenter Roeck <linux@roeck-us.net>
Cc: Heiner Kallweit <hkallweit1@gmail.com>
Cc: Jean Delvare <jdelvare@suse.com>
Cc: linux-hwmon@vger.kernel.org
---
 drivers/net/phy/nxp-tja11xx.c | 24 ++----------------------
 1 file changed, 2 insertions(+), 22 deletions(-)

Comments

Guenter Roeck May 28, 2019, 7:48 p.m. UTC | #1
On Tue, May 28, 2019 at 08:15:41PM +0200, Marek Vasut wrote:
> The HWMON_CHANNEL_INFO macro simplifies the code, reduces the likelihood
> of errors, and makes the code easier to read.
> 
> Signed-off-by: Marek Vasut <marex@denx.de>
> Cc: Andrew Lunn <andrew@lunn.ch>
> Cc: Florian Fainelli <f.fainelli@gmail.com>
> Cc: Guenter Roeck <linux@roeck-us.net>

Reviewed-by: Guenter Roeck <linux@roeck-us.net>

> Cc: Heiner Kallweit <hkallweit1@gmail.com>
> Cc: Jean Delvare <jdelvare@suse.com>
> Cc: linux-hwmon@vger.kernel.org
> ---
>  drivers/net/phy/nxp-tja11xx.c | 24 ++----------------------
>  1 file changed, 2 insertions(+), 22 deletions(-)
> 
> diff --git a/drivers/net/phy/nxp-tja11xx.c b/drivers/net/phy/nxp-tja11xx.c
> index 11b8701e78fd..b705d0bd798b 100644
> --- a/drivers/net/phy/nxp-tja11xx.c
> +++ b/drivers/net/phy/nxp-tja11xx.c
> @@ -311,29 +311,9 @@ static umode_t tja11xx_hwmon_is_visible(const void *data,
>  	return 0;
>  }
>  
> -static u32 tja11xx_hwmon_in_config[] = {
> -	HWMON_I_LCRIT_ALARM,
> -	0
> -};
> -
> -static const struct hwmon_channel_info tja11xx_hwmon_in = {
> -	.type		= hwmon_in,
> -	.config		= tja11xx_hwmon_in_config,
> -};
> -
> -static u32 tja11xx_hwmon_temp_config[] = {
> -	HWMON_T_CRIT_ALARM,
> -	0
> -};
> -
> -static const struct hwmon_channel_info tja11xx_hwmon_temp = {
> -	.type		= hwmon_temp,
> -	.config		= tja11xx_hwmon_temp_config,
> -};
> -
>  static const struct hwmon_channel_info *tja11xx_hwmon_info[] = {
> -	&tja11xx_hwmon_in,
> -	&tja11xx_hwmon_temp,
> +	HWMON_CHANNEL_INFO(in, HWMON_I_LCRIT_ALARM),
> +	HWMON_CHANNEL_INFO(temp, HWMON_T_CRIT_ALARM),
>  	NULL
>  };
>  
> -- 
> 2.20.1
>
David Miller May 30, 2019, 5:03 a.m. UTC | #2
From: Marek Vasut <marex@denx.de>
Date: Tue, 28 May 2019 20:15:41 +0200

> The HWMON_CHANNEL_INFO macro simplifies the code, reduces the likelihood
> of errors, and makes the code easier to read.
> 
> Signed-off-by: Marek Vasut <marex@denx.de>

Applied to net-next.
diff mbox series

Patch

diff --git a/drivers/net/phy/nxp-tja11xx.c b/drivers/net/phy/nxp-tja11xx.c
index 11b8701e78fd..b705d0bd798b 100644
--- a/drivers/net/phy/nxp-tja11xx.c
+++ b/drivers/net/phy/nxp-tja11xx.c
@@ -311,29 +311,9 @@  static umode_t tja11xx_hwmon_is_visible(const void *data,
 	return 0;
 }
 
-static u32 tja11xx_hwmon_in_config[] = {
-	HWMON_I_LCRIT_ALARM,
-	0
-};
-
-static const struct hwmon_channel_info tja11xx_hwmon_in = {
-	.type		= hwmon_in,
-	.config		= tja11xx_hwmon_in_config,
-};
-
-static u32 tja11xx_hwmon_temp_config[] = {
-	HWMON_T_CRIT_ALARM,
-	0
-};
-
-static const struct hwmon_channel_info tja11xx_hwmon_temp = {
-	.type		= hwmon_temp,
-	.config		= tja11xx_hwmon_temp_config,
-};
-
 static const struct hwmon_channel_info *tja11xx_hwmon_info[] = {
-	&tja11xx_hwmon_in,
-	&tja11xx_hwmon_temp,
+	HWMON_CHANNEL_INFO(in, HWMON_I_LCRIT_ALARM),
+	HWMON_CHANNEL_INFO(temp, HWMON_T_CRIT_ALARM),
 	NULL
 };