diff mbox series

[5/7] hwmon: (peci/dimmtemp) Use HWMON_CHANNEL_INFO macro

Message ID 20220512195556.137741-5-linux@roeck-us.net (mailing list archive)
State Accepted
Headers show
Series [1/7] hwmon: (as370-hwmon) Use HWMON_CHANNEL_INFO macro | expand

Commit Message

Guenter Roeck May 12, 2022, 7:55 p.m. UTC
The HWMON_CHANNEL_INFO macro simplifies the code, reduces the likelihood
of errors, and makes the code easier to read.

The conversion was done automatically with coccinelle. The semantic patch
used to make this change is as follows.

@s@
identifier i,j,ty;
@@

-struct hwmon_channel_info j = {
-       .type = ty,
-       .config = i,
-};

@r@
initializer list elements;
identifier s.i;
@@

-u32 i[] = {
-  elements,
-  0
-};

@script:ocaml t@
ty << s.ty;
elements << r.elements;
shorter;
elems;
@@

shorter :=
   make_ident (List.hd(List.rev (Str.split (Str.regexp "_") ty)));
elems :=
   make_ident
    (String.concat ","
     (List.map (fun x -> Printf.sprintf "\n\t\t\t   %s" x)
       (Str.split (Str.regexp " , ") elements)))

@@
identifier s.j,t.shorter;
identifier t.elems;
@@

- &j
+ HWMON_CHANNEL_INFO(shorter,elems)

This patch does not introduce functional changes. Many thanks to
Julia Lawall for providing the coccinelle script.

Cc: Iwona Winiarska <iwona.winiarska@intel.com>
Signed-off-by: Guenter Roeck <linux@roeck-us.net>
---
 drivers/hwmon/peci/dimmtemp.c | 14 +++-----------
 1 file changed, 3 insertions(+), 11 deletions(-)

Comments

Winiarska, Iwona May 13, 2022, 8:24 p.m. UTC | #1
On Thu, 2022-05-12 at 12:55 -0700, Guenter Roeck wrote:
> The HWMON_CHANNEL_INFO macro simplifies the code, reduces the likelihood
> of errors, and makes the code easier to read.
> 
> The conversion was done automatically with coccinelle. The semantic patch
> used to make this change is as follows.
> 
> @s@
> identifier i,j,ty;
> @@
> 
> -struct hwmon_channel_info j = {
> -       .type = ty,
> -       .config = i,
> -};
> 
> @r@
> initializer list elements;
> identifier s.i;
> @@
> 
> -u32 i[] = {
> -  elements,
> -  0
> -};
> 
> @script:ocaml t@
> ty << s.ty;
> elements << r.elements;
> shorter;
> elems;
> @@
> 
> shorter :=
>    make_ident (List.hd(List.rev (Str.split (Str.regexp "_") ty)));
> elems :=
>    make_ident
>     (String.concat ","
>      (List.map (fun x -> Printf.sprintf "\n\t\t\t   %s" x)
>        (Str.split (Str.regexp " , ") elements)))
> 
> @@
> identifier s.j,t.shorter;
> identifier t.elems;
> @@
> 
> - &j
> + HWMON_CHANNEL_INFO(shorter,elems)
> 
> This patch does not introduce functional changes. Many thanks to
> Julia Lawall for providing the coccinelle script.
> 
> Cc: Iwona Winiarska <iwona.winiarska@intel.com>
> Signed-off-by: Guenter Roeck <linux@roeck-us.net>

Reviewed-by: Iwona Winiarska <iwona.winiarska@intel.com>

Thanks
-Iwona

> ---
>  drivers/hwmon/peci/dimmtemp.c | 14 +++-----------
>  1 file changed, 3 insertions(+), 11 deletions(-)
>
diff mbox series

Patch

diff --git a/drivers/hwmon/peci/dimmtemp.c b/drivers/hwmon/peci/dimmtemp.c
index 96b9919db357..3c71b5546bcb 100644
--- a/drivers/hwmon/peci/dimmtemp.c
+++ b/drivers/hwmon/peci/dimmtemp.c
@@ -300,18 +300,10 @@  static int create_dimm_temp_label(struct peci_dimmtemp *priv, int chan)
 	return 0;
 }
 
-static const u32 peci_dimmtemp_temp_channel_config[] = {
-	[0 ... DIMM_NUMS_MAX - 1] = HWMON_T_LABEL | HWMON_T_INPUT | HWMON_T_MAX | HWMON_T_CRIT,
-	0
-};
-
-static const struct hwmon_channel_info peci_dimmtemp_temp_channel = {
-	.type = hwmon_temp,
-	.config = peci_dimmtemp_temp_channel_config,
-};
-
 static const struct hwmon_channel_info *peci_dimmtemp_temp_info[] = {
-	&peci_dimmtemp_temp_channel,
+	HWMON_CHANNEL_INFO(temp,
+			   [0 ... DIMM_NUMS_MAX - 1] = HWMON_T_LABEL |
+				HWMON_T_INPUT | HWMON_T_MAX | HWMON_T_CRIT),
 	NULL
 };