mbox series

[v5,0/4] iio: imu: fxos8700: fix bugs about ODR and changes for a good readability

Message ID 20230118074227.1665098-1-carlos.song@nxp.com (mailing list archive)
Headers show
Series iio: imu: fxos8700: fix bugs about ODR and changes for a good readability | expand

Message

Carlos Song Jan. 18, 2023, 7:42 a.m. UTC
From: Carlos Song <carlos.song@nxp.com>

Hi, Jonathan. Thank you for the suggestion. In patch 1, I use
regmap_write to modify the value of the register. And in patch 2,
I use regmap_update_bits instead of regmap_get and regmap_write
for a good readability. Other patches have not been changed.

Carlos Song (4):
  iio: imu: fxos8700: fix incorrect ODR mode readback
  iio: imu: fxos8700: fix failed initialization ODR mode assignment
  iio: imu: fxos8700: remove definition FXOS8700_CTRL_ODR_MIN
  iio: imu: fxos8700: fix MAGN sensor scale and unit

 drivers/iio/imu/fxos8700_core.c | 25 +++++++++++++------------
 1 file changed, 13 insertions(+), 12 deletions(-)

Comments

Jonathan Cameron Jan. 21, 2023, 6:15 p.m. UTC | #1
On Wed, 18 Jan 2023 15:42:23 +0800
carlos.song@nxp.com wrote:

> From: Carlos Song <carlos.song@nxp.com>
> 
> Hi, Jonathan. Thank you for the suggestion. In patch 1, I use
> regmap_write to modify the value of the register. And in patch 2,
> I use regmap_update_bits instead of regmap_get and regmap_write
> for a good readability. Other patches have not been changed.
> 
> Carlos Song (4):
>   iio: imu: fxos8700: fix incorrect ODR mode readback
>   iio: imu: fxos8700: fix failed initialization ODR mode assignment
>   iio: imu: fxos8700: remove definition FXOS8700_CTRL_ODR_MIN
>   iio: imu: fxos8700: fix MAGN sensor scale and unit
> 
>  drivers/iio/imu/fxos8700_core.c | 25 +++++++++++++------------
>  1 file changed, 13 insertions(+), 12 deletions(-)
> 

Series applied to the fixes-togreg branch of iio.git and marked
for stable inclusion.

Thanks,

Jonathan