Message ID | 20240712-iio-regulator-refactor-round-3-v1-0-835017bae43d@baylibre.com (mailing list archive) |
---|---|
Headers | show |
Series | iio: use devm_regulator_get_enable_read_voltage round 3 | expand |
On Fri, 12 Jul 2024 11:03:51 -0500 David Lechner <dlechner@baylibre.com> wrote: > This is the third round of patches to convert IIO drivers to use the > new devm_regulator_get_enable_read_voltage() helper function. > > This time, we are converting some Microchip drivers. These weren't as > trivial as some other drivers because of nested functions that need > to know info about the reference voltage, but for the most part, should > be fairly straightforward. And there is a bonus to remove a remove() > callback in one of the drivers. Applied 1-4 and 6. Comment outstanding on 5 so I'm assuming I'll see a v2 of just that patch at somepoint. Thanks, Jonathan > > --- > David Lechner (6): > iio: dac: mcp4728: rename err to ret in probe function > iio: dac: mcp4728: use devm_regulator_get_enable_read_voltage() > iio: dac: mcp4922: use devm_regulator_get_enable_read_voltage() > iio: dac: mcp4922: drop remove() callback > iio: adc: mcp3564: use devm_regulator_get_enable_read_voltage() > iio: adc: mcp3911: use devm_regulator_get_enable_read_voltage() > > drivers/iio/adc/mcp3564.c | 54 +++++++++++++------------------------------ > drivers/iio/adc/mcp3911.c | 59 +++++++++++++---------------------------------- > drivers/iio/dac/mcp4728.c | 45 +++++++++++------------------------- > drivers/iio/dac/mcp4922.c | 47 ++++++------------------------------- > 4 files changed, 52 insertions(+), 153 deletions(-) > --- > base-commit: 986da024b99a72e64f6bdb3f3f0e52af024b1f50 > change-id: 20240712-iio-regulator-refactor-round-3-17f2a82d2181