mbox series

[0/2] iio: imu: inv_icm42600: switch to use generic name irq get

Message ID 20250404-iio-imu-inv-icm42600-rework-interrupt-using-names-v1-0-72ed5100da14@tdk.com (mailing list archive)
Headers show
Series iio: imu: inv_icm42600: switch to use generic name irq get | expand

Message

Jean-Baptiste Maneyrol April 4, 2025, 3:52 p.m. UTC
The purpose of this series is to switch to fwnode_irq_get_by_name()
in the core module instead of using irq from the bus parsing.
Add interrupt naming and support only INT1.

Signed-off-by: Jean-Baptiste Maneyrol <jean-baptiste.maneyrol@tdk.com>
---
Jean-Baptiste Maneyrol (2):
      dt-bindings: iio: imu: icm42600: add interrupt naming support
      iio: imu: inv_icm42600: switch to use generic name irq get

 .../devicetree/bindings/iio/imu/invensense,icm42600.yaml    |  8 ++++++++
 drivers/iio/imu/inv_icm42600/inv_icm42600.h                 |  2 +-
 drivers/iio/imu/inv_icm42600/inv_icm42600_core.c            | 13 +++++++++++--
 drivers/iio/imu/inv_icm42600/inv_icm42600_i2c.c             |  2 +-
 drivers/iio/imu/inv_icm42600/inv_icm42600_spi.c             |  2 +-
 5 files changed, 22 insertions(+), 5 deletions(-)
---
base-commit: f8ffc92ae9052e6615896052f0c5b808bfc17520
change-id: 20250325-iio-imu-inv-icm42600-rework-interrupt-using-names-b397ced72835

Best regards,