diff mbox series

iio: sc27xx_adc: Use DIV_ROUND_CLOSEST() instead of open-coding it

Message ID 20201222191618.3433-1-lars@metafoo.de (mailing list archive)
State New, archived
Headers show
Series iio: sc27xx_adc: Use DIV_ROUND_CLOSEST() instead of open-coding it | expand

Commit Message

Lars-Peter Clausen Dec. 22, 2020, 7:16 p.m. UTC
Use DIV_ROUND_CLOSEST() instead of open-coding it. This makes it more clear
what is going on for the casual reviewer.

Generated using the following the Coccinelle semantic patch.

// <smpl>
@@
expression x, y;
@@
-((x) + ((y) / 2)) / (y)
+DIV_ROUND_CLOSEST(x, y)
// </smpl>

Signed-off-by: Lars-Peter Clausen <lars@metafoo.de>
---
 drivers/iio/adc/sc27xx_adc.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Chunyan Zhang Dec. 23, 2020, 5:39 a.m. UTC | #1
On Wed, 23 Dec 2020 at 03:16, Lars-Peter Clausen <lars@metafoo.de> wrote:
>
> Use DIV_ROUND_CLOSEST() instead of open-coding it. This makes it more clear
> what is going on for the casual reviewer.
>
> Generated using the following the Coccinelle semantic patch.
>
> // <smpl>
> @@
> expression x, y;
> @@
> -((x) + ((y) / 2)) / (y)
> +DIV_ROUND_CLOSEST(x, y)
> // </smpl>
>
> Signed-off-by: Lars-Peter Clausen <lars@metafoo.de>

Acked-by: Chunyan Zhang <zhang.lyra@gmail.com>

Thanks,
Chunyan

> ---
>  drivers/iio/adc/sc27xx_adc.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/iio/adc/sc27xx_adc.c b/drivers/iio/adc/sc27xx_adc.c
> index aa32a1f385e2..301cf66de695 100644
> --- a/drivers/iio/adc/sc27xx_adc.c
> +++ b/drivers/iio/adc/sc27xx_adc.c
> @@ -307,7 +307,7 @@ static int sc27xx_adc_convert_volt(struct sc27xx_adc_data *data, int channel,
>
>         sc27xx_adc_volt_ratio(data, channel, scale, &numerator, &denominator);
>
> -       return (volt * denominator + numerator / 2) / numerator;
> +       return DIV_ROUND_CLOSEST(volt * denominator, numerator);
>  }
>
>  static int sc27xx_adc_read_processed(struct sc27xx_adc_data *data,
> --
> 2.20.1
>
Jonathan Cameron Dec. 29, 2020, 2:28 p.m. UTC | #2
On Wed, 23 Dec 2020 13:39:24 +0800
Chunyan Zhang <zhang.lyra@gmail.com> wrote:

> On Wed, 23 Dec 2020 at 03:16, Lars-Peter Clausen <lars@metafoo.de> wrote:
> >
> > Use DIV_ROUND_CLOSEST() instead of open-coding it. This makes it more clear
> > what is going on for the casual reviewer.
> >
> > Generated using the following the Coccinelle semantic patch.
> >
> > // <smpl>
> > @@
> > expression x, y;
> > @@
> > -((x) + ((y) / 2)) / (y)
> > +DIV_ROUND_CLOSEST(x, y)
> > // </smpl>
> >
> > Signed-off-by: Lars-Peter Clausen <lars@metafoo.de>  
> 
> Acked-by: Chunyan Zhang <zhang.lyra@gmail.com>
Applied to the togreg branch of iio.git and pushed out as testing.

Thanks,

Jonathan

> 
> Thanks,
> Chunyan
> 
> > ---
> >  drivers/iio/adc/sc27xx_adc.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/drivers/iio/adc/sc27xx_adc.c b/drivers/iio/adc/sc27xx_adc.c
> > index aa32a1f385e2..301cf66de695 100644
> > --- a/drivers/iio/adc/sc27xx_adc.c
> > +++ b/drivers/iio/adc/sc27xx_adc.c
> > @@ -307,7 +307,7 @@ static int sc27xx_adc_convert_volt(struct sc27xx_adc_data *data, int channel,
> >
> >         sc27xx_adc_volt_ratio(data, channel, scale, &numerator, &denominator);
> >
> > -       return (volt * denominator + numerator / 2) / numerator;
> > +       return DIV_ROUND_CLOSEST(volt * denominator, numerator);
> >  }
> >
> >  static int sc27xx_adc_read_processed(struct sc27xx_adc_data *data,
> > --
> > 2.20.1
> >
diff mbox series

Patch

diff --git a/drivers/iio/adc/sc27xx_adc.c b/drivers/iio/adc/sc27xx_adc.c
index aa32a1f385e2..301cf66de695 100644
--- a/drivers/iio/adc/sc27xx_adc.c
+++ b/drivers/iio/adc/sc27xx_adc.c
@@ -307,7 +307,7 @@  static int sc27xx_adc_convert_volt(struct sc27xx_adc_data *data, int channel,
 
 	sc27xx_adc_volt_ratio(data, channel, scale, &numerator, &denominator);
 
-	return (volt * denominator + numerator / 2) / numerator;
+	return DIV_ROUND_CLOSEST(volt * denominator, numerator);
 }
 
 static int sc27xx_adc_read_processed(struct sc27xx_adc_data *data,