diff mbox series

[v2,2/7] iio: imu: fxos8700: fix swapped ACCEL and MAGN channels readback

Message ID 20221208071911.2405922-3-carlos.song@nxp.com (mailing list archive)
State Accepted
Headers show
Series iio: imu: fxos8700: fix few bugs in data readback and mode set | expand

Commit Message

Carlos Song Dec. 8, 2022, 7:19 a.m. UTC
From: Carlos Song <carlos.song@nxp.com>

Because ACCEL and MAGN channels data register base address is
swapped by error judgement, accelerometer and magnetometer
channels readback is swapped.

Fix swapped accelerometer and magnetometer channels readback.

Fixes: 84e5ddd5c46e ("iio: imu: Add support for the FXOS8700 IMU")
Signed-off-by: Carlos Song <carlos.song@nxp.com>
---
Changes for V2:
- Use a switch statement to instead of an enum to index the base
  address of the register by the channel type
- Rework commit log and comments

Comments

Jonathan Cameron Dec. 11, 2022, 1:43 p.m. UTC | #1
On Thu,  8 Dec 2022 15:19:06 +0800
carlos.song@nxp.com wrote:

> From: Carlos Song <carlos.song@nxp.com>
> 
> Because ACCEL and MAGN channels data register base address is
> swapped by error judgement, accelerometer and magnetometer
> channels readback is swapped.
> 
> Fix swapped accelerometer and magnetometer channels readback.
> 
> Fixes: 84e5ddd5c46e ("iio: imu: Add support for the FXOS8700 IMU")
> Signed-off-by: Carlos Song <carlos.song@nxp.com>
Applied to the fixes-togreg branch of iio.git and marked
for stable.

I tweaked the description a little for readability.

Thanks,

Jonathan

> ---
> Changes for V2:
> - Use a switch statement to instead of an enum to index the base
>   address of the register by the channel type
> - Rework commit log and comments
> 
> diff --git a/drivers/iio/imu/fxos8700_core.c b/drivers/iio/imu/fxos8700_core.c
> index 235b02b2f4e5..977eb7dc7dbd 100644
> --- a/drivers/iio/imu/fxos8700_core.c
> +++ b/drivers/iio/imu/fxos8700_core.c
> @@ -395,9 +395,22 @@ static int fxos8700_get_data(struct fxos8700_data *data, int chan_type,
>  {
>  	u8 base, reg;
>  	int ret;
> -	enum fxos8700_sensor type = fxos8700_to_sensor(chan_type);
>  
> -	base = type ? FXOS8700_OUT_X_MSB : FXOS8700_M_OUT_X_MSB;
> +	/*
> +	 * Different register base addresses varies with channel types.
> +	 * This bug hasn't been noticed before because using an enum is
> +	 * really hard to read. Use an a switch statement to take over that.
> +	 */
> +	switch (chan_type) {
> +	case IIO_ACCEL:
> +		base = FXOS8700_OUT_X_MSB;
> +		break;
> +	case IIO_MAGN:
> +		base = FXOS8700_M_OUT_X_MSB;
> +		break;
> +	default:
> +		return -EINVAL;
> +	}
>  
>  	/* Block read 6 bytes of device output registers to avoid data loss */
>  	ret = regmap_bulk_read(data->regmap, base, data->buf,
diff mbox series

Patch

diff --git a/drivers/iio/imu/fxos8700_core.c b/drivers/iio/imu/fxos8700_core.c
index 235b02b2f4e5..977eb7dc7dbd 100644
--- a/drivers/iio/imu/fxos8700_core.c
+++ b/drivers/iio/imu/fxos8700_core.c
@@ -395,9 +395,22 @@  static int fxos8700_get_data(struct fxos8700_data *data, int chan_type,
 {
 	u8 base, reg;
 	int ret;
-	enum fxos8700_sensor type = fxos8700_to_sensor(chan_type);
 
-	base = type ? FXOS8700_OUT_X_MSB : FXOS8700_M_OUT_X_MSB;
+	/*
+	 * Different register base addresses varies with channel types.
+	 * This bug hasn't been noticed before because using an enum is
+	 * really hard to read. Use an a switch statement to take over that.
+	 */
+	switch (chan_type) {
+	case IIO_ACCEL:
+		base = FXOS8700_OUT_X_MSB;
+		break;
+	case IIO_MAGN:
+		base = FXOS8700_M_OUT_X_MSB;
+		break;
+	default:
+		return -EINVAL;
+	}
 
 	/* Block read 6 bytes of device output registers to avoid data loss */
 	ret = regmap_bulk_read(data->regmap, base, data->buf,