diff mbox series

[02/15] iio: accel: fxls8962af: use irq_get_trigger_type()

Message ID 20240901135950.797396-3-jic23@kernel.org (mailing list archive)
State Accepted
Headers show
Series IIO: use irq_get_trigger_type() instead of opencoding. | expand

Commit Message

Jonathan Cameron Sept. 1, 2024, 1:59 p.m. UTC
From: Jonathan Cameron <Jonathan.Cameron@huawei.com>

Use irq_get_trigger_type() to replace getting the irq data then the
type in two steps.

Signed-off-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
---
 drivers/iio/accel/fxls8962af-core.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Sean Nyekjaer Sept. 2, 2024, 9:20 a.m. UTC | #1
On Sun, Sep 01, 2024 at 02:59:37PM UTC, Jonathan Cameron wrote:
> From: Jonathan Cameron <Jonathan.Cameron@huawei.com>
> 
> Use irq_get_trigger_type() to replace getting the irq data then the
> type in two steps.
> 
> Signed-off-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>

Reviewed-by: Sean Nyekjaer <sean@geanix.com>
Andy Shevchenko Sept. 2, 2024, 11:41 a.m. UTC | #2
On Sun, Sep 01, 2024 at 02:59:37PM +0100, Jonathan Cameron wrote:
> From: Jonathan Cameron <Jonathan.Cameron@huawei.com>
> 
> Use irq_get_trigger_type() to replace getting the irq data then the
> type in two steps.

...

> -	irq_type = irqd_get_trigger_type(irq_get_irq_data(irq));
> +	irq_type = irq_get_trigger_type(irq);

>  

While at it, I would drop this blank line as well. Because the next line is
quite coupled with the previous one.

>  	switch (irq_type) {
diff mbox series

Patch

diff --git a/drivers/iio/accel/fxls8962af-core.c b/drivers/iio/accel/fxls8962af-core.c
index acadabec4df7..a50c47f5179f 100644
--- a/drivers/iio/accel/fxls8962af-core.c
+++ b/drivers/iio/accel/fxls8962af-core.c
@@ -1103,7 +1103,7 @@  static int fxls8962af_irq_setup(struct iio_dev *indio_dev, int irq)
 	if (ret)
 		return ret;
 
-	irq_type = irqd_get_trigger_type(irq_get_irq_data(irq));
+	irq_type = irq_get_trigger_type(irq);
 
 	switch (irq_type) {
 	case IRQF_TRIGGER_HIGH: