diff mbox

[16/19] mfd / input: ti_am335x_tsc: rename device from tsc to TI-tsc

Message ID 1369681926-22185-17-git-send-email-bigeasy@linutronix.de (mailing list archive)
State New, archived
Headers show

Commit Message

Sebastian Andrzej Siewior May 27, 2013, 7:12 p.m. UTC
tsc is a very generic name. This patch adds a TI prefix to make it a
little less generic.
While here add an alias so the driver is loaded on demand.

Signed-off-by: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
---
 drivers/input/touchscreen/ti_am335x_tsc.c |    3 ++-
 drivers/mfd/ti_am335x_tscadc.c            |    2 +-
 2 files changed, 3 insertions(+), 2 deletions(-)

Comments

Dmitry Torokhov June 4, 2013, 4:50 p.m. UTC | #1
On Mon, May 27, 2013 at 09:12:03PM +0200, Sebastian Andrzej Siewior wrote:
> tsc is a very generic name. This patch adds a TI prefix to make it a
> little less generic.
> While here add an alias so the driver is loaded on demand.
> 
> Signed-off-by: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
> ---
>  drivers/input/touchscreen/ti_am335x_tsc.c |    3 ++-
>  drivers/mfd/ti_am335x_tscadc.c            |    2 +-
>  2 files changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/input/touchscreen/ti_am335x_tsc.c b/drivers/input/touchscreen/ti_am335x_tsc.c
> index 96accaa..2921163 100644
> --- a/drivers/input/touchscreen/ti_am335x_tsc.c
> +++ b/drivers/input/touchscreen/ti_am335x_tsc.c
> @@ -543,11 +543,12 @@ static struct platform_driver ti_tsc_driver = {
>  	.probe	= titsc_probe,
>  	.remove	= titsc_remove,
>  	.driver	= {
> -		.name   = "tsc",
> +		.name   = "TI-tsc",

Still quite generic... Why not call it "TI-am335x-tsc"?

Thanks.
Sebastian Andrzej Siewior June 4, 2013, 5:29 p.m. UTC | #2
* Dmitry Torokhov | 2013-06-04 09:50:35 [-0700]:

>> --- a/drivers/input/touchscreen/ti_am335x_tsc.c
>> +++ b/drivers/input/touchscreen/ti_am335x_tsc.c
>> @@ -543,11 +543,12 @@ static struct platform_driver ti_tsc_driver = {
>>  	.probe	= titsc_probe,
>>  	.remove	= titsc_remove,
>>  	.driver	= {
>> -		.name   = "tsc",
>> +		.name   = "TI-tsc",
>
>Still quite generic... Why not call it "TI-am335x-tsc"?
TI-am335x-tsc it is. In that case I make a similar change to adc node.

>Thanks.

Sebastian
--
To unsubscribe from this list: send the line "unsubscribe linux-input" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/input/touchscreen/ti_am335x_tsc.c b/drivers/input/touchscreen/ti_am335x_tsc.c
index 96accaa..2921163 100644
--- a/drivers/input/touchscreen/ti_am335x_tsc.c
+++ b/drivers/input/touchscreen/ti_am335x_tsc.c
@@ -543,11 +543,12 @@  static struct platform_driver ti_tsc_driver = {
 	.probe	= titsc_probe,
 	.remove	= titsc_remove,
 	.driver	= {
-		.name   = "tsc",
+		.name   = "TI-tsc",
 		.owner	= THIS_MODULE,
 		.pm	= TITSC_PM_OPS,
 	},
 };
+MODULE_ALIAS("platform:TI-tsc");
 module_platform_driver(ti_tsc_driver);
 
 MODULE_DESCRIPTION("TI touchscreen controller driver");
diff --git a/drivers/mfd/ti_am335x_tscadc.c b/drivers/mfd/ti_am335x_tscadc.c
index a27401a..c25fe00 100644
--- a/drivers/mfd/ti_am335x_tscadc.c
+++ b/drivers/mfd/ti_am335x_tscadc.c
@@ -184,7 +184,7 @@  static	int ti_tscadc_probe(struct platform_device *pdev)
 	if (tsc_wires > 0) {
 		tscadc->tsc_cell = tscadc->used_cells;
 		cell = &tscadc->cells[tscadc->used_cells++];
-		cell->name = "tsc";
+		cell->name = "TI-tsc";
 		cell->platform_data = tscadc;
 		cell->pdata_size = sizeof(*tscadc);
 	}