diff mbox series

[v2] input: misc: max8997: Simplify open coding of a division using up to 64 divisions

Message ID 20210316212233.50765-1-uwe@kleine-koenig.org (mailing list archive)
State Accepted
Commit 3f17a25b2d868b0d387a5eff4d6d34635e93a7da
Headers show
Series [v2] input: misc: max8997: Simplify open coding of a division using up to 64 divisions | expand

Commit Message

Uwe Kleine-König March 16, 2021, 9:22 p.m. UTC
The for loop is just a complicate way to express a division. Replace it
by the actual division which is both simpler to understand for a human
and more efficient for a CPU to calculate.

Signed-off-by: Uwe Kleine-König <uwe@kleine-koenig.org>
---
Changes since (implicit) v1:

 - drop now unused variable i
 - s/DIV_ROUNDUP/DIV_ROUND_UP/ to make the compiler happy.

Nota bene: Better do the compile test before calling git send-email :-)

Best regards
Uwe

 drivers/input/misc/max8997_haptic.c | 9 ++-------
 1 file changed, 2 insertions(+), 7 deletions(-)

Comments

Dmitry Torokhov March 23, 2021, 6:40 p.m. UTC | #1
On Tue, Mar 16, 2021 at 10:22:33PM +0100, Uwe Kleine-König wrote:
> The for loop is just a complicate way to express a division. Replace it
> by the actual division which is both simpler to understand for a human
> and more efficient for a CPU to calculate.
> 
> Signed-off-by: Uwe Kleine-König <uwe@kleine-koenig.org>

Applied, thank you.
diff mbox series

Patch

diff --git a/drivers/input/misc/max8997_haptic.c b/drivers/input/misc/max8997_haptic.c
index c86966ea0f16..ad82837c7ad5 100644
--- a/drivers/input/misc/max8997_haptic.c
+++ b/drivers/input/misc/max8997_haptic.c
@@ -65,15 +65,10 @@  static int max8997_haptic_set_duty_cycle(struct max8997_haptic *chip)
 		pwm_set_relative_duty_cycle(&state, chip->level, 100);
 		ret = pwm_apply_state(chip->pwm, &state);
 	} else {
-		int i;
 		u8 duty_index = 0;
 
-		for (i = 0; i <= 64; i++) {
-			if (chip->level <= i * 100 / 64) {
-				duty_index = i;
-				break;
-			}
-		}
+		duty_index = DIV_ROUND_UP(chip->level * 64, 100);
+
 		switch (chip->internal_mode_pattern) {
 		case 0:
 			max8997_write_reg(chip->client,