diff mbox series

HID: uclogic: Standardize test name prefix

Message ID 20221110174955.398885-1-jose.exposito89@gmail.com (mailing list archive)
State Mainlined
Commit af89dfde2a5f8b9d2489813f0ec575d0457ad902
Delegated to: Jiri Kosina
Headers show
Series HID: uclogic: Standardize test name prefix | expand

Commit Message

José Expósito Nov. 10, 2022, 5:49 p.m. UTC
Commit 961bcdf956a4 ("drm/tests: Change "igt_" prefix to "drm_test_"")
introduced a new naming convention for the KUnit tests present in the
DRM subsystem: "drm_test_<module>_<test name>".

This naming convention is very convenient because it allows to easily
run all subsystem tests or all driver tests using kunit.py's wildcards.

Follow the naming conventions used in the DRM subsystem adapted to the
HID subsystem: "hid_test_<module>_<test name>".

Signed-off-by: José Expósito <jose.exposito89@gmail.com>
---
 drivers/hid/hid-uclogic-params-test.c | 4 ++--
 drivers/hid/hid-uclogic-rdesc-test.c  | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

Comments

Maira Canal Nov. 10, 2022, 10:42 p.m. UTC | #1
Hi José,

On 11/10/22 14:49, José Expósito wrote:
> Commit 961bcdf956a4 ("drm/tests: Change "igt_" prefix to "drm_test_"")
> introduced a new naming convention for the KUnit tests present in the
> DRM subsystem: "drm_test_<module>_<test name>".
>> This naming convention is very convenient because it allows to easily
> run all subsystem tests or all driver tests using kunit.py's wildcards.
> 
> Follow the naming conventions used in the DRM subsystem adapted to the
> HID subsystem: "hid_test_<module>_<test name>".
> 
> Signed-off-by: José Expósito <jose.exposito89@gmail.com>

It is great to see this coming to other subsystems!

Reviewed-by: Maíra Canal <mairacanal@riseup.net>

Best Regards,
- Maíra Canal

> ---
>  drivers/hid/hid-uclogic-params-test.c | 4 ++--
>  drivers/hid/hid-uclogic-rdesc-test.c  | 4 ++--
>  2 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/hid/hid-uclogic-params-test.c b/drivers/hid/hid-uclogic-params-test.c
> index 57ef5d3e4b74..bfa7ccb7d1e8 100644
> --- a/drivers/hid/hid-uclogic-params-test.c
> +++ b/drivers/hid/hid-uclogic-params-test.c
> @@ -136,7 +136,7 @@ static void uclogic_parse_ugee_v2_desc_case_desc(struct uclogic_parse_ugee_v2_de
>  KUNIT_ARRAY_PARAM(uclogic_parse_ugee_v2_desc, uclogic_parse_ugee_v2_desc_cases,
>  		  uclogic_parse_ugee_v2_desc_case_desc);
>  
> -static void uclogic_parse_ugee_v2_desc_test(struct kunit *test)
> +static void hid_test_uclogic_parse_ugee_v2_desc(struct kunit *test)
>  {
>  	int res;
>  	s32 desc_params[UCLOGIC_RDESC_PH_ID_NUM];
> @@ -175,7 +175,7 @@ static void uclogic_parse_ugee_v2_desc_test(struct kunit *test)
>  }
>  
>  static struct kunit_case hid_uclogic_params_test_cases[] = {
> -	KUNIT_CASE_PARAM(uclogic_parse_ugee_v2_desc_test,
> +	KUNIT_CASE_PARAM(hid_test_uclogic_parse_ugee_v2_desc,
>  			 uclogic_parse_ugee_v2_desc_gen_params),
>  	{}
>  };
> diff --git a/drivers/hid/hid-uclogic-rdesc-test.c b/drivers/hid/hid-uclogic-rdesc-test.c
> index 3971a0854c3e..b429c541bf2f 100644
> --- a/drivers/hid/hid-uclogic-rdesc-test.c
> +++ b/drivers/hid/hid-uclogic-rdesc-test.c
> @@ -187,7 +187,7 @@ static void uclogic_template_case_desc(struct uclogic_template_case *t,
>  KUNIT_ARRAY_PARAM(uclogic_template, uclogic_template_cases,
>  		  uclogic_template_case_desc);
>  
> -static void uclogic_template_test(struct kunit *test)
> +static void hid_test_uclogic_template(struct kunit *test)
>  {
>  	__u8 *res;
>  	const struct uclogic_template_case *params = test->param_value;
> @@ -203,7 +203,7 @@ static void uclogic_template_test(struct kunit *test)
>  }
>  
>  static struct kunit_case hid_uclogic_rdesc_test_cases[] = {
> -	KUNIT_CASE_PARAM(uclogic_template_test, uclogic_template_gen_params),
> +	KUNIT_CASE_PARAM(hid_test_uclogic_template, uclogic_template_gen_params),
>  	{}
>  };
>
Jiri Kosina Nov. 14, 2022, 2:04 p.m. UTC | #2
On Thu, 10 Nov 2022, José Expósito wrote:

> Commit 961bcdf956a4 ("drm/tests: Change "igt_" prefix to "drm_test_"")
> introduced a new naming convention for the KUnit tests present in the
> DRM subsystem: "drm_test_<module>_<test name>".
> 
> This naming convention is very convenient because it allows to easily
> run all subsystem tests or all driver tests using kunit.py's wildcards.
> 
> Follow the naming conventions used in the DRM subsystem adapted to the
> HID subsystem: "hid_test_<module>_<test name>".
> 
> Signed-off-by: José Expósito <jose.exposito89@gmail.com>

Applied to hid.git#for-6.2/uclogic. Thanks,
diff mbox series

Patch

diff --git a/drivers/hid/hid-uclogic-params-test.c b/drivers/hid/hid-uclogic-params-test.c
index 57ef5d3e4b74..bfa7ccb7d1e8 100644
--- a/drivers/hid/hid-uclogic-params-test.c
+++ b/drivers/hid/hid-uclogic-params-test.c
@@ -136,7 +136,7 @@  static void uclogic_parse_ugee_v2_desc_case_desc(struct uclogic_parse_ugee_v2_de
 KUNIT_ARRAY_PARAM(uclogic_parse_ugee_v2_desc, uclogic_parse_ugee_v2_desc_cases,
 		  uclogic_parse_ugee_v2_desc_case_desc);
 
-static void uclogic_parse_ugee_v2_desc_test(struct kunit *test)
+static void hid_test_uclogic_parse_ugee_v2_desc(struct kunit *test)
 {
 	int res;
 	s32 desc_params[UCLOGIC_RDESC_PH_ID_NUM];
@@ -175,7 +175,7 @@  static void uclogic_parse_ugee_v2_desc_test(struct kunit *test)
 }
 
 static struct kunit_case hid_uclogic_params_test_cases[] = {
-	KUNIT_CASE_PARAM(uclogic_parse_ugee_v2_desc_test,
+	KUNIT_CASE_PARAM(hid_test_uclogic_parse_ugee_v2_desc,
 			 uclogic_parse_ugee_v2_desc_gen_params),
 	{}
 };
diff --git a/drivers/hid/hid-uclogic-rdesc-test.c b/drivers/hid/hid-uclogic-rdesc-test.c
index 3971a0854c3e..b429c541bf2f 100644
--- a/drivers/hid/hid-uclogic-rdesc-test.c
+++ b/drivers/hid/hid-uclogic-rdesc-test.c
@@ -187,7 +187,7 @@  static void uclogic_template_case_desc(struct uclogic_template_case *t,
 KUNIT_ARRAY_PARAM(uclogic_template, uclogic_template_cases,
 		  uclogic_template_case_desc);
 
-static void uclogic_template_test(struct kunit *test)
+static void hid_test_uclogic_template(struct kunit *test)
 {
 	__u8 *res;
 	const struct uclogic_template_case *params = test->param_value;
@@ -203,7 +203,7 @@  static void uclogic_template_test(struct kunit *test)
 }
 
 static struct kunit_case hid_uclogic_rdesc_test_cases[] = {
-	KUNIT_CASE_PARAM(uclogic_template_test, uclogic_template_gen_params),
+	KUNIT_CASE_PARAM(hid_test_uclogic_template, uclogic_template_gen_params),
 	{}
 };