diff mbox

[05/15] drivers: input: Drop unlikely before IS_ERR(_OR_NULL)

Message ID 72b53f2cabc15cf3d019041a0ed605ca7c24d19b.1438331416.git.viresh.kumar@linaro.org (mailing list archive)
State New, archived
Headers show

Commit Message

Viresh Kumar July 31, 2015, 8:38 a.m. UTC
IS_ERR(_OR_NULL) already contain an 'unlikely' compiler flag and there
is no need to do that again from its callers. Drop it.

Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org>
---
 drivers/input/mouse/alps.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Dmitry Torokhov July 31, 2015, 4:58 p.m. UTC | #1
On Fri, Jul 31, 2015 at 02:08:25PM +0530, Viresh Kumar wrote:
> IS_ERR(_OR_NULL) already contain an 'unlikely' compiler flag and there
> is no need to do that again from its callers. Drop it.

I'd rather keep it as it documents the expected behavior and double
unlikely should work just fine.

> 
> Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org>
> ---
>  drivers/input/mouse/alps.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/input/mouse/alps.c b/drivers/input/mouse/alps.c
> index 113d6f1516a5..cef3611a4ccd 100644
> --- a/drivers/input/mouse/alps.c
> +++ b/drivers/input/mouse/alps.c
> @@ -1365,7 +1365,7 @@ static void alps_report_bare_ps2_packet(struct psmouse *psmouse,
>  		/* On V2 devices the DualPoint Stick reports bare packets */
>  		dev = priv->dev2;
>  		dev2 = psmouse->dev;
> -	} else if (unlikely(IS_ERR_OR_NULL(priv->dev3))) {
> +	} else if (IS_ERR_OR_NULL(priv->dev3)) {
>  		/* Register dev3 mouse if we received PS/2 packet first time */
>  		if (!IS_ERR(priv->dev3))
>  			psmouse_queue_work(psmouse, &priv->dev3_register_work,
> -- 
> 2.4.0
> 

Thanks.
Viresh Kumar Aug. 1, 2015, 11:22 a.m. UTC | #2
On 31-07-15, 09:58, Dmitry Torokhov wrote:
> On Fri, Jul 31, 2015 at 02:08:25PM +0530, Viresh Kumar wrote:
> > IS_ERR(_OR_NULL) already contain an 'unlikely' compiler flag and there
> > is no need to do that again from its callers. Drop it.
> 
> I'd rather keep it as it documents the expected behavior and double
> unlikely should work just fine.

TBH, I don't really agree that it is there for documentation. The only purpose
of such compiler flags is to try make code more efficient.

Anyway, I got to this series as someone asked me to fix this for one of my
patches which used unlikely(IS_ERR_OR_NULL()). And so I thought about fixing all
sites that are doing double unlikely (that shouldn't hurt for sure).

I will leave it to you.
Pali Rohár Aug. 1, 2015, 11:44 a.m. UTC | #3
On Saturday 01 August 2015 13:22:51 Viresh Kumar wrote:
> On 31-07-15, 09:58, Dmitry Torokhov wrote:
> > On Fri, Jul 31, 2015 at 02:08:25PM +0530, Viresh Kumar wrote:
> > > IS_ERR(_OR_NULL) already contain an 'unlikely' compiler flag and
> > > there is no need to do that again from its callers. Drop it.
> > 
> > I'd rather keep it as it documents the expected behavior and double
> > unlikely should work just fine.
> 
> TBH, I don't really agree that it is there for documentation. The
> only purpose of such compiler flags is to try make code more
> efficient.
> 
> Anyway, I got to this series as someone asked me to fix this for one
> of my patches which used unlikely(IS_ERR_OR_NULL()). And so I
> thought about fixing all sites that are doing double unlikely (that
> shouldn't hurt for sure).
> 
> I will leave it to you.

I think that unlikely() macro here make code more readable. Yes, it is 
also for compiler optimization, but also for me it looks like Clean Code 
pattern <https://de.wikipedia.org/wiki/Clean_Code> -- is not it?
Pavel Machek Aug. 2, 2015, 3:43 p.m. UTC | #4
On Sat 2015-08-01 13:44:59, Pali Rohár wrote:
> On Saturday 01 August 2015 13:22:51 Viresh Kumar wrote:
> > On 31-07-15, 09:58, Dmitry Torokhov wrote:
> > > On Fri, Jul 31, 2015 at 02:08:25PM +0530, Viresh Kumar wrote:
> > > > IS_ERR(_OR_NULL) already contain an 'unlikely' compiler flag and
> > > > there is no need to do that again from its callers. Drop it.
> > > 
> > > I'd rather keep it as it documents the expected behavior and double
> > > unlikely should work just fine.
> > 
> > TBH, I don't really agree that it is there for documentation. The
> > only purpose of such compiler flags is to try make code more
> > efficient.
> > 
> > Anyway, I got to this series as someone asked me to fix this for one
> > of my patches which used unlikely(IS_ERR_OR_NULL()). And so I
> > thought about fixing all sites that are doing double unlikely (that
> > shouldn't hurt for sure).
> > 
> > I will leave it to you.
> 
> I think that unlikely() macro here make code more readable. Yes, it is 
> also for compiler optimization, but also for me it looks like Clean Code 
> pattern <https://de.wikipedia.org/wiki/Clean_Code> -- is not it?

People know that errors are unlikely, no need to tell them. I'd remove
it.
									Pavel
Pali Rohár Aug. 2, 2015, 3:59 p.m. UTC | #5
On Sunday 02 August 2015 17:43:52 Pavel Machek wrote:
> On Sat 2015-08-01 13:44:59, Pali Rohár wrote:
> > On Saturday 01 August 2015 13:22:51 Viresh Kumar wrote:
> > > On 31-07-15, 09:58, Dmitry Torokhov wrote:
> > > > On Fri, Jul 31, 2015 at 02:08:25PM +0530, Viresh Kumar wrote:
> > > > > IS_ERR(_OR_NULL) already contain an 'unlikely' compiler flag
> > > > > and there is no need to do that again from its callers. Drop
> > > > > it.
> > > > 
> > > > I'd rather keep it as it documents the expected behavior and
> > > > double unlikely should work just fine.
> > > 
> > > TBH, I don't really agree that it is there for documentation. The
> > > only purpose of such compiler flags is to try make code more
> > > efficient.
> > > 
> > > Anyway, I got to this series as someone asked me to fix this for
> > > one of my patches which used unlikely(IS_ERR_OR_NULL()). And so
> > > I thought about fixing all sites that are doing double unlikely
> > > (that shouldn't hurt for sure).
> > > 
> > > I will leave it to you.
> > 
> > I think that unlikely() macro here make code more readable. Yes, it
> > is also for compiler optimization, but also for me it looks like
> > Clean Code pattern <https://de.wikipedia.org/wiki/Clean_Code> --
> > is not it?
> 
> People know that errors are unlikely, no need to tell them. I'd
> remove it.
> 									Pavel

Errors and bugs are always unlikely ;-)
diff mbox

Patch

diff --git a/drivers/input/mouse/alps.c b/drivers/input/mouse/alps.c
index 113d6f1516a5..cef3611a4ccd 100644
--- a/drivers/input/mouse/alps.c
+++ b/drivers/input/mouse/alps.c
@@ -1365,7 +1365,7 @@  static void alps_report_bare_ps2_packet(struct psmouse *psmouse,
 		/* On V2 devices the DualPoint Stick reports bare packets */
 		dev = priv->dev2;
 		dev2 = psmouse->dev;
-	} else if (unlikely(IS_ERR_OR_NULL(priv->dev3))) {
+	} else if (IS_ERR_OR_NULL(priv->dev3)) {
 		/* Register dev3 mouse if we received PS/2 packet first time */
 		if (!IS_ERR(priv->dev3))
 			psmouse_queue_work(psmouse, &priv->dev3_register_work,