diff mbox

ima-evm-utils: attr/xattr.h is deprecated. Use sys/xattr.h instead

Message ID 20180524140410.16988-1-polynomial-c@gentoo.org (mailing list archive)
State New, archived
Headers show

Commit Message

Lars Wendler May 24, 2018, 2:04 p.m. UTC
See also:
http://git.savannah.nongnu.org/cgit/attr.git/commit/?id=7921157890d07858d092f4003ca4c6bae9fd2c38
---
 configure.ac | 2 +-
 src/evmctl.c | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Mimi Zohar June 6, 2018, 7:57 p.m. UTC | #1
Hi Lars, Andre,

On Thu, 2018-05-24 at 16:04 +0200, Lars Wendler wrote:
> See also:
> http://git.savannah.nongnu.org/cgit/attr.git/commit/?id=7921157890d07858d092f4003ca4c6bae9fd2c38

I'm so sorry, but André Draszik's previously posted a patch[1] was
never upstreamed.  Could you review/ack his patch please?

Mimi

[1] https://sourceforge.net/p/linux-ima/mailman/linux-ima-devel/thread/20161017114532.1936-1-git%40andred.net/
> ---
>  configure.ac | 2 +-
>  src/evmctl.c | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/configure.ac b/configure.ac
> index 0497eb7..1f017e2 100644
> --- a/configure.ac
> +++ b/configure.ac
> @@ -30,7 +30,7 @@ AC_SUBST(OPENSSL_LIBS)
>  AC_CHECK_HEADER(unistd.h)
>  AC_CHECK_HEADERS(openssl/conf.h)
> 
> -AC_CHECK_HEADERS(attr/xattr.h, , [AC_MSG_ERROR([attr/xattr.h header not found. You need the libattr development package.])])
> +AC_CHECK_HEADERS(sys/xattr.h, , [AC_MSG_ERROR([sys/xattr.h header not found.])])
>  AC_CHECK_HEADERS(keyutils.h, , [AC_MSG_ERROR([keyutils.h header not found. You need the libkeyutils development package.])])
> 
>  #debug support - yes for a while
> diff --git a/src/evmctl.c b/src/evmctl.c
> index 2ffee78..3fbcd33 100644
> --- a/src/evmctl.c
> +++ b/src/evmctl.c
> @@ -49,7 +49,7 @@
>  #include <stdint.h>
>  #include <string.h>
>  #include <dirent.h>
> -#include <attr/xattr.h>
> +#include <sys/xattr.h>
>  #include <linux/xattr.h>
>  #include <getopt.h>
>  #include <keyutils.h>
diff mbox

Patch

diff --git a/configure.ac b/configure.ac
index 0497eb7..1f017e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,7 +30,7 @@  AC_SUBST(OPENSSL_LIBS)
 AC_CHECK_HEADER(unistd.h)
 AC_CHECK_HEADERS(openssl/conf.h)
 
-AC_CHECK_HEADERS(attr/xattr.h, , [AC_MSG_ERROR([attr/xattr.h header not found. You need the libattr development package.])])
+AC_CHECK_HEADERS(sys/xattr.h, , [AC_MSG_ERROR([sys/xattr.h header not found.])])
 AC_CHECK_HEADERS(keyutils.h, , [AC_MSG_ERROR([keyutils.h header not found. You need the libkeyutils development package.])])
 
 #debug support - yes for a while
diff --git a/src/evmctl.c b/src/evmctl.c
index 2ffee78..3fbcd33 100644
--- a/src/evmctl.c
+++ b/src/evmctl.c
@@ -49,7 +49,7 @@ 
 #include <stdint.h>
 #include <string.h>
 #include <dirent.h>
-#include <attr/xattr.h>
+#include <sys/xattr.h>
 #include <linux/xattr.h>
 #include <getopt.h>
 #include <keyutils.h>