Show patches with: State = Action Required       |    Archived = No       |   637 patches
« 1 2 3 46 7 »
Patch Series A/R/T S/W/F Date Submitter Delegate State
答复: [PATCH] symbol : Make the size of the compile-related array fixed 答复: [PATCH] symbol : Make the size of the compile-related array fixed - - - --- 2021-04-16 韩大鹏(Han Dapeng) New
[kbuild] kbuild: add -grecord-gcc-switches to clang build [kbuild] kbuild: add -grecord-gcc-switches to clang build - - - --- 2021-03-28 Yonghong Song New
[kbuild,v2] kbuild: add -grecord-gcc-switches to clang build [kbuild,v2] kbuild: add -grecord-gcc-switches to clang build - - - --- 2021-03-31 Yonghong Song New
[kbuild,v3,1/2] kbuild: move LINUX_ELFNOTE_BUILD_SALT to elfnote.h add an elfnote with type BUILD_COMPILER_LTO_INFO - - - --- 2021-04-01 Yonghong Song New
[kbuild,v3,2/2] kbuild: add an elfnote with type BUILD_COMPILER_LTO_INFO add an elfnote with type BUILD_COMPILER_LTO_INFO - - - --- 2021-04-01 Yonghong Song New
[kbuild,v4] kbuild: add an elfnote for whether vmlinux is built with lto [kbuild,v4] kbuild: add an elfnote for whether vmlinux is built with lto - 1 2 --- 2021-04-01 Yonghong Song New
[01/12] vfio/pci: Rename vfio_pci.c to vfio_pci_core.c Introduce vfio_pci_core subsystem - - - --- 2021-07-21 Yishai Hadas New
[02/12] vfio/pci: Rename vfio_pci_private.h to vfio_pci_core.h Introduce vfio_pci_core subsystem - - - --- 2021-07-21 Yishai Hadas New
[03/12] vfio/pci: Rename vfio_pci_device to vfio_pci_core_device Introduce vfio_pci_core subsystem - - - --- 2021-07-21 Yishai Hadas New
[04/12] vfio/pci: Rename ops functions to fit core namings Introduce vfio_pci_core subsystem - - - --- 2021-07-21 Yishai Hadas New
[05/12] vfio/pci: Include vfio header in vfio_pci_core.h Introduce vfio_pci_core subsystem - - - --- 2021-07-21 Yishai Hadas New
[06/12] vfio/pci: Split the pci_driver code out of vfio_pci_core.c Introduce vfio_pci_core subsystem - - - --- 2021-07-21 Yishai Hadas New
[07/12] vfio/pci: Move igd initialization to vfio_pci.c Introduce vfio_pci_core subsystem - - - --- 2021-07-21 Yishai Hadas New
[08/12] vfio/pci: Move module parameters to vfio_pci.c Introduce vfio_pci_core subsystem - - - --- 2021-07-21 Yishai Hadas New
[09/12] PCI: Add a PCI_ID_F_VFIO_DRIVER_OVERRIDE flag to struct pci_device_id Introduce vfio_pci_core subsystem - - - --- 2021-07-21 Yishai Hadas New
[10/12] vfio: Use select for eventfd Introduce vfio_pci_core subsystem - - - --- 2021-07-21 Yishai Hadas New
[11/12] vfio: Use kconfig if XX/endif blocks instead of repeating 'depends on' Introduce vfio_pci_core subsystem - - - --- 2021-07-21 Yishai Hadas New
[12/12] vfio/pci: Introduce vfio_pci_core.ko Introduce vfio_pci_core subsystem - - - --- 2021-07-21 Yishai Hadas New
[V2,01/12] vfio/pci: Rename vfio_pci.c to vfio_pci_core.c Introduce vfio_pci_core subsystem - - - --- 2021-08-18 Yishai Hadas New
[V2,02/12] vfio/pci: Rename vfio_pci_private.h to vfio_pci_core.h Introduce vfio_pci_core subsystem - - - --- 2021-08-18 Yishai Hadas New
[V2,03/12] vfio/pci: Rename vfio_pci_device to vfio_pci_core_device Introduce vfio_pci_core subsystem - - - --- 2021-08-18 Yishai Hadas New
[V2,04/12] vfio/pci: Rename ops functions to fit core namings Introduce vfio_pci_core subsystem - - - --- 2021-08-18 Yishai Hadas New
[V2,05/12] vfio/pci: Include vfio header in vfio_pci_core.h Introduce vfio_pci_core subsystem - - - --- 2021-08-18 Yishai Hadas New
[V2,06/12] vfio/pci: Split the pci_driver code out of vfio_pci_core.c Introduce vfio_pci_core subsystem - - - --- 2021-08-18 Yishai Hadas New
[V2,07/12] vfio/pci: Move igd initialization to vfio_pci.c Introduce vfio_pci_core subsystem - - - --- 2021-08-18 Yishai Hadas New
[V2,08/12] vfio/pci: Move module parameters to vfio_pci.c Introduce vfio_pci_core subsystem - - - --- 2021-08-18 Yishai Hadas New
[V2,09/12] PCI: Add 'override_only' bitmap to struct pci_device_id Introduce vfio_pci_core subsystem - - - --- 2021-08-18 Yishai Hadas New
[V2,10/12] vfio: Use select for eventfd Introduce vfio_pci_core subsystem - - - --- 2021-08-18 Yishai Hadas New
[V2,11/12] vfio: Use kconfig if XX/endif blocks instead of repeating 'depends on' Introduce vfio_pci_core subsystem - - - --- 2021-08-18 Yishai Hadas New
[V2,12/12] vfio/pci: Introduce vfio_pci_core.ko Introduce vfio_pci_core subsystem - - - --- 2021-08-18 Yishai Hadas New
[V3,01/13] vfio/pci: Rename vfio_pci.c to vfio_pci_core.c Introduce vfio_pci_core subsystem - - - --- 2021-08-22 Yishai Hadas New
[V3,02/13] vfio/pci: Rename vfio_pci_private.h to vfio_pci_core.h Introduce vfio_pci_core subsystem - - - --- 2021-08-22 Yishai Hadas New
[V3,03/13] vfio/pci: Rename vfio_pci_device to vfio_pci_core_device Introduce vfio_pci_core subsystem - - - --- 2021-08-22 Yishai Hadas New
[V3,04/13] vfio/pci: Rename ops functions to fit core namings Introduce vfio_pci_core subsystem - - - --- 2021-08-22 Yishai Hadas New
[V3,05/13] vfio/pci: Include vfio header in vfio_pci_core.h Introduce vfio_pci_core subsystem - - - --- 2021-08-22 Yishai Hadas New
[V3,06/13] vfio/pci: Split the pci_driver code out of vfio_pci_core.c Introduce vfio_pci_core subsystem - - - --- 2021-08-22 Yishai Hadas New
[V3,07/13] vfio/pci: Move igd initialization to vfio_pci.c Introduce vfio_pci_core subsystem - - - --- 2021-08-22 Yishai Hadas New
[V3,08/13] vfio/pci: Move module parameters to vfio_pci.c Introduce vfio_pci_core subsystem - - - --- 2021-08-22 Yishai Hadas New
[V3,09/13] PCI: Add 'override_only' field to struct pci_device_id Introduce vfio_pci_core subsystem - - - --- 2021-08-22 Yishai Hadas New
[V3,10/13] PCI / VFIO: Add 'override_only' support for VFIO PCI sub system Introduce vfio_pci_core subsystem - - - --- 2021-08-22 Yishai Hadas New
[V3,11/13] vfio: Use select for eventfd Introduce vfio_pci_core subsystem - - - --- 2021-08-22 Yishai Hadas New
[V3,12/13] vfio: Use kconfig if XX/endif blocks instead of repeating 'depends on' Introduce vfio_pci_core subsystem - - - --- 2021-08-22 Yishai Hadas New
[V3,13/13] vfio/pci: Introduce vfio_pci_core.ko Introduce vfio_pci_core subsystem - - - --- 2021-08-22 Yishai Hadas New
[V4,01/13] vfio/pci: Rename vfio_pci.c to vfio_pci_core.c Introduce vfio_pci_core subsystem - 1 - --- 2021-08-25 Yishai Hadas New
[V4,02/13] vfio/pci: Rename vfio_pci_private.h to vfio_pci_core.h Introduce vfio_pci_core subsystem - 1 - --- 2021-08-25 Yishai Hadas New
[V4,03/13] vfio/pci: Rename vfio_pci_device to vfio_pci_core_device Introduce vfio_pci_core subsystem - 1 - --- 2021-08-25 Yishai Hadas New
[V4,04/13] vfio/pci: Rename ops functions to fit core namings Introduce vfio_pci_core subsystem - 1 - --- 2021-08-25 Yishai Hadas New
[V4,05/13] vfio/pci: Include vfio header in vfio_pci_core.h Introduce vfio_pci_core subsystem - 1 - --- 2021-08-25 Yishai Hadas New
[V4,06/13] vfio/pci: Split the pci_driver code out of vfio_pci_core.c Introduce vfio_pci_core subsystem - 1 - --- 2021-08-25 Yishai Hadas New
[V4,07/13] vfio/pci: Move igd initialization to vfio_pci.c Introduce vfio_pci_core subsystem - 1 - --- 2021-08-25 Yishai Hadas New
[V4,08/13] vfio/pci: Move module parameters to vfio_pci.c Introduce vfio_pci_core subsystem - 1 - --- 2021-08-25 Yishai Hadas New
[V4,09/13] PCI: Add 'override_only' field to struct pci_device_id Introduce vfio_pci_core subsystem 1 - - --- 2021-08-25 Yishai Hadas New
[V4,10/13] PCI / VFIO: Add 'override_only' support for VFIO PCI sub system Introduce vfio_pci_core subsystem 1 - - --- 2021-08-25 Yishai Hadas New
[V4,11/13] vfio: Use select for eventfd Introduce vfio_pci_core subsystem - 1 - --- 2021-08-25 Yishai Hadas New
[V4,12/13] vfio: Use kconfig if XX/endif blocks instead of repeating 'depends on' Introduce vfio_pci_core subsystem - 1 - --- 2021-08-25 Yishai Hadas New
[V4,13/13] vfio/pci: Introduce vfio_pci_core.ko Introduce vfio_pci_core subsystem - 1 - --- 2021-08-25 Yishai Hadas New
[V5,01/13] vfio/pci: Rename vfio_pci.c to vfio_pci_core.c Introduce vfio_pci_core subsystem - 1 - --- 2021-08-26 Yishai Hadas New
[V5,02/13] vfio/pci: Rename vfio_pci_private.h to vfio_pci_core.h Introduce vfio_pci_core subsystem - 1 - --- 2021-08-26 Yishai Hadas New
[V5,03/13] vfio/pci: Rename vfio_pci_device to vfio_pci_core_device Introduce vfio_pci_core subsystem - 1 - --- 2021-08-26 Yishai Hadas New
[V5,04/13] vfio/pci: Rename ops functions to fit core namings Introduce vfio_pci_core subsystem - 1 - --- 2021-08-26 Yishai Hadas New
[V5,05/13] vfio/pci: Include vfio header in vfio_pci_core.h Introduce vfio_pci_core subsystem - 1 - --- 2021-08-26 Yishai Hadas New
[V5,06/13] vfio/pci: Split the pci_driver code out of vfio_pci_core.c Introduce vfio_pci_core subsystem - 1 - --- 2021-08-26 Yishai Hadas New
[V5,07/13] vfio/pci: Move igd initialization to vfio_pci.c Introduce vfio_pci_core subsystem - 1 - --- 2021-08-26 Yishai Hadas New
[V5,08/13] vfio/pci: Move module parameters to vfio_pci.c Introduce vfio_pci_core subsystem - 1 - --- 2021-08-26 Yishai Hadas New
[V5,09/13] PCI: Add 'override_only' field to struct pci_device_id Introduce vfio_pci_core subsystem 1 - - --- 2021-08-26 Yishai Hadas New
[V5,10/13] PCI / VFIO: Add 'override_only' support for VFIO PCI sub system Introduce vfio_pci_core subsystem 1 - - --- 2021-08-26 Yishai Hadas New
[V5,11/13] vfio: Use select for eventfd Introduce vfio_pci_core subsystem - 1 - --- 2021-08-26 Yishai Hadas New
[V5,12/13] vfio: Use kconfig if XX/endif blocks instead of repeating 'depends on' Introduce vfio_pci_core subsystem - 1 - --- 2021-08-26 Yishai Hadas New
[V5,13/13] vfio/pci: Introduce vfio_pci_core.ko Introduce vfio_pci_core subsystem - 1 - --- 2021-08-26 Yishai Hadas New
[1/2] kbuild: allow setting zstd compression level for modules [1/2] kbuild: allow setting zstd compression level for modules - - 1 --- 2021-04-09 Tor Vic New
[2/2] kbuild: allow setting zstd compression level for kernel [1/2] kbuild: allow setting zstd compression level for modules - - - --- 2021-04-09 Tor Vic New
[1/1] Makefile: Pass -warn-stack-size only on LLD < 13.0.0 [1/1] Makefile: Pass -warn-stack-size only on LLD < 13.0.0 - 2 - --- 2021-06-13 Tor Vic New
[1/1] Kbuild, clang: add option for choosing a ThinLTO cache directory [1/1] Kbuild, clang: add option for choosing a ThinLTO cache directory - - - --- 2021-07-12 Tor Vic New
[v2,1/1] Kbuild, clang: add option for choosing a ThinLTO cache directory [v2,1/1] Kbuild, clang: add option for choosing a ThinLTO cache directory - - - --- 2021-07-13 Tor Vic New
[v4,01/17] add support for Clang CFI Add support for Clang CFI - 1 - --- 2021-03-31 Sami Tolvanen New
[v4,02/17] cfi: add __cficanonical Add support for Clang CFI 1 1 - --- 2021-03-31 Sami Tolvanen New
[v4,03/17] mm: add generic function_nocfi macro Add support for Clang CFI - 1 - --- 2021-03-31 Sami Tolvanen New
[v4,04/17] module: ensure __cfi_check alignment Add support for Clang CFI 1 1 - --- 2021-03-31 Sami Tolvanen New
[v4,05/17] workqueue: use WARN_ON_FUNCTION_MISMATCH Add support for Clang CFI - 1 - --- 2021-03-31 Sami Tolvanen New
[v4,06/17] kthread: use WARN_ON_FUNCTION_MISMATCH Add support for Clang CFI - 1 - --- 2021-03-31 Sami Tolvanen New
[v4,07/17] kallsyms: strip ThinLTO hashes from static functions Add support for Clang CFI - 1 - --- 2021-03-31 Sami Tolvanen New
[v4,08/17] bpf: disable CFI in dispatcher functions Add support for Clang CFI - 1 - --- 2021-03-31 Sami Tolvanen New
[v4,09/17] treewide: Change list_sort to use const pointers Add support for Clang CFI - 3 1 --- 2021-03-31 Sami Tolvanen New
[v4,10/17] lkdtm: use function_nocfi Add support for Clang CFI 1 - - --- 2021-03-31 Sami Tolvanen New
[v4,11/17] psci: use function_nocfi for cpu_resume Add support for Clang CFI - 1 - --- 2021-03-31 Sami Tolvanen New
[v4,12/17] arm64: implement function_nocfi Add support for Clang CFI - 1 - --- 2021-03-31 Sami Tolvanen New
[v4,13/17] arm64: use function_nocfi with __pa_symbol Add support for Clang CFI - 1 - --- 2021-03-31 Sami Tolvanen New
[v4,14/17] arm64: add __nocfi to functions that jump to a physical address Add support for Clang CFI - 1 - --- 2021-03-31 Sami Tolvanen New
[v4,15/17] arm64: add __nocfi to __apply_alternatives Add support for Clang CFI - 1 - --- 2021-03-31 Sami Tolvanen New
[v4,16/17] KVM: arm64: Disable CFI for nVHE Add support for Clang CFI - 1 - --- 2021-03-31 Sami Tolvanen New
[v4,17/17] arm64: allow CONFIG_CFI_CLANG to be selected Add support for Clang CFI - 1 - --- 2021-03-31 Sami Tolvanen New
[v5,01/18] add support for Clang CFI Add support for Clang CFI - 1 - --- 2021-04-01 Sami Tolvanen New
[v5,02/18] cfi: add __cficanonical Add support for Clang CFI 1 1 - --- 2021-04-01 Sami Tolvanen New
[v5,03/18] mm: add generic function_nocfi macro Add support for Clang CFI 2 1 - --- 2021-04-01 Sami Tolvanen New
[v5,04/18] module: ensure __cfi_check alignment Add support for Clang CFI 1 1 - --- 2021-04-01 Sami Tolvanen New
[v5,05/18] workqueue: use WARN_ON_FUNCTION_MISMATCH Add support for Clang CFI - 1 - --- 2021-04-01 Sami Tolvanen New
[v5,06/18] kthread: use WARN_ON_FUNCTION_MISMATCH Add support for Clang CFI - 1 - --- 2021-04-01 Sami Tolvanen New
[v5,07/18] kallsyms: strip ThinLTO hashes from static functions Add support for Clang CFI - 1 - --- 2021-04-01 Sami Tolvanen New
[v5,08/18] bpf: disable CFI in dispatcher functions Add support for Clang CFI - 1 - --- 2021-04-01 Sami Tolvanen New
[v5,09/18] treewide: Change list_sort to use const pointers Add support for Clang CFI - 3 1 --- 2021-04-01 Sami Tolvanen New
« 1 2 3 46 7 »