mbox series

[v5,0/3] selftests: livepatch: test livepatching a kprobed function

Message ID 20241017200132.21946-1-mvetter@suse.com (mailing list archive)
Headers show
Series selftests: livepatch: test livepatching a kprobed function | expand

Message

Michael Vetter Oct. 17, 2024, 8:01 p.m. UTC
Thanks for all the reviews.

V5:
Replace /sys/kernel/livepatch also in other/already existing tests.
Improve commit message of 3rd patch.

V4:
Use variable for /sys/kernel/debug.
Be consistent with "" around variables.
Fix path in commit message to /sys/kernel/debug/kprobes/enabled.

V3:
Save and restore kprobe state also when test fails, by integrating it
into setup_config() and cleanup().
Rename SYSFS variables in a more logical way.
Sort test modules in alphabetical order.
Rename module description.

V2:
Save and restore kprobe state.

Michael Vetter (3):
  selftests: livepatch: rename KLP_SYSFS_DIR to SYSFS_KLP_DIR
  selftests: livepatch: save and restore kprobe state
  selftests: livepatch: test livepatching a kprobed function

 tools/testing/selftests/livepatch/Makefile    |  3 +-
 .../testing/selftests/livepatch/functions.sh  | 29 +++++----
 .../selftests/livepatch/test-callbacks.sh     | 24 +++----
 .../selftests/livepatch/test-ftrace.sh        |  2 +-
 .../selftests/livepatch/test-kprobe.sh        | 62 +++++++++++++++++++
 .../selftests/livepatch/test-livepatch.sh     | 12 ++--
 .../testing/selftests/livepatch/test-state.sh |  8 +--
 .../selftests/livepatch/test-syscall.sh       |  2 +-
 .../testing/selftests/livepatch/test-sysfs.sh |  8 +--
 .../selftests/livepatch/test_modules/Makefile |  3 +-
 .../livepatch/test_modules/test_klp_kprobe.c  | 38 ++++++++++++
 11 files changed, 150 insertions(+), 41 deletions(-)
 create mode 100755 tools/testing/selftests/livepatch/test-kprobe.sh
 create mode 100644 tools/testing/selftests/livepatch/test_modules/test_klp_kprobe.c