mbox series

[v2,0/6,0/6] KUnit test moves / renames

Message ID 20241202075545.3648096-1-davidgow@google.com (mailing list archive)
Headers show
Series KUnit test moves / renames | expand

Message

David Gow Dec. 2, 2024, 7:55 a.m. UTC
As discussed in [1], the KUnit test naming scheme has changed to avoid
name conflicts (and tab-completion woes) with the files being tested.
These renames and moves have caused a nasty set of merge conflicts, so
this series collates and rebases them all on top of v6.13-rc1, to be
applied minimising any further conflicts. [2,3]

Thanks to everyone whose patches appear here, and everyone who reviewed
on the original series. I hope I didn't break them too much during the
rebase!

Link: https://lore.kernel.org/lkml/20240720165441.it.320-kees@kernel.org/ [1]
Link: https://lore.kernel.org/lkml/CABVgOSmbSzcGUi=E4piSojh3A4_0GjE0fAYbqKjtYGbE9beYRQ@mail.gmail.com/ [2]
Link: https://lore.kernel.org/linux-kselftest/CABVgOSkhD6=5K72oL_n35CUeMhbsiQjZ6ds+EuQmJggBtVTFVg@mail.gmail.com/ [3]

Bruno Sobreira França (1):
  lib/math: Add int_log test suite

Diego Vieira (1):
  lib/tests/kfifo_kunit.c: add tests for the kfifo structure

Gabriela Bittencourt (2):
  unicode: kunit: refactor selftest to kunit tests
  unicode: kunit: change tests filename and path

Kees Cook (1):
  lib: Move KUnit tests into tests/ subdirectory

Luis Felipe Hernandez (1):
  lib: math: Move kunit tests into tests/ subdir

 MAINTAINERS                                   |  19 +-
 fs/unicode/Kconfig                            |   5 +-
 fs/unicode/Makefile                           |   2 +-
 fs/unicode/tests/.kunitconfig                 |   3 +
 .../{utf8-selftest.c => tests/utf8_kunit.c}   | 149 ++++++------
 fs/unicode/utf8-norm.c                        |   2 +-
 lib/Kconfig.debug                             |  27 ++-
 lib/Makefile                                  |  39 +--
 lib/math/Makefile                             |   4 +-
 lib/math/tests/Makefile                       |   4 +-
 lib/math/tests/int_log_kunit.c                |  75 ++++++
 .../rational_kunit.c}                         |   0
 lib/tests/Makefile                            |  41 ++++
 lib/{ => tests}/bitfield_kunit.c              |   0
 lib/{ => tests}/checksum_kunit.c              |   0
 lib/{ => tests}/cmdline_kunit.c               |   0
 lib/{ => tests}/cpumask_kunit.c               |   0
 lib/{ => tests}/crc16_kunit.c                 |   0
 lib/{ => tests}/fortify_kunit.c               |   0
 lib/{ => tests}/hashtable_test.c              |   0
 lib/{ => tests}/is_signed_type_kunit.c        |   0
 lib/tests/kfifo_kunit.c                       | 224 ++++++++++++++++++
 lib/{ => tests}/kunit_iov_iter.c              |   0
 lib/{ => tests}/list-test.c                   |   0
 lib/{ => tests}/memcpy_kunit.c                |   0
 lib/{ => tests}/overflow_kunit.c              |   0
 lib/{ => tests}/siphash_kunit.c               |   0
 lib/{ => tests}/slub_kunit.c                  |   0
 lib/{ => tests}/stackinit_kunit.c             |   0
 lib/{ => tests}/string_helpers_kunit.c        |   0
 lib/{ => tests}/string_kunit.c                |   0
 lib/{ => tests}/test_bits.c                   |   0
 lib/{ => tests}/test_fprobe.c                 |   0
 lib/{ => tests}/test_hash.c                   |   0
 lib/{ => tests}/test_kprobes.c                |   0
 lib/{ => tests}/test_linear_ranges.c          |   0
 lib/{ => tests}/test_list_sort.c              |   0
 lib/{ => tests}/test_sort.c                   |   0
 lib/{ => tests}/usercopy_kunit.c              |   0
 lib/{ => tests}/util_macros_kunit.c           |   0
 40 files changed, 459 insertions(+), 135 deletions(-)
 create mode 100644 fs/unicode/tests/.kunitconfig
 rename fs/unicode/{utf8-selftest.c => tests/utf8_kunit.c} (64%)
 create mode 100644 lib/math/tests/int_log_kunit.c
 rename lib/math/{rational-test.c => tests/rational_kunit.c} (100%)
 rename lib/{ => tests}/bitfield_kunit.c (100%)
 rename lib/{ => tests}/checksum_kunit.c (100%)
 rename lib/{ => tests}/cmdline_kunit.c (100%)
 rename lib/{ => tests}/cpumask_kunit.c (100%)
 rename lib/{ => tests}/crc16_kunit.c (100%)
 rename lib/{ => tests}/fortify_kunit.c (100%)
 rename lib/{ => tests}/hashtable_test.c (100%)
 rename lib/{ => tests}/is_signed_type_kunit.c (100%)
 create mode 100644 lib/tests/kfifo_kunit.c
 rename lib/{ => tests}/kunit_iov_iter.c (100%)
 rename lib/{ => tests}/list-test.c (100%)
 rename lib/{ => tests}/memcpy_kunit.c (100%)
 rename lib/{ => tests}/overflow_kunit.c (100%)
 rename lib/{ => tests}/siphash_kunit.c (100%)
 rename lib/{ => tests}/slub_kunit.c (100%)
 rename lib/{ => tests}/stackinit_kunit.c (100%)
 rename lib/{ => tests}/string_helpers_kunit.c (100%)
 rename lib/{ => tests}/string_kunit.c (100%)
 rename lib/{ => tests}/test_bits.c (100%)
 rename lib/{ => tests}/test_fprobe.c (100%)
 rename lib/{ => tests}/test_hash.c (100%)
 rename lib/{ => tests}/test_kprobes.c (100%)
 rename lib/{ => tests}/test_linear_ranges.c (100%)
 rename lib/{ => tests}/test_list_sort.c (100%)
 rename lib/{ => tests}/test_sort.c (100%)
 rename lib/{ => tests}/usercopy_kunit.c (100%)
 rename lib/{ => tests}/util_macros_kunit.c (100%)

Comments

Andy Shevchenko Dec. 2, 2024, 4:01 p.m. UTC | #1
On Mon, Dec 02, 2024 at 03:55:37PM +0800, David Gow wrote:
> As discussed in [1], the KUnit test naming scheme has changed to avoid
> name conflicts (and tab-completion woes) with the files being tested.
> These renames and moves have caused a nasty set of merge conflicts, so
> this series collates and rebases them all on top of v6.13-rc1, to be
> applied minimising any further conflicts. [2,3]
> 
> Thanks to everyone whose patches appear here, and everyone who reviewed
> on the original series. I hope I didn't break them too much during the
> rebase!
> 
> Link: https://lore.kernel.org/lkml/20240720165441.it.320-kees@kernel.org/ [1]
> Link: https://lore.kernel.org/lkml/CABVgOSmbSzcGUi=E4piSojh3A4_0GjE0fAYbqKjtYGbE9beYRQ@mail.gmail.com/ [2]
> Link: https://lore.kernel.org/linux-kselftest/CABVgOSkhD6=5K72oL_n35CUeMhbsiQjZ6ds+EuQmJggBtVTFVg@mail.gmail.com/ [3]
> 
> Bruno Sobreira França (1):
>   lib/math: Add int_log test suite
> 
> Diego Vieira (1):
>   lib/tests/kfifo_kunit.c: add tests for the kfifo structure
> 
> Gabriela Bittencourt (2):
>   unicode: kunit: refactor selftest to kunit tests
>   unicode: kunit: change tests filename and path
> 
> Kees Cook (1):
>   lib: Move KUnit tests into tests/ subdirectory
> 
> Luis Felipe Hernandez (1):
>   lib: math: Move kunit tests into tests/ subdir

Can we deduplicate test/kunit in the file names please?

See df7f9acd8646 ("platform/x86: intel: Add 'intel' prefix to the modules
automatically") for the details how to achieve that in non-verbose way.
Rae Moar Dec. 2, 2024, 11:29 p.m. UTC | #2
On Mon, Dec 2, 2024 at 2:55 AM David Gow <davidgow@google.com> wrote:
>
> As discussed in [1], the KUnit test naming scheme has changed to avoid
> name conflicts (and tab-completion woes) with the files being tested.
> These renames and moves have caused a nasty set of merge conflicts, so
> this series collates and rebases them all on top of v6.13-rc1, to be
> applied minimising any further conflicts. [2,3]
>
> Thanks to everyone whose patches appear here, and everyone who reviewed
> on the original series. I hope I didn't break them too much during the
> rebase!
>

Hello!

This series looks good to me. Tests are passed both built-in and as modules.

One comment: The second patch in the series "[PATCH v2 2/6] lib/math:
Add int_log test suite" applies with a warning of an extra EOF blank
line.

Other than that small nit,

Reviewed-by: Rae Moar <rmoar@google.com>

Thanks!
-Rae


> Link: https://lore.kernel.org/lkml/20240720165441.it.320-kees@kernel.org/ [1]
> Link: https://lore.kernel.org/lkml/CABVgOSmbSzcGUi=E4piSojh3A4_0GjE0fAYbqKjtYGbE9beYRQ@mail.gmail.com/ [2]
> Link: https://lore.kernel.org/linux-kselftest/CABVgOSkhD6=5K72oL_n35CUeMhbsiQjZ6ds+EuQmJggBtVTFVg@mail.gmail.com/ [3]
>
> Bruno Sobreira França (1):
>   lib/math: Add int_log test suite
>
> Diego Vieira (1):
>   lib/tests/kfifo_kunit.c: add tests for the kfifo structure
>
> Gabriela Bittencourt (2):
>   unicode: kunit: refactor selftest to kunit tests
>   unicode: kunit: change tests filename and path
>
> Kees Cook (1):
>   lib: Move KUnit tests into tests/ subdirectory
>
> Luis Felipe Hernandez (1):
>   lib: math: Move kunit tests into tests/ subdir
>
>  MAINTAINERS                                   |  19 +-
>  fs/unicode/Kconfig                            |   5 +-
>  fs/unicode/Makefile                           |   2 +-
>  fs/unicode/tests/.kunitconfig                 |   3 +
>  .../{utf8-selftest.c => tests/utf8_kunit.c}   | 149 ++++++------
>  fs/unicode/utf8-norm.c                        |   2 +-
>  lib/Kconfig.debug                             |  27 ++-
>  lib/Makefile                                  |  39 +--
>  lib/math/Makefile                             |   4 +-
>  lib/math/tests/Makefile                       |   4 +-
>  lib/math/tests/int_log_kunit.c                |  75 ++++++
>  .../rational_kunit.c}                         |   0
>  lib/tests/Makefile                            |  41 ++++
>  lib/{ => tests}/bitfield_kunit.c              |   0
>  lib/{ => tests}/checksum_kunit.c              |   0
>  lib/{ => tests}/cmdline_kunit.c               |   0
>  lib/{ => tests}/cpumask_kunit.c               |   0
>  lib/{ => tests}/crc16_kunit.c                 |   0
>  lib/{ => tests}/fortify_kunit.c               |   0
>  lib/{ => tests}/hashtable_test.c              |   0
>  lib/{ => tests}/is_signed_type_kunit.c        |   0
>  lib/tests/kfifo_kunit.c                       | 224 ++++++++++++++++++
>  lib/{ => tests}/kunit_iov_iter.c              |   0
>  lib/{ => tests}/list-test.c                   |   0
>  lib/{ => tests}/memcpy_kunit.c                |   0
>  lib/{ => tests}/overflow_kunit.c              |   0
>  lib/{ => tests}/siphash_kunit.c               |   0
>  lib/{ => tests}/slub_kunit.c                  |   0
>  lib/{ => tests}/stackinit_kunit.c             |   0
>  lib/{ => tests}/string_helpers_kunit.c        |   0
>  lib/{ => tests}/string_kunit.c                |   0
>  lib/{ => tests}/test_bits.c                   |   0
>  lib/{ => tests}/test_fprobe.c                 |   0
>  lib/{ => tests}/test_hash.c                   |   0
>  lib/{ => tests}/test_kprobes.c                |   0
>  lib/{ => tests}/test_linear_ranges.c          |   0
>  lib/{ => tests}/test_list_sort.c              |   0
>  lib/{ => tests}/test_sort.c                   |   0
>  lib/{ => tests}/usercopy_kunit.c              |   0
>  lib/{ => tests}/util_macros_kunit.c           |   0
>  40 files changed, 459 insertions(+), 135 deletions(-)
>  create mode 100644 fs/unicode/tests/.kunitconfig
>  rename fs/unicode/{utf8-selftest.c => tests/utf8_kunit.c} (64%)
>  create mode 100644 lib/math/tests/int_log_kunit.c
>  rename lib/math/{rational-test.c => tests/rational_kunit.c} (100%)
>  rename lib/{ => tests}/bitfield_kunit.c (100%)
>  rename lib/{ => tests}/checksum_kunit.c (100%)
>  rename lib/{ => tests}/cmdline_kunit.c (100%)
>  rename lib/{ => tests}/cpumask_kunit.c (100%)
>  rename lib/{ => tests}/crc16_kunit.c (100%)
>  rename lib/{ => tests}/fortify_kunit.c (100%)
>  rename lib/{ => tests}/hashtable_test.c (100%)
>  rename lib/{ => tests}/is_signed_type_kunit.c (100%)
>  create mode 100644 lib/tests/kfifo_kunit.c
>  rename lib/{ => tests}/kunit_iov_iter.c (100%)
>  rename lib/{ => tests}/list-test.c (100%)
>  rename lib/{ => tests}/memcpy_kunit.c (100%)
>  rename lib/{ => tests}/overflow_kunit.c (100%)
>  rename lib/{ => tests}/siphash_kunit.c (100%)
>  rename lib/{ => tests}/slub_kunit.c (100%)
>  rename lib/{ => tests}/stackinit_kunit.c (100%)
>  rename lib/{ => tests}/string_helpers_kunit.c (100%)
>  rename lib/{ => tests}/string_kunit.c (100%)
>  rename lib/{ => tests}/test_bits.c (100%)
>  rename lib/{ => tests}/test_fprobe.c (100%)
>  rename lib/{ => tests}/test_hash.c (100%)
>  rename lib/{ => tests}/test_kprobes.c (100%)
>  rename lib/{ => tests}/test_linear_ranges.c (100%)
>  rename lib/{ => tests}/test_list_sort.c (100%)
>  rename lib/{ => tests}/test_sort.c (100%)
>  rename lib/{ => tests}/usercopy_kunit.c (100%)
>  rename lib/{ => tests}/util_macros_kunit.c (100%)
>
> --
> 2.47.0.338.g60cca15819-goog
>