Message ID | 20220417110532.c0580c358f@2b220eea1db5e11 (mailing list archive) |
---|---|
State | Accepted |
Commit | 77930ee4d5b35e4a88a33e83fe8bf91a7a7016f9 |
Delegated to: | Brendan Higgins |
Headers | show |
Series | [PROPER] Documentation: kunit: change complete_and_exit to kthread_complete_and_exit | expand |
diff --git a/Documentation/dev-tools/kunit/architecture.rst b/Documentation/dev-tools/kunit/architecture.rst index ff9c85a0bff21..cf9e6e3eeae4c 100644 --- a/Documentation/dev-tools/kunit/architecture.rst +++ b/Documentation/dev-tools/kunit/architecture.rst @@ -125,7 +125,7 @@ All expectations/assertions are formatted as: ``void __noreturn kunit_try_catch_throw(struct kunit_try_catch *try_catch)``. - ``kunit_try_catch_throw`` calls function: - ``void complete_and_exit(struct completion *, long) __noreturn;`` + ``void kthread_complete_and_exit(struct completion *, long) __noreturn;`` and terminates the special thread context. - ``<op>`` denotes a check with options: ``TRUE`` (supplied property
Commit cead18552660 ("exit: Rename complete_and_exit to kthread_complete_and_exit") renamed complete_and_exit to kthread_complete_and_exit. CC: Brendan Higgins <brendanhiggins@google.com> CC: Jonathan Corbet <corbet@lwn.net> CC: linux-kselftest@vger.kernel.org CC: kunit-dev@googlegroups.com CC: linux-doc@vger.kernel.org CC: linux-kernel@vger.kernel.org Signed-off-by: Andreas-Christian Hagau <ach@hagau.se> --- Documentation/dev-tools/kunit/architecture.rst | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)