diff mbox series

Documentation: kunit: Rename references to kunit_abort()

Message ID 20230602035400.2333527-1-davidgow@google.com (mailing list archive)
State Accepted
Commit fefdb43943c1a0d87e1b43ae4d03e5f9a1d058f4
Delegated to: Brendan Higgins
Headers show
Series Documentation: kunit: Rename references to kunit_abort() | expand

Commit Message

David Gow June 2, 2023, 3:53 a.m. UTC
The kunit_abort() function has been renamed __kunit_abort(), update the
references to it in the documentation.

Suggested-by: Daniel Latypov <dlatypov@google.com>
Signed-off-by: David Gow <davidgow@google.com>
---
 Documentation/dev-tools/kunit/architecture.rst | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Daniel Latypov June 2, 2023, 9:36 p.m. UTC | #1
On Thu, Jun 1, 2023 at 8:54 PM David Gow <davidgow@google.com> wrote:
>
> The kunit_abort() function has been renamed __kunit_abort(), update the
> references to it in the documentation.
>
> Suggested-by: Daniel Latypov <dlatypov@google.com>
> Signed-off-by: David Gow <davidgow@google.com>

Reviewed-by: Daniel Latypov <dlatypov@google.com>

Thanks!
Double checked that this was the only remaining reference and that
this patch applied OK.
diff mbox series

Patch

diff --git a/Documentation/dev-tools/kunit/architecture.rst b/Documentation/dev-tools/kunit/architecture.rst
index e95ab05342bb..f335f883f8f6 100644
--- a/Documentation/dev-tools/kunit/architecture.rst
+++ b/Documentation/dev-tools/kunit/architecture.rst
@@ -119,9 +119,9 @@  All expectations/assertions are formatted as:
 	  terminated immediately.
 
 		- Assertions call the function:
-		  ``void __noreturn kunit_abort(struct kunit *)``.
+		  ``void __noreturn __kunit_abort(struct kunit *)``.
 
-		- ``kunit_abort`` calls the function:
+		- ``__kunit_abort`` calls the function:
 		  ``void __noreturn kunit_try_catch_throw(struct kunit_try_catch *try_catch)``.
 
 		- ``kunit_try_catch_throw`` calls the function: