Message ID | 20230810192128.1855570-1-axelrasmussen@google.com (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | [mm-unstable,fix] mm: userfaultfd: check for start + len overflow in validate_range: fix | expand |
On Thu, Aug 10, 2023 at 1:21 PM Axel Rasmussen <axelrasmussen@google.com> wrote: > > A previous fixup to this commit fixed one issue, but introduced another: > we're now overly strict when validating the src address for UFFDIO_COPY. > > Most of the validation in validate_range is useful to apply to src as > well as dst, but page alignment is only a requirement for dst, not src. > So, split the function up so src can use an "unaligned" variant, while > still allowing us to share the majority of the code between the > different cases. > > Reported-by: Ryan Roberts <ryan.roberts@arm.com> > Closes: https://lore.kernel.org/linux-mm/8fbb5965-28f7-4e9a-ac04-1406ed8fc2d4@arm.com/T/#t > Signed-off-by: Axel Rasmussen <axelrasmussen@google.com> Reviewed-by: Yu Zhao <yuzhao@google.com>
On Thu, Aug 10, 2023 at 12:21:28PM -0700, Axel Rasmussen wrote: > A previous fixup to this commit fixed one issue, but introduced another: > we're now overly strict when validating the src address for UFFDIO_COPY. > > Most of the validation in validate_range is useful to apply to src as > well as dst, but page alignment is only a requirement for dst, not src. > So, split the function up so src can use an "unaligned" variant, while > still allowing us to share the majority of the code between the > different cases. > > Reported-by: Ryan Roberts <ryan.roberts@arm.com> > Closes: https://lore.kernel.org/linux-mm/8fbb5965-28f7-4e9a-ac04-1406ed8fc2d4@arm.com/T/#t > Signed-off-by: Axel Rasmussen <axelrasmussen@google.com> Acked-by: Peter Xu <peterx@redhat.com>
diff --git a/fs/userfaultfd.c b/fs/userfaultfd.c index bb5c474a0a77..1091cb461747 100644 --- a/fs/userfaultfd.c +++ b/fs/userfaultfd.c @@ -1287,13 +1287,11 @@ static __always_inline void wake_userfault(struct userfaultfd_ctx *ctx, __wake_userfault(ctx, range); } -static __always_inline int validate_range(struct mm_struct *mm, - __u64 start, __u64 len) +static __always_inline int validate_unaligned_range( + struct mm_struct *mm, __u64 start, __u64 len) { __u64 task_size = mm->task_size; - if (start & ~PAGE_MASK) - return -EINVAL; if (len & ~PAGE_MASK) return -EINVAL; if (!len) @@ -1309,6 +1307,15 @@ static __always_inline int validate_range(struct mm_struct *mm, return 0; } +static __always_inline int validate_range(struct mm_struct *mm, + __u64 start, __u64 len) +{ + if (start & ~PAGE_MASK) + return -EINVAL; + + return validate_unaligned_range(mm, start, len); +} + static int userfaultfd_register(struct userfaultfd_ctx *ctx, unsigned long arg) { @@ -1759,7 +1766,8 @@ static int userfaultfd_copy(struct userfaultfd_ctx *ctx, sizeof(uffdio_copy)-sizeof(__s64))) goto out; - ret = validate_range(ctx->mm, uffdio_copy.src, uffdio_copy.len); + ret = validate_unaligned_range(ctx->mm, uffdio_copy.src, + uffdio_copy.len); if (ret) goto out; ret = validate_range(ctx->mm, uffdio_copy.dst, uffdio_copy.len);
A previous fixup to this commit fixed one issue, but introduced another: we're now overly strict when validating the src address for UFFDIO_COPY. Most of the validation in validate_range is useful to apply to src as well as dst, but page alignment is only a requirement for dst, not src. So, split the function up so src can use an "unaligned" variant, while still allowing us to share the majority of the code between the different cases. Reported-by: Ryan Roberts <ryan.roberts@arm.com> Closes: https://lore.kernel.org/linux-mm/8fbb5965-28f7-4e9a-ac04-1406ed8fc2d4@arm.com/T/#t Signed-off-by: Axel Rasmussen <axelrasmussen@google.com> --- fs/userfaultfd.c | 18 +++++++++++++----- 1 file changed, 13 insertions(+), 5 deletions(-) -- 2.41.0.640.ga95def55d0-goog