diff mbox series

[v4,2/2] selftests: tmpfs: Add kselftest support to tmpfs

Message ID 20241105202639.1977356-3-cvam0000@gmail.com (mailing list archive)
State New
Headers show
Series kselftest: tmpfs: Add ksft macros and skip if no root | expand

Commit Message

Shivam Chaudhary Nov. 5, 2024, 8:26 p.m. UTC
Replace direct error handling with 'ksft_test_result_*',
'ksft_print_msg' and KSFT_SKIP  macros for better reporting.

Test logs:

Before change:

- Without root
 error: unshare, errno 1

- With root
 No, output

After change:

- Without root
 TAP version 13
 1..1
  ok 1 # SKIP This test needs root to run

- With root
 TAP version 13
1..1
  unshare(): Creat new mount namespace: Success.
  mount(): Root filesystem private mount: Success
  mount(): Mounting tmpfs on /tmp: Success
  openat(): Open first temporary file: Success
  linkat(): Linking the temporary file: Success
  openat(): Opening the second temporary file: Success
  ok 1 Test : Success
  Totals: pass:1 fail:0 xfail:0 xpass:0 skip:0 error:0

Signed-off-by: Shivam Chaudhary <cvam0000@gmail.com>
---

 .../selftests/tmpfs/bug-link-o-tmpfile.c      | 66 ++++++++++++++-----
 1 file changed, 49 insertions(+), 17 deletions(-)

Comments

Shuah Khan Nov. 6, 2024, 5:01 p.m. UTC | #1
On 11/5/24 13:26, Shivam Chaudhary wrote:
> Replace direct error handling with 'ksft_test_result_*',
> 'ksft_print_msg' and KSFT_SKIP  macros for better reporting.
> 
> Test logs:
> 
> Before change:
> 
> - Without root
>   error: unshare, errno 1
> 
> - With root
>   No, output
> 
> After change:
> 
> - Without root
>   TAP version 13
>   1..1
>    ok 1 # SKIP This test needs root to run
> 
> - With root
>   TAP version 13
> 1..1
>    unshare(): Creat new mount namespace: Success.
>    mount(): Root filesystem private mount: Success
>    mount(): Mounting tmpfs on /tmp: Success
>    openat(): Open first temporary file: Success
>    linkat(): Linking the temporary file: Success
>    openat(): Opening the second temporary file: Success

This is too noisy - there is no need to add message in
every single conditional. Errors make sense, bot don't
add unnecessary messages.

>    ok 1 Test : Success
>    Totals: pass:1 fail:0 xfail:0 xpass:0 skip:0 error:0
> 
> Signed-off-by: Shivam Chaudhary <cvam0000@gmail.com>
> ---
> 
>   .../selftests/tmpfs/bug-link-o-tmpfile.c      | 66 ++++++++++++++-----
>   1 file changed, 49 insertions(+), 17 deletions(-)
> 
> diff --git a/tools/testing/selftests/tmpfs/bug-link-o-tmpfile.c b/tools/testing/selftests/tmpfs/bug-link-o-tmpfile.c
> index cdab1e8c0392..f2e6a5b20698 100644
> --- a/tools/testing/selftests/tmpfs/bug-link-o-tmpfile.c
> +++ b/tools/testing/selftests/tmpfs/bug-link-o-tmpfile.c
> @@ -42,39 +42,71 @@ int main(void)
>   
>   	if (unshare(CLONE_NEWNS) == -1) {
>   		if (errno == ENOSYS || errno == EPERM) {
> -			fprintf(stderr, "error: unshare, errno %d\n", errno);
> -			return 4;
> +			ksft_print_msg("unshare() error: unshare, errno %d\n", errno);
> +			exit(KSFT_SKIP);

Same comment - you can simply use approrpiare ksft_exit_*() routine.

> +
> +		}
> +		else{
> +			fprintf(stderr, "unshare() error: unshare, errno %d\n", errno);
> +			return 1;

Since you are converting the test to use KSFT_ codes,
why not change this one? Shound't this ksft_exit_fail_msg()


> +
>   		}
> -		fprintf(stderr, "error: unshare, errno %d\n", errno);
> -		return 1;

Since you are converting the test to use KSFT_ codes,
why not change this one? Shound't this ksft_exit_fail_msg()

> +	}
> +	
> +	else {
> +		ksft_print_msg("unshare(): Creat new mount namespace: Success.\n");

Spelling - did you tun checkpatch on this?

> +
>   	}
> -	if (mount(NULL, "/", NULL, MS_PRIVATE|MS_REC, NULL) == -1) {
> -		fprintf(stderr, "error: mount '/', errno %d\n", errno);
> -		return 1;

Since you are converting the test to use KSFT_ codes,
why not change this one? Shound't this ksft_exit_fail_msg()

Same comment on using KSFT_ codes consistently.

> +
> +
> +
> +	if (mount(NULL, "/", NULL, MS_PRIVATE | MS_REC, NULL) == -1) {
> +		ksft_print_msg("mount() error: Root filesystem private mount: Fail %d\n", errno);
> +		exit(KSFT_SKIP);

Why is this a skip?

Don't need two calls - ksft_exit_* calls

Since you are converting the test to use KSFT_ codes,
why not change this one? Shound't this ksft_exit_fail_msg()

> +	} else {
> +		ksft_print_msg("mount(): Root filesystem private mount: Success\n");

Is this message necessary?

>   	}
>   
> +
>   	/* Our heroes: 1 root inode, 1 O_TMPFILE inode, 1 permanent inode. */
>   	if (mount(NULL, "/tmp", "tmpfs", 0, "nr_inodes=3") == -1) {
> -		fprintf(stderr, "error: mount tmpfs, errno %d\n", errno);
> -		return 1;
> +		ksft_print_msg("mount() error: Mounting tmpfs on /tmp: Fail %d\n", errno);
> +		exit(KSFT_SKIP);
> +	} else {
> +		ksft_print_msg("mount(): Mounting tmpfs on /tmp: Success\n");
>   	}
>   
> -	fd = openat(AT_FDCWD, "/tmp", O_WRONLY|O_TMPFILE, 0600);
> +
> +	fd = openat(AT_FDCWD, "/tmp", O_WRONLY | O_TMPFILE, 0600);
>   	if (fd == -1) {
> -		fprintf(stderr, "error: open 1, errno %d\n", errno);
> -		return 1;
> +		ksft_print_msg("openat() error: Open first temporary file: Fail %d\n", errno);
> +		exit(KSFT_SKIP);
> +	} else {
> +		ksft_print_msg("openat(): Open first temporary file: Success\n");
>   	}
> +
> +
>   	if (linkat(fd, "", AT_FDCWD, "/tmp/1", AT_EMPTY_PATH) == -1) {
> -		fprintf(stderr, "error: linkat, errno %d\n", errno);
> -		return 1;
> +		ksft_print_msg("linkat() error: Linking the temporary file: Fail %d\n", errno);
> +		/* Ensure fd is closed on failure */
> +		close(fd);
> +		exit(KSFT_SKIP);
> +	} else {
> +		ksft_print_msg("linkat(): Linking the temporary file: Success\n");
>   	}
>   	close(fd);
>   
> -	fd = openat(AT_FDCWD, "/tmp", O_WRONLY|O_TMPFILE, 0600);
> +
> +	fd = openat(AT_FDCWD, "/tmp", O_WRONLY | O_TMPFILE, 0600);
>   	if (fd == -1) {
> -		fprintf(stderr, "error: open 2, errno %d\n", errno);
> -		return 1;
> +		ksft_print_msg("openat() error: Opening the second temporary file: Fail %d\n", errno);
> +		exit(KSFT_SKIP);
> +	} else {
> +		ksft_print_msg("openat(): Opening the second temporary file: Success\n");
>   	}
>   
> +    ksft_test_result_pass("Test : Success\n");

Why do you need a message additional message here.

> +	ksft_exit_pass();
>   	return 0;
>   }
> +


I didn't call out every single error path. Same comments apply
to all. Please get rid of unnecessary success path messages.

If the output is too noisy it is hard to read and understand.

thanks,
-- Shuah
diff mbox series

Patch

diff --git a/tools/testing/selftests/tmpfs/bug-link-o-tmpfile.c b/tools/testing/selftests/tmpfs/bug-link-o-tmpfile.c
index cdab1e8c0392..f2e6a5b20698 100644
--- a/tools/testing/selftests/tmpfs/bug-link-o-tmpfile.c
+++ b/tools/testing/selftests/tmpfs/bug-link-o-tmpfile.c
@@ -42,39 +42,71 @@  int main(void)
 
 	if (unshare(CLONE_NEWNS) == -1) {
 		if (errno == ENOSYS || errno == EPERM) {
-			fprintf(stderr, "error: unshare, errno %d\n", errno);
-			return 4;
+			ksft_print_msg("unshare() error: unshare, errno %d\n", errno);
+			exit(KSFT_SKIP);
+
+		}
+		else{
+			fprintf(stderr, "unshare() error: unshare, errno %d\n", errno);
+			return 1;
+
 		}
-		fprintf(stderr, "error: unshare, errno %d\n", errno);
-		return 1;
+	} 
+	
+	else {
+		ksft_print_msg("unshare(): Creat new mount namespace: Success.\n");
+
 	}
-	if (mount(NULL, "/", NULL, MS_PRIVATE|MS_REC, NULL) == -1) {
-		fprintf(stderr, "error: mount '/', errno %d\n", errno);
-		return 1;
+
+
+
+	if (mount(NULL, "/", NULL, MS_PRIVATE | MS_REC, NULL) == -1) {
+		ksft_print_msg("mount() error: Root filesystem private mount: Fail %d\n", errno);
+		exit(KSFT_SKIP);
+	} else {
+		ksft_print_msg("mount(): Root filesystem private mount: Success\n");
 	}
 
+
 	/* Our heroes: 1 root inode, 1 O_TMPFILE inode, 1 permanent inode. */
 	if (mount(NULL, "/tmp", "tmpfs", 0, "nr_inodes=3") == -1) {
-		fprintf(stderr, "error: mount tmpfs, errno %d\n", errno);
-		return 1;
+		ksft_print_msg("mount() error: Mounting tmpfs on /tmp: Fail %d\n", errno);
+		exit(KSFT_SKIP);
+	} else {
+		ksft_print_msg("mount(): Mounting tmpfs on /tmp: Success\n");
 	}
 
-	fd = openat(AT_FDCWD, "/tmp", O_WRONLY|O_TMPFILE, 0600);
+
+	fd = openat(AT_FDCWD, "/tmp", O_WRONLY | O_TMPFILE, 0600);
 	if (fd == -1) {
-		fprintf(stderr, "error: open 1, errno %d\n", errno);
-		return 1;
+		ksft_print_msg("openat() error: Open first temporary file: Fail %d\n", errno);
+		exit(KSFT_SKIP);
+	} else {
+		ksft_print_msg("openat(): Open first temporary file: Success\n");
 	}
+
+
 	if (linkat(fd, "", AT_FDCWD, "/tmp/1", AT_EMPTY_PATH) == -1) {
-		fprintf(stderr, "error: linkat, errno %d\n", errno);
-		return 1;
+		ksft_print_msg("linkat() error: Linking the temporary file: Fail %d\n", errno);
+		/* Ensure fd is closed on failure */
+		close(fd); 
+		exit(KSFT_SKIP);
+	} else {
+		ksft_print_msg("linkat(): Linking the temporary file: Success\n");
 	}
 	close(fd);
 
-	fd = openat(AT_FDCWD, "/tmp", O_WRONLY|O_TMPFILE, 0600);
+
+	fd = openat(AT_FDCWD, "/tmp", O_WRONLY | O_TMPFILE, 0600);
 	if (fd == -1) {
-		fprintf(stderr, "error: open 2, errno %d\n", errno);
-		return 1;
+		ksft_print_msg("openat() error: Opening the second temporary file: Fail %d\n", errno);
+		exit(KSFT_SKIP);
+	} else {
+		ksft_print_msg("openat(): Opening the second temporary file: Success\n");
 	}
 
+    ksft_test_result_pass("Test : Success\n");
+	ksft_exit_pass();
 	return 0;
 }
+