mbox series

[v4,0/3] int3472: Support GPIO con_id based on _HID

Message ID 20250131073707.1082931-1-sakari.ailus@linux.intel.com (mailing list archive)
Headers show
Series int3472: Support GPIO con_id based on _HID | expand

Message

Sakari Ailus Jan. 31, 2025, 7:37 a.m. UTC
Hi folks,

One patch turned into a set, the second patch being the original one.

since v3:

- Add a patch (first one) to switch to unsigned long type for polarity
  field and renames it as gpio_flags.

- Use a polarity_low boolean field for indicating the GPIO polarity. This
  is turned to gpio_flags in int3472_get_con_id_and_polarity().

- Put the new polarity_low bool field next to the u8's for better struct
  packing.

- Add a patch (last one) to rename "func" as "con_id" which is used
  throughout the GPIO framework.

Sakari Ailus (3):
  platform/x86: int3472: Use correct type for "polarity", call it
    gpio_flags
  platform/x86: int3472: Call "reset" GPIO "enable" for INT347E
  platform/x86: int3472: Call "func" "con_id" instead

 drivers/platform/x86/intel/int3472/discrete.c | 98 +++++++++++++------
 1 file changed, 68 insertions(+), 30 deletions(-)

Comments

Hans de Goede Jan. 31, 2025, 9:16 a.m. UTC | #1
Hi,

On 31-Jan-25 8:37 AM, Sakari Ailus wrote:
> Hi folks,
> 
> One patch turned into a set, the second patch being the original one.
> 
> since v3:
> 
> - Add a patch (first one) to switch to unsigned long type for polarity
>   field and renames it as gpio_flags.
> 
> - Use a polarity_low boolean field for indicating the GPIO polarity. This
>   is turned to gpio_flags in int3472_get_con_id_and_polarity().
> 
> - Put the new polarity_low bool field next to the u8's for better struct
>   packing.
> 
> - Add a patch (last one) to rename "func" as "con_id" which is used
>   throughout the GPIO framework.

Thanks the whole series looks good to me:

Reviewed-by: Hans de Goede <hdegoede@redhat.com>

for the series.

Regards,

Hans


p.s.

Did you see my remarks about rewriting the INT3472 code to have it
do all the power-sequencing itself in the "RFC: How to deal with the INT3472
handshake GPIO found on Intel IPU6 MTL?" thread ?
Andy Shevchenko Jan. 31, 2025, 11:24 a.m. UTC | #2
On Fri, Jan 31, 2025 at 09:37:04AM +0200, Sakari Ailus wrote:
> Hi folks,
> 
> One patch turned into a set, the second patch being the original one.
> 
> since v3:
> 
> - Add a patch (first one) to switch to unsigned long type for polarity
>   field and renames it as gpio_flags.
> 
> - Use a polarity_low boolean field for indicating the GPIO polarity. This
>   is turned to gpio_flags in int3472_get_con_id_and_polarity().
> 
> - Put the new polarity_low bool field next to the u8's for better struct
>   packing.
> 
> - Add a patch (last one) to rename "func" as "con_id" which is used
>   throughout the GPIO framework.

With a comment addressed in patch 2,
Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>