From patchwork Tue Aug 2 11:23:07 2016 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: "baolex.ni" X-Patchwork-Id: 9258887 Return-Path: Received: from mail.wl.linuxfoundation.org (pdx-wl-mail.web.codeaurora.org [172.30.200.125]) by pdx-korg-patchwork.web.codeaurora.org (Postfix) with ESMTP id BC4356089F for ; Tue, 2 Aug 2016 16:45:01 +0000 (UTC) Received: from mail.wl.linuxfoundation.org (localhost [127.0.0.1]) by mail.wl.linuxfoundation.org (Postfix) with ESMTP id AC3FC2857A for ; Tue, 2 Aug 2016 16:45:01 +0000 (UTC) Received: by mail.wl.linuxfoundation.org (Postfix, from userid 486) id A0CBC28578; Tue, 2 Aug 2016 16:45:01 +0000 (UTC) X-Spam-Checker-Version: SpamAssassin 3.3.1 (2010-03-16) on pdx-wl-mail.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-6.9 required=2.0 tests=BAYES_00,RCVD_IN_DNSWL_HI autolearn=ham version=3.3.1 Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.wl.linuxfoundation.org (Postfix) with ESMTP id 20F8728504 for ; Tue, 2 Aug 2016 16:45:00 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933737AbcHBQoq (ORCPT ); Tue, 2 Aug 2016 12:44:46 -0400 Received: from mga09.intel.com ([134.134.136.24]:7892 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S933410AbcHBMAv (ORCPT ); Tue, 2 Aug 2016 08:00:51 -0400 Received: from fmsmga003.fm.intel.com ([10.253.24.29]) by orsmga102.jf.intel.com with ESMTP; 02 Aug 2016 05:00:49 -0700 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="743077693" Received: from shsibuild003.sh.intel.com ([10.239.146.225]) by FMSMGA003.fm.intel.com with ESMTP; 02 Aug 2016 05:00:46 -0700 From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, hverkuil@xs4all.nl, s.nawrocki@samsung.com, kgene@kernel.org, k.kozlowski@samsung.com Cc: linux-media@vger.kernel.org, linux-kernel@vger.kernel.org, dan.carpenter@oracle.com, hans.verkuil@cisco.com, chuansheng.liu@intel.com, baolex.ni@intel.com, niklas.soderlund+renesas@ragnatech.se Subject: [PATCH 0548/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:23:07 +0800 Message-Id: <20160802112307.18501-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-media-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-media@vger.kernel.org X-Virus-Scanned: ClamAV using ClamSMTP I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/media/radio/wl128x/fmdrv_common.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/media/radio/wl128x/fmdrv_common.c b/drivers/media/radio/wl128x/fmdrv_common.c index 3f9e6df..9f80411 100644 --- a/drivers/media/radio/wl128x/fmdrv_common.c +++ b/drivers/media/radio/wl128x/fmdrv_common.c @@ -67,12 +67,12 @@ MODULE_PARM_DESC(default_radio_region, "Region: 0=Europe/US, 1=Japan"); /* RDS buffer blocks */ static u32 default_rds_buf = 300; -module_param(default_rds_buf, uint, 0444); +module_param(default_rds_buf, uint, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(default_rds_buf, "RDS buffer entries"); /* Radio Nr */ static u32 radio_nr = -1; -module_param(radio_nr, int, 0444); +module_param(radio_nr, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(radio_nr, "Radio Nr"); /* FM irq handlers forward declaration */