diff mbox series

[1/2] meson: Fix building with -Dv4l-utils=false

Message ID 20231212152418.20584-1-chewi@gentoo.org (mailing list archive)
State New
Headers show
Series [1/2] meson: Fix building with -Dv4l-utils=false | expand

Commit Message

James Le Cuirot Dec. 12, 2023, 3:24 p.m. UTC
ir_bpf_enabled was referenced without being defined.
---
 meson.build | 2 ++
 1 file changed, 2 insertions(+)

Comments

Peter Seiderer Dec. 13, 2023, 9:43 p.m. UTC | #1
On Tue, 12 Dec 2023 15:24:05 +0000, James Le Cuirot <chewi@gentoo.org> wrote:

> ir_bpf_enabled was referenced without being defined.
> ---
>  meson.build | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/meson.build b/meson.build
> index 03508bc8..d9689d35 100644
> --- a/meson.build
> +++ b/meson.build
> @@ -382,6 +382,8 @@ subdir('lib')
>  if get_option('v4l-utils')
>      subdir('utils')
>      subdir('contrib')
> +else
> +    ir_bpf_enabled = false
>  endif
>
>  subdir('doc')

Can confirm the following error/failure without the patch (using
buildroot where v4l-utils is known as libv4l package)

  .../libv4l-1.26.0/meson.build:406:32: ERROR: Unknown variable "ir_bpf_enabled".

and no error with the patch applied, so you can add my

Tested-by: Peter Seiderer <ps.report@gmx.net>

Regards,
Peter
diff mbox series

Patch

diff --git a/meson.build b/meson.build
index 03508bc8..d9689d35 100644
--- a/meson.build
+++ b/meson.build
@@ -382,6 +382,8 @@  subdir('lib')
 if get_option('v4l-utils')
     subdir('utils')
     subdir('contrib')
+else
+    ir_bpf_enabled = false
 endif
 
 subdir('doc')