Message ID | 20250210090725.4580-2-nas.chung@chipsnmedia.com (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | Add support for Wave6 video codec driver | expand |
On 10/02/2025 10:07, Nas Chung wrote: > The existing Kconfig parameter VIDEO_WAVE_VPU is ambiguous, > as it does not clearly indicate that it is specific to the Wave5 IP. > > Rename VIDEO_WAVE_VPU to VIDEO_WAVE5_VPU to make it explicit > that the parameter is specific to the Wave5 IP. > > No functional changes, only the parameter name is updated. That's unnecessary churn. Old name was fine. Kconfig does not match hardware 1-to-1 but represents only the driver name (or not even that...). If you solve any particular problem, then explain it. Otherwise this is just unnecessarily affecting users and backports. > > Signed-off-by: Nas Chung <nas.chung@chipsnmedia.com> > --- > arch/arm64/configs/defconfig | 2 +- That's a SoC patch, don't mix up subsystems. Best regards, Krzysztof
Hi, Krzysztof. >-----Original Message----- >From: Krzysztof Kozlowski <krzk@kernel.org> >Sent: Tuesday, February 11, 2025 2:24 AM >To: Nas Chung <nas.chung@chipsnmedia.com>; mchehab@kernel.org; >hverkuil@xs4all.nl; sebastian.fricke@collabora.com; robh@kernel.org; >krzk+dt@kernel.org; conor+dt@kernel.org >Cc: linux-media@vger.kernel.org; devicetree@vger.kernel.org; linux- >kernel@vger.kernel.org; linux-imx@nxp.com; linux-arm- >kernel@lists.infradead.org; jackson.lee <jackson.lee@chipsnmedia.com>; >lafley.kim <lafley.kim@chipsnmedia.com> >Subject: Re: [PATCH 1/8] media: platform: chips-media: wave5: Rename >Kconfig parameter > >On 10/02/2025 10:07, Nas Chung wrote: >> The existing Kconfig parameter VIDEO_WAVE_VPU is ambiguous, >> as it does not clearly indicate that it is specific to the Wave5 IP. >> >> Rename VIDEO_WAVE_VPU to VIDEO_WAVE5_VPU to make it explicit >> that the parameter is specific to the Wave5 IP. >> >> No functional changes, only the parameter name is updated. > > >That's unnecessary churn. Old name was fine. Kconfig does not match >hardware 1-to-1 but represents only the driver name (or not even that...). > >If you solve any particular problem, then explain it. Otherwise this is >just unnecessarily affecting users and backports. I understand your point. To avoid unnecessary changes, I'll drop this patch. Thank you for your feedback. Thanks. Nas. > >> >> Signed-off-by: Nas Chung <nas.chung@chipsnmedia.com> >> --- >> arch/arm64/configs/defconfig | 2 +- > >That's a SoC patch, don't mix up subsystems. > > >Best regards, >Krzysztof
diff --git a/arch/arm64/configs/defconfig b/arch/arm64/configs/defconfig index cb7da4415599..d904d4dc4f0d 100644 --- a/arch/arm64/configs/defconfig +++ b/arch/arm64/configs/defconfig @@ -837,7 +837,7 @@ CONFIG_VIDEO_AMPHION_VPU=m CONFIG_VIDEO_CADENCE_CSI2RX=m CONFIG_VIDEO_MEDIATEK_JPEG=m CONFIG_VIDEO_MEDIATEK_VCODEC=m -CONFIG_VIDEO_WAVE_VPU=m +CONFIG_VIDEO_WAVE5_VPU=m CONFIG_VIDEO_E5010_JPEG_ENC=m CONFIG_VIDEO_IMX7_CSI=m CONFIG_VIDEO_IMX_MIPI_CSIS=m diff --git a/drivers/media/platform/chips-media/wave5/Kconfig b/drivers/media/platform/chips-media/wave5/Kconfig index f1bcef5177bd..914720a35de8 100644 --- a/drivers/media/platform/chips-media/wave5/Kconfig +++ b/drivers/media/platform/chips-media/wave5/Kconfig @@ -1,6 +1,6 @@ # SPDX-License-Identifier: GPL-2.0 -config VIDEO_WAVE_VPU - tristate "Chips&Media Wave Codec Driver" +config VIDEO_WAVE5_VPU + tristate "Chips&Media Wave5 Codec Driver" depends on V4L_MEM2MEM_DRIVERS depends on VIDEO_DEV && OF depends on ARCH_K3 || COMPILE_TEST @@ -9,7 +9,7 @@ config VIDEO_WAVE_VPU select V4L2_MEM2MEM_DEV select GENERIC_ALLOCATOR help - Chips&Media stateful encoder and decoder driver. + Chips&Media Wave5 stateful encoder and decoder driver. The driver supports HEVC and H264 formats. To compile this driver as modules, choose M here: the modules will be called wave5. diff --git a/drivers/media/platform/chips-media/wave5/Makefile b/drivers/media/platform/chips-media/wave5/Makefile index 3d738a03bd8e..81be0e1dcebd 100644 --- a/drivers/media/platform/chips-media/wave5/Makefile +++ b/drivers/media/platform/chips-media/wave5/Makefile @@ -1,6 +1,6 @@ # SPDX-License-Identifier: GPL-2.0 -obj-$(CONFIG_VIDEO_WAVE_VPU) += wave5.o +obj-$(CONFIG_VIDEO_WAVE5_VPU) += wave5.o wave5-objs += wave5-hw.o \ wave5-vpuapi.o \ wave5-vdi.o \
The existing Kconfig parameter VIDEO_WAVE_VPU is ambiguous, as it does not clearly indicate that it is specific to the Wave5 IP. Rename VIDEO_WAVE_VPU to VIDEO_WAVE5_VPU to make it explicit that the parameter is specific to the Wave5 IP. No functional changes, only the parameter name is updated. Signed-off-by: Nas Chung <nas.chung@chipsnmedia.com> --- arch/arm64/configs/defconfig | 2 +- drivers/media/platform/chips-media/wave5/Kconfig | 6 +++--- drivers/media/platform/chips-media/wave5/Makefile | 2 +- 3 files changed, 5 insertions(+), 5 deletions(-)