diff mbox

[PATCHv4,13/25,media] dvb_net: add support for DVB net node at the media controller

Message ID 9c7ff55979e714f5ffb23a8a85bc2593d5b9350b.1423867976.git.mchehab@osg.samsung.com (mailing list archive)
State New, archived
Headers show

Commit Message

Mauro Carvalho Chehab Feb. 13, 2015, 10:57 p.m. UTC
Make the dvb core network support aware of the media controller and
register the corresponding devices.

Signed-off-by: Mauro Carvalho Chehab <mchehab@osg.samsung.com>

Comments

Hans Verkuil Feb. 16, 2015, 9:03 a.m. UTC | #1
On 02/13/2015 11:57 PM, Mauro Carvalho Chehab wrote:
> Make the dvb core network support aware of the media controller and
> register the corresponding devices.
> 
> Signed-off-by: Mauro Carvalho Chehab <mchehab@osg.samsung.com>
> 
> diff --git a/drivers/media/dvb-core/dvb_net.c b/drivers/media/dvb-core/dvb_net.c
> index 686d3277dad1..40990058b4bc 100644
> --- a/drivers/media/dvb-core/dvb_net.c
> +++ b/drivers/media/dvb-core/dvb_net.c
> @@ -1462,14 +1462,16 @@ static const struct file_operations dvb_net_fops = {
>  	.llseek = noop_llseek,
>  };
>  
> -static struct dvb_device dvbdev_net = {
> +static const struct dvb_device dvbdev_net = {
>  	.priv = NULL,
>  	.users = 1,
>  	.writers = 1,
> +#if defined(CONFIG_MEDIA_CONTROLLER_DVB)
> +	.name = "dvb net",

I would suggest 'dvb-net' rather than 'dvb net' with a space. That's a personal
preference, though.

Regards,

	Hans

> +#endif
>  	.fops = &dvb_net_fops,
>  };
>  
> -
>  void dvb_net_release (struct dvb_net *dvbnet)
>  {
>  	int i;
> 

--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Mauro Carvalho Chehab Feb. 16, 2015, 10:53 a.m. UTC | #2
Em Mon, 16 Feb 2015 10:03:51 +0100
Hans Verkuil <hverkuil@xs4all.nl> escreveu:

> On 02/13/2015 11:57 PM, Mauro Carvalho Chehab wrote:
> > Make the dvb core network support aware of the media controller and
> > register the corresponding devices.
> > 
> > Signed-off-by: Mauro Carvalho Chehab <mchehab@osg.samsung.com>

Thanks for reviewing this patch series!

> > 
> > diff --git a/drivers/media/dvb-core/dvb_net.c b/drivers/media/dvb-core/dvb_net.c
> > index 686d3277dad1..40990058b4bc 100644
> > --- a/drivers/media/dvb-core/dvb_net.c
> > +++ b/drivers/media/dvb-core/dvb_net.c
> > @@ -1462,14 +1462,16 @@ static const struct file_operations dvb_net_fops = {
> >  	.llseek = noop_llseek,
> >  };
> >  
> > -static struct dvb_device dvbdev_net = {
> > +static const struct dvb_device dvbdev_net = {
> >  	.priv = NULL,
> >  	.users = 1,
> >  	.writers = 1,
> > +#if defined(CONFIG_MEDIA_CONTROLLER_DVB)
> > +	.name = "dvb net",
> 
> I would suggest 'dvb-net' rather than 'dvb net' with a space. That's a personal
> preference, though.

Works for me. I'll write a patch changing the names to dvb-foo for the
DVB nodes.

Regards,
Mauro
--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/media/dvb-core/dvb_net.c b/drivers/media/dvb-core/dvb_net.c
index 686d3277dad1..40990058b4bc 100644
--- a/drivers/media/dvb-core/dvb_net.c
+++ b/drivers/media/dvb-core/dvb_net.c
@@ -1462,14 +1462,16 @@  static const struct file_operations dvb_net_fops = {
 	.llseek = noop_llseek,
 };
 
-static struct dvb_device dvbdev_net = {
+static const struct dvb_device dvbdev_net = {
 	.priv = NULL,
 	.users = 1,
 	.writers = 1,
+#if defined(CONFIG_MEDIA_CONTROLLER_DVB)
+	.name = "dvb net",
+#endif
 	.fops = &dvb_net_fops,
 };
 
-
 void dvb_net_release (struct dvb_net *dvbnet)
 {
 	int i;