diff mbox

[RFC,4/5] V4L2: Rename subdev field of struct v4l2_async_notifier

Message ID CA+V-a8t+tqvJXZrFUJ2sA2TM=7AM1U50h7aAfHze+yKnAzsYMw@mail.gmail.com (mailing list archive)
State New, archived
Headers show

Commit Message

Lad, Prabhakar July 23, 2013, 3:50 p.m. UTC
Hi Sylwester,

On Mon, Jul 22, 2013 at 11:34 PM, Sylwester Nawrocki
<s.nawrocki@samsung.com> wrote:
> This is a purely cosmetic change. Since the 'subdev' member
> points to an array of subdevs it seems more intuitive to name
> it in plural form.
>
> Signed-off-by: Sylwester Nawrocki <s.nawrocki@samsung.com>
> Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
> ---
>  drivers/media/platform/soc_camera/soc_camera.c |    2 +-
>  drivers/media/v4l2-core/v4l2-async.c           |    2 +-
>  include/media/v4l2-async.h                     |    4 ++--
>  3 files changed, 4 insertions(+), 4 deletions(-)
>

can you include the following changes in the same patch ?
so that git bisect doesn’t break.

(maybe you need to rebase the patches on
http://git.linuxtv.org/hverkuil/media_tree.git/shortlog/refs/heads/for-v3.12)

Regards,
--Prabhakar Lad

--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Comments

Hi Prabhakar,

On 07/23/2013 05:50 PM, Prabhakar Lad wrote:
> On Mon, Jul 22, 2013 at 11:34 PM, Sylwester Nawrocki
> <s.nawrocki@samsung.com> wrote:
>> This is a purely cosmetic change. Since the 'subdev' member
>> points to an array of subdevs it seems more intuitive to name
>> it in plural form.
>>
>> Signed-off-by: Sylwester Nawrocki <s.nawrocki@samsung.com>
>> Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
>> ---
>>  drivers/media/platform/soc_camera/soc_camera.c |    2 +-
>>  drivers/media/v4l2-core/v4l2-async.c           |    2 +-
>>  include/media/v4l2-async.h                     |    4 ++--
>>  3 files changed, 4 insertions(+), 4 deletions(-)
>>
> 
> can you include the following changes in the same patch ?
> so that git bisect doesn’t break.
> 
> (maybe you need to rebase the patches on
> http://git.linuxtv.org/hverkuil/media_tree.git/shortlog/refs/heads/for-v3.12)

Thanks for your testing and Ack. I'll wait couple days to also
let other take a look and review the patches. I'm not going to
try to merge that without at least Guennadi's Ack ;)

I think the best is to wait until the above patches from Hans'
tree get merged to the media master branch. Then I would rebase
my series on top of that before sending any pull request.

Regards,
Sylwester

> diff --git a/drivers/media/platform/davinci/vpif_capture.c
> b/drivers/media/platform/davinci/vpif_capture.c
> index b11d7a7..7fbde6d 100644
> --- a/drivers/media/platform/davinci/vpif_capture.c
> +++ b/drivers/media/platform/davinci/vpif_capture.c
> @@ -2168,7 +2168,7 @@ static __init int vpif_probe(struct platform_device *pdev)
>  		}
>  		vpif_probe_complete();
>  	} else {
> -		vpif_obj.notifier.subdev = vpif_obj.config->asd;
> +		vpif_obj.notifier.subdevs = vpif_obj.config->asd;
>  		vpif_obj.notifier.num_subdevs = vpif_obj.config->asd_sizes[0];
>  		vpif_obj.notifier.bound = vpif_async_bound;
>  		vpif_obj.notifier.complete = vpif_async_complete;
> diff --git a/drivers/media/platform/davinci/vpif_display.c
> b/drivers/media/platform/davinci/vpif_display.c
> index c2ff067..6336dfc 100644
> --- a/drivers/media/platform/davinci/vpif_display.c
> +++ b/drivers/media/platform/davinci/vpif_display.c
> @@ -1832,7 +1832,7 @@ static __init int vpif_probe(struct platform_device *pdev)
>  		}
>  		vpif_probe_complete();
>  	} else {
> -		vpif_obj.notifier.subdev = vpif_obj.config->asd;
> +		vpif_obj.notifier.subdevs = vpif_obj.config->asd;
>  		vpif_obj.notifier.num_subdevs = vpif_obj.config->asd_sizes[0];
>  		vpif_obj.notifier.bound = vpif_async_bound;
>  		vpif_obj.notifier.complete = vpif_async_complete;
--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/media/platform/davinci/vpif_capture.c
b/drivers/media/platform/davinci/vpif_capture.c
index b11d7a7..7fbde6d 100644
--- a/drivers/media/platform/davinci/vpif_capture.c
+++ b/drivers/media/platform/davinci/vpif_capture.c
@@ -2168,7 +2168,7 @@  static __init int vpif_probe(struct platform_device *pdev)
 		}
 		vpif_probe_complete();
 	} else {
-		vpif_obj.notifier.subdev = vpif_obj.config->asd;
+		vpif_obj.notifier.subdevs = vpif_obj.config->asd;
 		vpif_obj.notifier.num_subdevs = vpif_obj.config->asd_sizes[0];
 		vpif_obj.notifier.bound = vpif_async_bound;
 		vpif_obj.notifier.complete = vpif_async_complete;
diff --git a/drivers/media/platform/davinci/vpif_display.c
b/drivers/media/platform/davinci/vpif_display.c
index c2ff067..6336dfc 100644
--- a/drivers/media/platform/davinci/vpif_display.c
+++ b/drivers/media/platform/davinci/vpif_display.c
@@ -1832,7 +1832,7 @@  static __init int vpif_probe(struct platform_device *pdev)
 		}
 		vpif_probe_complete();
 	} else {
-		vpif_obj.notifier.subdev = vpif_obj.config->asd;
+		vpif_obj.notifier.subdevs = vpif_obj.config->asd;
 		vpif_obj.notifier.num_subdevs = vpif_obj.config->asd_sizes[0];
 		vpif_obj.notifier.bound = vpif_async_bound;
 		vpif_obj.notifier.complete = vpif_async_complete;