mbox series

[00/14] arch: make PxD_ORDER generically available

Message ID 20220703141203.147893-1-rppt@kernel.org (mailing list archive)
Headers show
Series arch: make PxD_ORDER generically available | expand

Message

Mike Rapoport July 3, 2022, 2:11 p.m. UTC
From: Mike Rapoport <rppt@linux.ibm.com>

Hi,

The question what does PxD_ORDER define raises from time to time and
there is still a conflict between MIPS and DAX definitions.

Some time ago Matthew Wilcox suggested to use PMD_TABLE_ORDER to define
the order of page table allocation: 

[1] https://lore.kernel.org/linux-arch/YPCJftSTUBEnq2lI@casper.infradead.org/

The parisc patch made it in, but mips didn't. 
Now mips defines from asm/include/pgtable.h were copied to loongarch which
made it worse.

Let's deal with it once and for all and rename PxD_ORDER defines to
PxD_TABLE_ORDER or just drop them when the only possible order of page
table is 0.

I think the best way to merge this via mm tree with acks from arch
maintainers.

Matthew Wilcox (Oracle) (1):
  mips: Rename PMD_ORDER to PMD_TABLE_ORDER

Mike Rapoport (13):
  csky: drop definition of PTE_ORDER
  csky: drop definition of PGD_ORDER
  mips: Rename PUD_ORDER to PUD_TABLE_ORDER
  mips: drop definitions of PTE_ORDER
  mips: Rename PGD_ORDER to PGD_TABLE_ORDER
  nios2: drop definition of PTE_ORDER
  nios2: drop definition of PGD_ORDER
  loongarch: drop definition of PTE_ORDER
  loongarch: drop definition of PMD_ORDER
  loongarch: drop definition of PUD_ORDER
  loongarch: drop definition of PGD_ORDER
  parisc: Rename PGD_ORDER to PGD_TABLE_ORDER
  xtensa: drop definition of PGD_ORDER

 arch/csky/include/asm/pgalloc.h      |  2 +-
 arch/csky/include/asm/pgtable.h      |  6 +--
 arch/loongarch/include/asm/pgalloc.h |  6 +--
 arch/loongarch/include/asm/pgtable.h | 27 +++++-------
 arch/loongarch/kernel/asm-offsets.c  |  5 ---
 arch/loongarch/mm/pgtable.c          |  2 +-
 arch/loongarch/mm/tlbex.S            |  6 +--
 arch/mips/include/asm/pgalloc.h      |  8 ++--
 arch/mips/include/asm/pgtable-32.h   | 19 ++++-----
 arch/mips/include/asm/pgtable-64.h   | 61 +++++++++++++---------------
 arch/mips/kernel/asm-offsets.c       |  5 ---
 arch/mips/kvm/mmu.c                  |  2 +-
 arch/mips/mm/pgtable.c               |  2 +-
 arch/mips/mm/tlbex.c                 | 14 +++----
 arch/nios2/include/asm/pgtable.h     |  7 +---
 arch/nios2/mm/init.c                 |  5 +--
 arch/nios2/mm/pgtable.c              |  2 +-
 arch/parisc/include/asm/pgalloc.h    |  6 +--
 arch/parisc/include/asm/pgtable.h    |  8 ++--
 arch/xtensa/include/asm/pgalloc.h    |  2 +-
 arch/xtensa/include/asm/pgtable.h    |  1 -
 21 files changed, 84 insertions(+), 112 deletions(-)


base-commit: 03c765b0e3b4cb5063276b086c76f7a612856a9a

Comments

Helge Deller July 3, 2022, 2:27 p.m. UTC | #1
On 7/3/22 16:11, Mike Rapoport wrote:
> From: Mike Rapoport <rppt@linux.ibm.com>
>
> Hi,
>
> The question what does PxD_ORDER define raises from time to time and
> there is still a conflict between MIPS and DAX definitions.
>
> Some time ago Matthew Wilcox suggested to use PMD_TABLE_ORDER to define
> the order of page table allocation:
>
> [1] https://lore.kernel.org/linux-arch/YPCJftSTUBEnq2lI@casper.infradead.org/
>
> The parisc patch made it in, but mips didn't.
> Now mips defines from asm/include/pgtable.h were copied to loongarch which
> made it worse.
>
> Let's deal with it once and for all and rename PxD_ORDER defines to
> PxD_TABLE_ORDER or just drop them when the only possible order of page
> table is 0.
>
> I think the best way to merge this via mm tree with acks from arch
> maintainers.

That's fine for me.

Acked-by: Helge Deller <deller@gmx.de> # parisc

Thanks!
Helge



> Matthew Wilcox (Oracle) (1):
>   mips: Rename PMD_ORDER to PMD_TABLE_ORDER
>
> Mike Rapoport (13):
>   csky: drop definition of PTE_ORDER
>   csky: drop definition of PGD_ORDER
>   mips: Rename PUD_ORDER to PUD_TABLE_ORDER
>   mips: drop definitions of PTE_ORDER
>   mips: Rename PGD_ORDER to PGD_TABLE_ORDER
>   nios2: drop definition of PTE_ORDER
>   nios2: drop definition of PGD_ORDER
>   loongarch: drop definition of PTE_ORDER
>   loongarch: drop definition of PMD_ORDER
>   loongarch: drop definition of PUD_ORDER
>   loongarch: drop definition of PGD_ORDER
>   parisc: Rename PGD_ORDER to PGD_TABLE_ORDER
>   xtensa: drop definition of PGD_ORDER
>
>  arch/csky/include/asm/pgalloc.h      |  2 +-
>  arch/csky/include/asm/pgtable.h      |  6 +--
>  arch/loongarch/include/asm/pgalloc.h |  6 +--
>  arch/loongarch/include/asm/pgtable.h | 27 +++++-------
>  arch/loongarch/kernel/asm-offsets.c  |  5 ---
>  arch/loongarch/mm/pgtable.c          |  2 +-
>  arch/loongarch/mm/tlbex.S            |  6 +--
>  arch/mips/include/asm/pgalloc.h      |  8 ++--
>  arch/mips/include/asm/pgtable-32.h   | 19 ++++-----
>  arch/mips/include/asm/pgtable-64.h   | 61 +++++++++++++---------------
>  arch/mips/kernel/asm-offsets.c       |  5 ---
>  arch/mips/kvm/mmu.c                  |  2 +-
>  arch/mips/mm/pgtable.c               |  2 +-
>  arch/mips/mm/tlbex.c                 | 14 +++----
>  arch/nios2/include/asm/pgtable.h     |  7 +---
>  arch/nios2/mm/init.c                 |  5 +--
>  arch/nios2/mm/pgtable.c              |  2 +-
>  arch/parisc/include/asm/pgalloc.h    |  6 +--
>  arch/parisc/include/asm/pgtable.h    |  8 ++--
>  arch/xtensa/include/asm/pgalloc.h    |  2 +-
>  arch/xtensa/include/asm/pgtable.h    |  1 -
>  21 files changed, 84 insertions(+), 112 deletions(-)
>
>
> base-commit: 03c765b0e3b4cb5063276b086c76f7a612856a9a
Huacai Chen July 4, 2022, 12:40 a.m. UTC | #2
Acked-by: Huacai Chen <chenhuacai@kernel.org> # LoongArch

On Sun, Jul 3, 2022 at 10:28 PM Helge Deller <deller@gmx.de> wrote:
>
> On 7/3/22 16:11, Mike Rapoport wrote:
> > From: Mike Rapoport <rppt@linux.ibm.com>
> >
> > Hi,
> >
> > The question what does PxD_ORDER define raises from time to time and
> > there is still a conflict between MIPS and DAX definitions.
> >
> > Some time ago Matthew Wilcox suggested to use PMD_TABLE_ORDER to define
> > the order of page table allocation:
> >
> > [1] https://lore.kernel.org/linux-arch/YPCJftSTUBEnq2lI@casper.infradead.org/
> >
> > The parisc patch made it in, but mips didn't.
> > Now mips defines from asm/include/pgtable.h were copied to loongarch which
> > made it worse.
> >
> > Let's deal with it once and for all and rename PxD_ORDER defines to
> > PxD_TABLE_ORDER or just drop them when the only possible order of page
> > table is 0.
> >
> > I think the best way to merge this via mm tree with acks from arch
> > maintainers.
>
> That's fine for me.
>
> Acked-by: Helge Deller <deller@gmx.de> # parisc
>
> Thanks!
> Helge
>
>
>
> > Matthew Wilcox (Oracle) (1):
> >   mips: Rename PMD_ORDER to PMD_TABLE_ORDER
> >
> > Mike Rapoport (13):
> >   csky: drop definition of PTE_ORDER
> >   csky: drop definition of PGD_ORDER
> >   mips: Rename PUD_ORDER to PUD_TABLE_ORDER
> >   mips: drop definitions of PTE_ORDER
> >   mips: Rename PGD_ORDER to PGD_TABLE_ORDER
> >   nios2: drop definition of PTE_ORDER
> >   nios2: drop definition of PGD_ORDER
> >   loongarch: drop definition of PTE_ORDER
> >   loongarch: drop definition of PMD_ORDER
> >   loongarch: drop definition of PUD_ORDER
> >   loongarch: drop definition of PGD_ORDER
> >   parisc: Rename PGD_ORDER to PGD_TABLE_ORDER
> >   xtensa: drop definition of PGD_ORDER
> >
> >  arch/csky/include/asm/pgalloc.h      |  2 +-
> >  arch/csky/include/asm/pgtable.h      |  6 +--
> >  arch/loongarch/include/asm/pgalloc.h |  6 +--
> >  arch/loongarch/include/asm/pgtable.h | 27 +++++-------
> >  arch/loongarch/kernel/asm-offsets.c  |  5 ---
> >  arch/loongarch/mm/pgtable.c          |  2 +-
> >  arch/loongarch/mm/tlbex.S            |  6 +--
> >  arch/mips/include/asm/pgalloc.h      |  8 ++--
> >  arch/mips/include/asm/pgtable-32.h   | 19 ++++-----
> >  arch/mips/include/asm/pgtable-64.h   | 61 +++++++++++++---------------
> >  arch/mips/kernel/asm-offsets.c       |  5 ---
> >  arch/mips/kvm/mmu.c                  |  2 +-
> >  arch/mips/mm/pgtable.c               |  2 +-
> >  arch/mips/mm/tlbex.c                 | 14 +++----
> >  arch/nios2/include/asm/pgtable.h     |  7 +---
> >  arch/nios2/mm/init.c                 |  5 +--
> >  arch/nios2/mm/pgtable.c              |  2 +-
> >  arch/parisc/include/asm/pgalloc.h    |  6 +--
> >  arch/parisc/include/asm/pgtable.h    |  8 ++--
> >  arch/xtensa/include/asm/pgalloc.h    |  2 +-
> >  arch/xtensa/include/asm/pgtable.h    |  1 -
> >  21 files changed, 84 insertions(+), 112 deletions(-)
> >
> >
> > base-commit: 03c765b0e3b4cb5063276b086c76f7a612856a9a
>
Guo Ren July 4, 2022, 1:45 a.m. UTC | #3
For csky part.

Acked-by: Guo Ren <guoren@kernel.org>

On Mon, Jul 4, 2022 at 8:40 AM Huacai Chen <chenhuacai@kernel.org> wrote:
>
> Acked-by: Huacai Chen <chenhuacai@kernel.org> # LoongArch
>
> On Sun, Jul 3, 2022 at 10:28 PM Helge Deller <deller@gmx.de> wrote:
> >
> > On 7/3/22 16:11, Mike Rapoport wrote:
> > > From: Mike Rapoport <rppt@linux.ibm.com>
> > >
> > > Hi,
> > >
> > > The question what does PxD_ORDER define raises from time to time and
> > > there is still a conflict between MIPS and DAX definitions.
> > >
> > > Some time ago Matthew Wilcox suggested to use PMD_TABLE_ORDER to define
> > > the order of page table allocation:
> > >
> > > [1] https://lore.kernel.org/linux-arch/YPCJftSTUBEnq2lI@casper.infradead.org/
> > >
> > > The parisc patch made it in, but mips didn't.
> > > Now mips defines from asm/include/pgtable.h were copied to loongarch which
> > > made it worse.
> > >
> > > Let's deal with it once and for all and rename PxD_ORDER defines to
> > > PxD_TABLE_ORDER or just drop them when the only possible order of page
> > > table is 0.
> > >
> > > I think the best way to merge this via mm tree with acks from arch
> > > maintainers.
> >
> > That's fine for me.
> >
> > Acked-by: Helge Deller <deller@gmx.de> # parisc
> >
> > Thanks!
> > Helge
> >
> >
> >
> > > Matthew Wilcox (Oracle) (1):
> > >   mips: Rename PMD_ORDER to PMD_TABLE_ORDER
> > >
> > > Mike Rapoport (13):
> > >   csky: drop definition of PTE_ORDER
> > >   csky: drop definition of PGD_ORDER
> > >   mips: Rename PUD_ORDER to PUD_TABLE_ORDER
> > >   mips: drop definitions of PTE_ORDER
> > >   mips: Rename PGD_ORDER to PGD_TABLE_ORDER
> > >   nios2: drop definition of PTE_ORDER
> > >   nios2: drop definition of PGD_ORDER
> > >   loongarch: drop definition of PTE_ORDER
> > >   loongarch: drop definition of PMD_ORDER
> > >   loongarch: drop definition of PUD_ORDER
> > >   loongarch: drop definition of PGD_ORDER
> > >   parisc: Rename PGD_ORDER to PGD_TABLE_ORDER
> > >   xtensa: drop definition of PGD_ORDER
> > >
> > >  arch/csky/include/asm/pgalloc.h      |  2 +-
> > >  arch/csky/include/asm/pgtable.h      |  6 +--
> > >  arch/loongarch/include/asm/pgalloc.h |  6 +--
> > >  arch/loongarch/include/asm/pgtable.h | 27 +++++-------
> > >  arch/loongarch/kernel/asm-offsets.c  |  5 ---
> > >  arch/loongarch/mm/pgtable.c          |  2 +-
> > >  arch/loongarch/mm/tlbex.S            |  6 +--
> > >  arch/mips/include/asm/pgalloc.h      |  8 ++--
> > >  arch/mips/include/asm/pgtable-32.h   | 19 ++++-----
> > >  arch/mips/include/asm/pgtable-64.h   | 61 +++++++++++++---------------
> > >  arch/mips/kernel/asm-offsets.c       |  5 ---
> > >  arch/mips/kvm/mmu.c                  |  2 +-
> > >  arch/mips/mm/pgtable.c               |  2 +-
> > >  arch/mips/mm/tlbex.c                 | 14 +++----
> > >  arch/nios2/include/asm/pgtable.h     |  7 +---
> > >  arch/nios2/mm/init.c                 |  5 +--
> > >  arch/nios2/mm/pgtable.c              |  2 +-
> > >  arch/parisc/include/asm/pgalloc.h    |  6 +--
> > >  arch/parisc/include/asm/pgtable.h    |  8 ++--
> > >  arch/xtensa/include/asm/pgalloc.h    |  2 +-
> > >  arch/xtensa/include/asm/pgtable.h    |  1 -
> > >  21 files changed, 84 insertions(+), 112 deletions(-)
> > >
> > >
> > > base-commit: 03c765b0e3b4cb5063276b086c76f7a612856a9a
> >