mbox series

[v2,00/16] A few cleanup patches for huge_memory

Message ID 20220628132835.8925-1-linmiaohe@huawei.com (mailing list archive)
Headers show
Series A few cleanup patches for huge_memory | expand

Message

Miaohe Lin June 28, 2022, 1:28 p.m. UTC
Hi everyone,
This series contains a few cleaup patches to remove duplicated codes,
add/use helper functions, fix some obsolete comments and so on. More
details can be found in the respective changelogs. Thanks!
---
v2
  This patch set is rebased on linux-next-20220628.
  Collect Reviewed-by tag and Acked-by per Muchun and Zach. Thanks.
  fix typo in 3/16
  replace last parameter of touch_p[u|m]d to bool
  split "mm/huge_memory: minor cleanup for split_huge_pages_pid"
  drop "mm/huge_memory: add helper __get_deferred_split_queue"
  enhance comment of page_deferred_list
v1
  This patch set is based on linux-next-20220621.
---
Miaohe Lin (16):
  mm/huge_memory: use flush_pmd_tlb_range in move_huge_pmd
  mm/huge_memory: access vm_page_prot with READ_ONCE in
    remove_migration_pmd
  mm/huge_memory: fix comment of __pud_trans_huge_lock
  mm/huge_memory: use helper touch_pud in huge_pud_set_accessed
  mm/huge_memory: use helper touch_pmd in huge_pmd_set_accessed
  mm/huge_memory: rename mmun_start to haddr in remove_migration_pmd
  mm/huge_memory: use helper function vma_lookup in split_huge_pages_pid
  mm/huge_memory: use helper macro __ATTR_RW
  mm/huge_memory: fix comment in zap_huge_pud
  mm/huge_memory: check pmd_present first in is_huge_zero_pmd
  mm/huge_memory: try to free subpage in swapcache when possible
  mm/huge_memory: minor cleanup for split_huge_pages_all
  mm/huge_memory: fix comment of page_deferred_list
  mm/huge_memory: correct comment of prep_transhuge_page
  mm/huge_memory: comment the subtly logic in __split_huge_pmd
  mm/huge_memory: use helper macro IS_ERR_OR_NULL in
    split_huge_pages_pid

 include/linux/huge_mm.h |  6 +--
 mm/huge_memory.c        | 90 +++++++++++++++++------------------------
 2 files changed, 40 insertions(+), 56 deletions(-)