mbox series

[mm-unstable,v4,0/6] Convert various mempolicy.c functions to use folios

Message ID 20230130201833.27042-1-vishal.moola@gmail.com (mailing list archive)
Headers show
Series Convert various mempolicy.c functions to use folios | expand

Message

Vishal Moola Jan. 30, 2023, 8:18 p.m. UTC
This patch series converts migrate_page_add() and queue_pages_required()
to migrate_folio_add() and queue_page_required(). It also converts the
callers of the functions to use folios as well, and introduces a helper
function to estimate the number of sharers of a folio.

---
v4:
  - Rebase on latest mm-unstable
  - Rename folio_estimated_mapcount() to folio_estimated_sharers()

v3:
  - Move folio_estimated_mapcount() to fix build warnings
  - Add comments to folio_estimated_mapcount() to make its function and
purpose clear

v2:
  - Introduce folio_estimated_mapcount() to replace page_mapcount() in
migrate_page_add() and queue_pages_hugetlb().
  - Elaborate on the comments to make it clear what the mapcount check is
for and why it is being done this way.

Vishal Moola (Oracle) (6):
  mm: add folio_estimated_sharers()
  mm/mempolicy: convert queue_pages_pmd() to queue_folios_pmd()
  mm/mempolicy: convert queue_pages_pte_range() to
    queue_folios_pte_range()
  mm/mempolicy: convert queue_pages_hugetlb() to queue_folios_hugetlb()
  mm/mempolicy: convert queue_pages_required() to queue_folio_required()
  mm/mempolicy: convert migrate_page_add() to migrate_folio_add()

 include/linux/mm.h |  18 +++++++
 mm/mempolicy.c     | 122 ++++++++++++++++++++++++---------------------
 2 files changed, 83 insertions(+), 57 deletions(-)