mbox series

[0/2] mm: zswap: simplify zswap_swapoff()

Message ID 20240120024007.2850671-1-yosryahmed@google.com (mailing list archive)
Headers show
Series mm: zswap: simplify zswap_swapoff() | expand

Message

Yosry Ahmed Jan. 20, 2024, 2:40 a.m. UTC
This mini-series simplifies aims to zswap_swapoff(), which should
simplify in progress work touching it (zswap tree split, rbtree to
xarray conversion).

Patch 1 is a code readability change in the core swap code that makes
patch 2 (the actual simplification) more obviously correct.

Yosry Ahmed (2):
  mm: swap: update inuse_pages after all cleanups are done
  mm: zswap: remove unnecessary tree cleanups in zswap_swapoff()

 mm/swapfile.c | 4 ++--
 mm/zswap.c    | 9 ++-------
 2 files changed, 4 insertions(+), 9 deletions(-)