From patchwork Mon Aug 12 18:22:46 2024 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Danilo Krummrich X-Patchwork-Id: 13760918 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from kanga.kvack.org (kanga.kvack.org [205.233.56.17]) by smtp.lore.kernel.org (Postfix) with ESMTP id 54A83C52D7C for ; Mon, 12 Aug 2024 18:24:18 +0000 (UTC) Received: by kanga.kvack.org (Postfix) id 4EC396B009F; Mon, 12 Aug 2024 14:24:17 -0400 (EDT) Received: by kanga.kvack.org (Postfix, from userid 40) id 49A9F6B00A4; Mon, 12 Aug 2024 14:24:17 -0400 (EDT) X-Delivered-To: int-list-linux-mm@kvack.org Received: by kanga.kvack.org (Postfix, from userid 63042) id 388996B00A3; Mon, 12 Aug 2024 14:24:17 -0400 (EDT) X-Delivered-To: linux-mm@kvack.org Received: from relay.hostedemail.com (smtprelay0011.hostedemail.com [216.40.44.11]) by kanga.kvack.org (Postfix) with ESMTP id 1E4096B008C for ; Mon, 12 Aug 2024 14:24:17 -0400 (EDT) Received: from smtpin15.hostedemail.com (a10.router.float.18 [10.200.18.1]) by unirelay08.hostedemail.com (Postfix) with ESMTP id 9A64C140349 for ; Mon, 12 Aug 2024 18:24:16 +0000 (UTC) X-FDA: 82444418112.15.EA0E0DB Received: from sin.source.kernel.org (sin.source.kernel.org [145.40.73.55]) by imf11.hostedemail.com (Postfix) with ESMTP id 69D7F40018 for ; Mon, 12 Aug 2024 18:24:12 +0000 (UTC) Authentication-Results: imf11.hostedemail.com; dkim=pass header.d=kernel.org header.s=k20201202 header.b=KM5IskO0; spf=pass (imf11.hostedemail.com: domain of dakr@kernel.org designates 145.40.73.55 as permitted sender) smtp.mailfrom=dakr@kernel.org; dmarc=pass (policy=none) header.from=kernel.org ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=hostedemail.com; s=arc-20220608; t=1723486984; h=from:from:sender:reply-to:subject:subject:date:date: message-id:message-id:to:to:cc:cc:mime-version:mime-version: content-type:content-transfer-encoding:content-transfer-encoding: in-reply-to:references:dkim-signature; bh=9u6CcdBhonYraB0GlESD41U7UTNR9tF4ITpEApdMlBM=; b=nPHv1Bi9LfbG7Vp8Dl1vYYTafRfBm4uB2DH4j07rZSqcVmZJF3i//UKZY1ut0dNssufwlH SYuW8Wl2Db/0Yw8S9Zg+Ig9yreUoVTLg2NP0qlBzzidZ7s2I7NgUUfEbUvrou52UTq9HeX ik1Mlw9Hki2KDHreP2lskZeZniBaQSs= ARC-Seal: i=1; s=arc-20220608; d=hostedemail.com; t=1723486984; a=rsa-sha256; cv=none; b=fq3OYXb46gLk98Q2dTyAH6UaeueqCNfoea9EiBkGyqUTD0Pk63qHIb0m61jVdFv3fd19T1 2RpgnFICcFFnfyc/sygWgsoROY07/pxlnGg1vp36g1L/KdpiCMnXt0HaXXZc2ltEegFKfp JaXXF71y2IVih6RXiB0tbrc+3Optb/s= ARC-Authentication-Results: i=1; imf11.hostedemail.com; dkim=pass header.d=kernel.org header.s=k20201202 header.b=KM5IskO0; spf=pass (imf11.hostedemail.com: domain of dakr@kernel.org designates 145.40.73.55 as permitted sender) smtp.mailfrom=dakr@kernel.org; dmarc=pass (policy=none) header.from=kernel.org Received: from smtp.kernel.org (transwarp.subspace.kernel.org [100.75.92.58]) by sin.source.kernel.org (Postfix) with ESMTP id E5FDCCE102B; Mon, 12 Aug 2024 18:24:08 +0000 (UTC) Received: by smtp.kernel.org (Postfix) with ESMTPSA id 307A9C32782; Mon, 12 Aug 2024 18:24:02 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=k20201202; t=1723487048; bh=Ns1h3gXj/2arkX/lA6BIN0gq6mOxbC6136FhiLGYvHM=; h=From:To:Cc:Subject:Date:From; b=KM5IskO0lNYHsDR3hyluPlh0rgfrOmPOhbYF1Bt7eli16lFLXmwZL7pVsiScXpUJd xLEutTUU5FaS7tEKNsaUJDNb4Um4G5S5vNYxTeHsD7hu565+FZuDtqcMNhjk3e42oA ZriexdH3zlHiCR8Dcv82wC0ISV+me7+ZWzrOP2RqZw7YkyxBUEW0gDY7jce9ADGiMa xnxwVCM5hnamtZzkWUbOFFMcXbbCYuVnsFqRkl9N46v1gL1NxhbntvnHVT3xouAxOI H2nsiH/UOXYAo7I9JLA388J9XS5xTsDhQvhUbtCT9aJmLEv4XaIYAA3AX+nef/rTSe J3jCcS85vmjdg== From: Danilo Krummrich To: ojeda@kernel.org, alex.gaynor@gmail.com, wedsonaf@gmail.com, boqun.feng@gmail.com, gary@garyguo.net, bjorn3_gh@protonmail.com, benno.lossin@proton.me, a.hindborg@samsung.com, aliceryhl@google.com, akpm@linux-foundation.org Cc: daniel.almeida@collabora.com, faith.ekstrand@collabora.com, boris.brezillon@collabora.com, lina@asahilina.net, mcanal@igalia.com, zhiw@nvidia.com, cjia@nvidia.com, jhubbard@nvidia.com, airlied@redhat.com, ajanulgu@redhat.com, lyude@redhat.com, linux-kernel@vger.kernel.org, rust-for-linux@vger.kernel.org, linux-mm@kvack.org, Danilo Krummrich Subject: [PATCH v5 00/26] Generic `Allocator` support for Rust Date: Mon, 12 Aug 2024 20:22:46 +0200 Message-ID: <20240812182355.11641-1-dakr@kernel.org> X-Mailer: git-send-email 2.45.2 MIME-Version: 1.0 X-Stat-Signature: 1kbq8rb6ci7eetprjkbom97zg3nuxttj X-Rspamd-Queue-Id: 69D7F40018 X-Rspam-User: X-Rspamd-Server: rspam08 X-HE-Tag: 1723487052-462617 X-HE-Meta: U2FsdGVkX1/eakOFkM8Tqq812GQbNyn4KqkTTfzhbYW4zH6g3AoiBqJGlvd5994HmZ5hs77Xi1FxgLOZnvXrA5DUs7BkjNkU4FM3gXc4SL1GLTjh7GcC5iLNJUkf2Rxb3szrtRk32E9Wrzb7H8vrq7i9iAPCUgS/A06alAqLr+liYjuDLc9wMBh0dY/GFmQ3OOVZPYum4YMJ+DVqtGMkIScKLKz0Nw6pANFN9vXmK5DDOfRTbRJEIeR1v2KUSlW+/d99GyXUWoS180zKsVLxEugCHxuUDpdqtOnPwoKLLCv+ZqykzgIgxLq8JcI++aZPC7fFBL8hfeizdiOjXVmLZgdV3fT1TQPMSbPS4VI9cSqRcq9Y9kpsR5poEKqdG9hn7ejOZZTywMj+R3tkj9X9Y6PUWb7XV5rkt9g0aX8gkk88c+WYo7wwkYCDt10JmUW6CndutzS0kzC2/r3oySO5EdzgklfSRQZjVY1h9s5kPMeKsQAkBp/iEsOHF3KsMkBY/jmM7qnjdX/i+Q3kg8EeLYpN969wzSjHkcPEcaovNjat/8gbI04Bfw7nSQriRJfJH+9+9GSk7Bv3UZrziMAH/rZrPaMRT22Mv5XIIWc44OuXM59khvpBSQuzEBR409xQm67rqhc5ijp163lZHD9hxWMdAJWA0XAwoWHahbwbqI+E8xByZXUgPUHRZX0yiKsi4K7QMpMPoP7mOADfpdmO0ZgjIIm6hw+Tdy0PMr73N0Ut7ibbvNf4k4cVUGUIUySPSupXcTMH5jgJMyCLMRBWdIp32ojodukCNIHRTIiaaInNrj7c4/TM1wFOXdRTNsG7e/9xqgXgR+PqST+HIlueGQ2uiZhEQzS59477iBHht/WMKZ6UUtgYCtFjU9obngJvYXQN4zuZrvprlRprGriW+I+RNYcOtu/vkQ/+IKww6zFjMGNBU54V6BHlQT5OTWmjRMFIsuWd8GUv8uK5+T/ zrQ6nJXU bJyjoYjPHfpt1Lg+0z7ReyYwxe2hsduax/Dx1geAPPbXN7wLPx0X/yZsqar/9E7FOLtl2dsYcfOcOs/5ovOk6pSy7GzsMPAYSCk8Y/+AtuzGTMoUMnlaAfizPqzJKRbvFFFjreifJKN7iYtA7wG3LXgZWdyi5oHXuOCP8tqwp2dwzwVLDh3PKDML/G8f8rIpQAtFtm5fqMXZC8VhP0YokSojt361X5qu3fq1qpferurF0BO77eJtzlOWzquQIelw64hdwKg6SOfhRT/UgC/4WNWgi0xybT6onEsapIT5Stzj3MKFK5elVVDHpYw== X-Bogosity: Ham, tests=bogofilter, spamicity=0.000000, version=1.2.4 Sender: owner-linux-mm@kvack.org Precedence: bulk X-Loop: owner-majordomo@kvack.org List-ID: List-Subscribe: List-Unsubscribe: Hi, This patch series adds generic kernel allocator support for Rust, which so far is limited to `kmalloc` allocations. In order to abstain from (re-)adding unstable Rust features to the kernel, this patch series does not extend the `Allocator` trait from Rust's `alloc` crate, nor does it extend the `BoxExt` and `VecExt` extensions. Instead, this series introduces a kernel specific `Allocator` trait, which is implemented by the `Kmalloc`, `Vmalloc` and `KVmalloc` allocators, also implemented in the context of this series. As a consequence we need our own kernel `Box` and `Vec` types. Additionally, this series adds the following type aliases: ``` pub type KBox = Box; pub type VBox = Box; pub type KVBox = Box; pub type KVec = Vec; pub type VVec = Vec; pub type KVVec = Vec; ``` With that, we can start using the kernel `Box` and `Vec` types throughout the tree and remove the now obolete extensions `BoxExt` and `VecExt`. For a final cleanup, this series removes the last minor dependencies to Rust's `alloc` crate and removes it from the entire kernel build. The series ensures not to break the `rusttest` make target by implementing the `allocator_test` module providing a stub implementation for all kernel `Allocator`s. This patch series passes all KUnit tests, including the ones added by this series. Additionally, the tests were run with `kmemleak` and `KASAN` enabled, without any issues. This series is based on [1], which hit -mm/mm-unstable, and is also available in [2]. [1] https://git.kernel.org/pub/scm/linux/kernel/git/dakr/linux.git/log/?h=mm/krealloc [2] https://git.kernel.org/pub/scm/linux/kernel/git/dakr/linux.git/log/?h=rust/mm Changes in v5: - (safety) comment / documentation fixes suggested by Alice, Benno and Gary - remove `Unique` and implement `Send` and `Sync` for `Box` and `Vec` - use `KMALLOC_MAX_SIZE` for `KVmalloc` test and add a `Kmalloc` test that expects to fail for `KMALLOC_MAX_SIZE` - create use constants `KREALLOC`, `VREALLOC` and `KVREALLOC` for `ReallocFuncs` - drop `Box::drop_contents` for now, will add it again, once I actually rebase on the original patch that introduces it - improve usage of `size_of_val` in `Box` - move `InPlaceInit` and `ForeignOwnable` impls into kbox.rs - fix missing `Box` conversions in rnull.rs - reworked `Cmalloc` to keep track of the size of memory allocations itself - remove `GlobalAlloc` together with the `alloc` crate to avoid a linker error - remove `alloc` from scripts/generate_rust_analyzer.py Changes in v4: - (safety) comment fixes suggested by Alice and Boqun - remove `Box::from_raw_alloc` and `Box::into_raw_alloc`, we don't need them - in `Box::drop` call `size_of_val` before `drop_in_place` - implement ForeignOwnable for Pin> as suggested by Alice - in `Vec::extend_with`, iterate over `n` instead of `spare.len()` - for `Vmalloc` and `KVmalloc` fail allocation for alignments larger than PAGE_SIZE for now (will add support for larger alignments in a separate series) - implement `Cmalloc` in `allocator_test` and type alias all kernel allocator types to it, such that we can use the kernel's `Box` and `Vec` types in userspace tests (rusttest) - this makes patch "rust: str: test: replace `alloc::format`" rather trivial Changes in v3: - Box: - minor documentation fixes - removed unnecessary imports in doc tests - dropeed `self` argument from some remaining `Box` methods - implement `InPlaceInit` for Box rather than specifically for `KBox` - Vec: - minor documentation fixes - removed useless `Vec::allocator` method - in `Vec::extend_with` use `Vec::spare_capacity_mut` instead of raw pointer operations - added a few missing safety comments - pass GFP flags to `Vec::collect` - fixed a rustdoc warning in alloc.rs - fixed the allocator_test module to implement the `Allocator` trait correctly - rebased to rust-next Changes in v2: - preserve `impl GlobalAlloc for Kmalloc` and remove it at the end (Benno) - remove `&self` parameter from all `Allocator` functions (Benno) - various documentation fixes for `Allocator` (Benno) - use `NonNull` for `Allocator::free` and `Option>` for `Allocator::realloc` (Benno) - fix leak of `IntoIter` in `Vec::collect` (Boqun) - always realloc (try to shrink) in `Vec::collect`, it's up the the `Allocator` to provide a heuristic whether it makes sense to actually shrink - rename `KBox` -> `Box` and `KVec` -> `Vec` and provide type aliases `KBox`, `VBox`, `KVBox`, etc. - This allows for much cleaner code and, in combination with removing `&self` parameters from `Allocator`s, gets us rid of the need for `Box::new` and `Box::new_alloc` and all other "_alloc" postfixed functions. - Before: `KBox::new_alloc(foo, Vmalloc)?` - After: `VBox::new(foo)?`, which resolves to `Box::::new(foo)?; Danilo Krummrich (26): rust: alloc: add `Allocator` trait rust: alloc: separate `aligned_size` from `krealloc_aligned` rust: alloc: rename `KernelAllocator` to `Kmalloc` rust: alloc: implement `Allocator` for `Kmalloc` rust: alloc: add module `allocator_test` rust: alloc: implement `Vmalloc` allocator rust: alloc: implement `KVmalloc` allocator rust: alloc: add __GFP_NOWARN to `Flags` rust: alloc: implement kernel `Box` rust: treewide: switch to our kernel `Box` type rust: alloc: remove `BoxExt` extension rust: alloc: add `Box` to prelude rust: alloc: implement kernel `Vec` type rust: alloc: implement `IntoIterator` for `Vec` rust: alloc: implement `collect` for `IntoIter` rust: treewide: switch to the kernel `Vec` type rust: alloc: remove `VecExt` extension rust: alloc: add `Vec` to prelude rust: error: use `core::alloc::LayoutError` rust: error: check for config `test` in `Error::name` rust: alloc: implement `contains` for `Flags` rust: alloc: implement `Cmalloc` in module allocator_test rust: str: test: replace `alloc::format` rust: alloc: update module comment of alloc.rs kbuild: rust: remove the `alloc` crate and `GlobalAlloc` MAINTAINERS: add entry for the Rust `alloc` module MAINTAINERS | 7 + drivers/block/rnull.rs | 4 +- rust/Makefile | 44 +- rust/bindings/bindings_helper.h | 1 + rust/exports.c | 1 - rust/helpers.c | 16 +- rust/kernel/alloc.rs | 121 +++- rust/kernel/alloc/allocator.rs | 156 +++-- rust/kernel/alloc/allocator_test.rs | 182 ++++++ rust/kernel/alloc/box_ext.rs | 56 -- rust/kernel/alloc/kbox.rs | 437 ++++++++++++++ rust/kernel/alloc/kvec.rs | 875 ++++++++++++++++++++++++++++ rust/kernel/alloc/vec_ext.rs | 185 ------ rust/kernel/error.rs | 6 +- rust/kernel/init.rs | 83 +-- rust/kernel/init/__internal.rs | 2 +- rust/kernel/lib.rs | 1 - rust/kernel/prelude.rs | 5 +- rust/kernel/str.rs | 35 +- rust/kernel/sync/arc.rs | 17 +- rust/kernel/sync/condvar.rs | 4 +- rust/kernel/sync/lock/mutex.rs | 2 +- rust/kernel/sync/lock/spinlock.rs | 2 +- rust/kernel/sync/locked_by.rs | 2 +- rust/kernel/types.rs | 25 +- rust/kernel/uaccess.rs | 17 +- rust/kernel/workqueue.rs | 20 +- rust/macros/lib.rs | 12 +- samples/rust/rust_minimal.rs | 4 +- scripts/Makefile.build | 7 +- scripts/generate_rust_analyzer.py | 11 +- 31 files changed, 1853 insertions(+), 487 deletions(-) create mode 100644 rust/kernel/alloc/allocator_test.rs delete mode 100644 rust/kernel/alloc/box_ext.rs create mode 100644 rust/kernel/alloc/kbox.rs create mode 100644 rust/kernel/alloc/kvec.rs delete mode 100644 rust/kernel/alloc/vec_ext.rs base-commit: c0d669a6bbe161a3afa26dea3d8491863e352e59