Message ID | 20250102230658.1112261-1-isaacmanjarres@google.com (mailing list archive) |
---|---|
Headers | show |
Series | Cleanup for memfd_create() | expand |
On Thu, Jan 02, 2025 at 03:06:53PM -0800, Isaac J. Manjarres wrote: > memfd_create() handles all of its logic in a single function. Some of > the logic in the function is also somewhat contrived (i.e. copying the > memfd name from userpace). > > This series aims to cleanup memfd_create() by splitting out the logic > into helper functions, and simplifying the memfd name copying to make > the code easier to follow. > > This has no intended functional changes. > What is this against? I tried b4 shazam'ing it against mm-unstable and it didn't apply. Could you rebase on mm-unstable? Thanks! > Isaac J. Manjarres (2): > mm/memfd: Refactor and cleanup the logic in memfd_create() > mm/memfd: Use strncpy_from_user() to read memfd name > > mm/memfd.c | 101 +++++++++++++++++++++++++++++++---------------------- > 1 file changed, 59 insertions(+), 42 deletions(-) > > -- > 2.47.1.613.gc27f4b7a9f-goog >
On Tue, Jan 07, 2025 at 03:09:49PM +0000, Lorenzo Stoakes wrote: > On Thu, Jan 02, 2025 at 03:06:53PM -0800, Isaac J. Manjarres wrote: > > memfd_create() handles all of its logic in a single function. Some of > > the logic in the function is also somewhat contrived (i.e. copying the > > memfd name from userpace). > > > > This series aims to cleanup memfd_create() by splitting out the logic > > into helper functions, and simplifying the memfd name copying to make > > the code easier to follow. > > > > This has no intended functional changes. > > > > What is this against? I tried b4 shazam'ing it against mm-unstable and it > didn't apply. Could you rebase on mm-unstable? > > Thanks! > Hi Lorenzo, I had uploaded this against Linus' master branch. However, I've uploaded a second version that is just a rebase on mm-unstable, as requested: https://lore.kernel.org/all/20250107184804.4074147-1-isaacmanjarres@google.com/ Thanks, Isaac