mbox series

[v3,0/2] Cleanup for memfd_create()

Message ID 20250109185908.1006310-1-isaacmanjarres@google.com (mailing list archive)
Headers show
Series Cleanup for memfd_create() | expand

Message

Isaac J. Manjarres Jan. 9, 2025, 6:59 p.m. UTC
memfd_create() handles all of its logic in a single function. Some of
the logic in the function is also somewhat contrived (i.e. copying the
memfd name from userpace).

This series aims to cleanup memfd_create() by splitting out the logic
into helper functions, and simplifying the memfd name copying to make
the code easier to follow.

This has no intended functional changes.

Note: to apply this series over mm-unstable, please revert v2 of
the series:

commit 729d8812ffd5 ("mm/memfd: Use strncpy_from_user() to read memfd name")
commit 24847e33d746 ("mm/memfd: Refactor and cleanup the logic in memfd_create()")

The base commit from mm-unstable that I used was:

commit 1cdadc307463 ("mm: compaction: skip memory compaction when there are not enough migratable pages")

Thank you Alice and Lorenzo for reviewing v2 of this series and for your
feedback!

Changes from v2 ==> v3:

- Removed namespacing from the new helper functions names.
- Updated names for helper functions to better describe what they do.
- Changed the argument to the flags sanitization function to be a
  pointer to not discard changes to the flags.
- Restored original ordering of how the fd and file structure were
  allocated.
- Simplified the constant used for allocating the buffer for the memfd
  name to NAME_MAX.
- Updated a comment about the return value of strncpy_from_user().
- Added Alice's "Reviewed-by" tag to the last patch in the series.

Changes from v1 ==> v2:

- Rebased on top of the mm-unstable branch instead of Linus' master
  branch. Base commit on mm-unstable: ca95745c20ad ("mm/memmap: prevent
  double scanning of memmap by kmemleak").

Links:

v1: https://lore.kernel.org/all/20250102230658.1112261-1-isaacmanjarres@google.com/#t
v2: https://lore.kernel.org/all/20250107184804.4074147-1-isaacmanjarres@google.com/

Isaac J. Manjarres (2):
  mm/memfd: Refactor and cleanup the logic in memfd_create()
  mm/memfd: Use strncpy_from_user() to read memfd name

 mm/memfd.c | 96 +++++++++++++++++++++++++++++++++++-------------------
 1 file changed, 62 insertions(+), 34 deletions(-)