mbox series

[00/12] Tiny cleanup and improvements about SWAP code

Message ID 20250205092721.9395-1-bhe@redhat.com (mailing list archive)
Headers show
Series Tiny cleanup and improvements about SWAP code | expand

Message

Baoquan He Feb. 5, 2025, 9:27 a.m. UTC
These are all made during reviewing and learning below patchset from
Kairui.

[PATCH v3 00/13] mm, swap: rework of swap allocator locks

Baoquan He (12):
  mm/swap_state.c: fix the obsolete code comment
  mm/swap_state.c: optimize the code in clear_shadow_from_swap_cache()
  mm/swap: remove SWAP_FLAG_PRIO_SHIFT
  mm/swap: skip scanning cluster range if it's empty cluster
  mm/swap: rename swap_is_has_cache() to swap_only_has_cache()
  mm/swapfile.c: update the code comment above swap_count_continued()
  mm/swapfile.c: optimize code in setup_clusters()
  mm/swap_state.c: remove the meaningless code comment
  mm/swapfile.c: remove the unneeded checking
  mm/swap: rename swap_swapcount() to swap_entry_swapped()
  mm/swapfile.c: remove the incorrect code comment
  mm/swapfile.c: open code cluster_alloc_swap()

 include/linux/swap.h |  7 ++--
 mm/swap_state.c      | 12 ++-----
 mm/swapfile.c        | 83 +++++++++++++++++---------------------------
 3 files changed, 37 insertions(+), 65 deletions(-)