mbox series

[v3,0/3] Some cleanups for shmem

Message ID cover.1721626645.git.baolin.wang@linux.alibaba.com (mailing list archive)
Headers show
Series Some cleanups for shmem | expand

Message

Baolin Wang July 22, 2024, 5:43 a.m. UTC
Hi,

This series does some cleanups to reuse code, rename functions and simplify
logic to make code more clear. No functional changes are expected.

Changes from v2:
 - Add reviewed tag from Ryan. Thanks.
 - Pass vma instead of mm to shmem_huge_global_enabled(), per Ryan.

Changes from v1:
 - Add a dummy function in case CONFIG_TRANSPARENT_HUGEPAGE is not
 enabled, which fixes a building error reported by kernel test robot.

Baolin Wang (3):
  mm: shmem: simplify the suitable huge orders validation for tmpfs
  mm: shmem: rename shmem_is_huge() to shmem_huge_global_enabled()
  mm: shmem: move shmem_huge_global_enabled() into
    shmem_allowable_huge_orders()

 include/linux/shmem_fs.h | 11 +----
 mm/huge_memory.c         | 11 ++---
 mm/shmem.c               | 93 +++++++++++++++++++++-------------------
 3 files changed, 54 insertions(+), 61 deletions(-)