diff mbox series

[v3] mm: move_pages: report the number of non-attempted pages

Message ID 1580144268-79620-1-git-send-email-yang.shi@linux.alibaba.com (mailing list archive)
State New, archived
Headers show
Series [v3] mm: move_pages: report the number of non-attempted pages | expand

Commit Message

Yang Shi Jan. 27, 2020, 4:57 p.m. UTC
Since commit 49bd4d71637 ("mm, numa: rework do_pages_move"),
the semantic of move_pages() has changed to return the number of
non-migrated pages if they were result of a non-fatal reasons (usually a
busy page).  This was an unintentional change that hasn't been noticed
except for LTP tests which checked for the documented behavior.

There are two ways to go around this change.  We can even get back to the
original behavior and return -EAGAIN whenever migrate_pages is not able
to migrate pages due to non-fatal reasons.  Another option would be to
simply continue with the changed semantic and extend move_pages
documentation to clarify that -errno is returned on an invalid input or
when migration simply cannot succeed (e.g. -ENOMEM, -EBUSY) or the
number of pages that couldn't have been migrated due to ephemeral
reasons (e.g. page is pinned or locked for other reasons).

This patch implements the second option because this behavior is in
place for some time without anybody complaining and possibly new users
depending on it.  Also it allows to have a slightly easier error handling
as the caller knows that it is worth to retry when err > 0.

But since the new semantic would be aborted immediately if migration is
failed due to ephemeral reasons, need include the number of non-attempted
pages in the return value too.

Fixes: a49bd4d71637 ("mm, numa: rework do_pages_move")
Suggested-by: Michal Hocko <mhocko@suse.com>
Acked-by: Michal Hocko <mhocko@suse.com>
Cc: Wei Yang <richardw.yang@linux.intel.com>
Cc: <stable@vger.kernel.org>    [4.17+]
Signed-off-by: Yang Shi <yang.shi@linux.alibaba.com>
---
v3: Rephrased the commit log per Michal and added Michal's Acked-by
v2: Rebased on top of the latest mainline kernel per Andrew

 mm/migrate.c | 24 ++++++++++++++++++++++--
 1 file changed, 22 insertions(+), 2 deletions(-)

Comments

Matthew Wilcox Jan. 27, 2020, 7:35 p.m. UTC | #1
> @@ -1627,8 +1627,18 @@ static int do_pages_move(struct mm_struct *mm, nodemask_t task_nodes,
>  			start = i;
>  		} else if (node != current_node) {
>  			err = do_move_pages_to_node(mm, &pagelist, current_node);
> -			if (err)
> +			if (err) {
> +				/*
> +				 * Possitive err means the number of failed

"positive"

> +				 * pages to migrate.  Since we are going to
> +				 * abort and return the number of non-migrated
> +				 * pages, so need incude the rest of the

"need to include"

> +				 * nr_pages that have not attempted as well.

"have not been attempted"

> @@ -1674,6 +1687,13 @@ static int do_pages_move(struct mm_struct *mm, nodemask_t task_nodes,
>  
>  	/* Make sure we do not overwrite the existing error */
>  	err1 = do_move_pages_to_node(mm, &pagelist, current_node);
> +	/*
> +	 * Don't have to report non-attempted pages here since:
> +	 *     - If the above loop is done gracefully there is not non-attempted

"all pages have been attempted"

> +	 *       page.
> +	 *     - If the above loop is aborted to it means more fatal error

s/to// s/more/a/

> +	 *       happened, should return err.
> +	 */   

I'd also be tempted to rename "err" to "ret" since it has meanings beyond
"error" now.
Yang Shi Jan. 27, 2020, 7:55 p.m. UTC | #2
On 1/27/20 11:35 AM, Matthew Wilcox wrote:
>> @@ -1627,8 +1627,18 @@ static int do_pages_move(struct mm_struct *mm, nodemask_t task_nodes,
>>   			start = i;
>>   		} else if (node != current_node) {
>>   			err = do_move_pages_to_node(mm, &pagelist, current_node);
>> -			if (err)
>> +			if (err) {
>> +				/*
>> +				 * Possitive err means the number of failed
> "positive"
>
>> +				 * pages to migrate.  Since we are going to
>> +				 * abort and return the number of non-migrated
>> +				 * pages, so need incude the rest of the
> "need to include"
>
>> +				 * nr_pages that have not attempted as well.
> "have not been attempted"
>
>> @@ -1674,6 +1687,13 @@ static int do_pages_move(struct mm_struct *mm, nodemask_t task_nodes,
>>   
>>   	/* Make sure we do not overwrite the existing error */
>>   	err1 = do_move_pages_to_node(mm, &pagelist, current_node);
>> +	/*
>> +	 * Don't have to report non-attempted pages here since:
>> +	 *     - If the above loop is done gracefully there is not non-attempted
> "all pages have been attempted"
>
>> +	 *       page.
>> +	 *     - If the above loop is aborted to it means more fatal error
> s/to// s/more/a/
>
>> +	 *       happened, should return err.
>> +	 */
> I'd also be tempted to rename "err" to "ret" since it has meanings beyond
> "error" now.

Thanks for catching these problems. Will fix in v4.
>
Michal Hocko Jan. 29, 2020, 10:12 a.m. UTC | #3
Btw. please do not forget to update the man page as well.
Thanks!
Yang Shi Jan. 29, 2020, 5:18 p.m. UTC | #4
On 1/29/20 2:12 AM, Michal Hocko wrote:
> Btw. please do not forget to update the man page as well.
> Thanks!

Sure.
diff mbox series

Patch

diff --git a/mm/migrate.c b/mm/migrate.c
index 86873b6..9b8eb5d 100644
--- a/mm/migrate.c
+++ b/mm/migrate.c
@@ -1627,8 +1627,18 @@  static int do_pages_move(struct mm_struct *mm, nodemask_t task_nodes,
 			start = i;
 		} else if (node != current_node) {
 			err = do_move_pages_to_node(mm, &pagelist, current_node);
-			if (err)
+			if (err) {
+				/*
+				 * Possitive err means the number of failed
+				 * pages to migrate.  Since we are going to
+				 * abort and return the number of non-migrated
+				 * pages, so need incude the rest of the
+				 * nr_pages that have not attempted as well.
+				 */
+				if (err > 0)
+					err += nr_pages - i - 1;
 				goto out;
+			}
 			err = store_status(status, start, current_node, i - start);
 			if (err)
 				goto out;
@@ -1659,8 +1669,11 @@  static int do_pages_move(struct mm_struct *mm, nodemask_t task_nodes,
 			goto out_flush;
 
 		err = do_move_pages_to_node(mm, &pagelist, current_node);
-		if (err)
+		if (err) {
+			if (err > 0)
+				err += nr_pages - i - 1;
 			goto out;
+		}
 		if (i > start) {
 			err = store_status(status, start, current_node, i - start);
 			if (err)
@@ -1674,6 +1687,13 @@  static int do_pages_move(struct mm_struct *mm, nodemask_t task_nodes,
 
 	/* Make sure we do not overwrite the existing error */
 	err1 = do_move_pages_to_node(mm, &pagelist, current_node);
+	/*
+	 * Don't have to report non-attempted pages here since:
+	 *     - If the above loop is done gracefully there is not non-attempted
+	 *       page.
+	 *     - If the above loop is aborted to it means more fatal error
+	 *       happened, should return err.
+	 */   
 	if (!err1)
 		err1 = store_status(status, start, current_node, i - start);
 	if (!err)