diff mbox series

fs/exec.c: simplify initial stack size expansion

Message ID 2017429.gqNitNVd0C@mobilepool36.emlix.com (mailing list archive)
State New
Headers show
Series fs/exec.c: simplify initial stack size expansion | expand

Commit Message

Rolf Eike Beer Oct. 19, 2022, 7:32 a.m. UTC
I had a hard time trying to understand completely why it is using vm_end in
one side of the expression and vm_start in the other one, and using
something in the "if" clause that is not an exact copy of what is used
below. The whole point is that the stack_size variable that was used in the
"if" clause is the difference between vm_start and vm_end, which is not far
away but makes this thing harder to read than it must be.

Signed-off-by: Rolf Eike Beer <eb@emlix.com>
---
 fs/exec.c | 13 +++++--------
 1 file changed, 5 insertions(+), 8 deletions(-)

Comments

Kees Cook Oct. 25, 2022, 10:24 p.m. UTC | #1
On Wed, 19 Oct 2022 09:32:35 +0200, Rolf Eike Beer wrote:
> I had a hard time trying to understand completely why it is using vm_end in
> one side of the expression and vm_start in the other one, and using
> something in the "if" clause that is not an exact copy of what is used
> below. The whole point is that the stack_size variable that was used in the
> "if" clause is the difference between vm_start and vm_end, which is not far
> away but makes this thing harder to read than it must be.
> 
> [...]

Applied to for-next/execve, thanks!

[1/1] fs/exec.c: simplify initial stack size expansion
      https://git.kernel.org/kees/c/bfb4a2b95875
diff mbox series

Patch

diff --git a/fs/exec.c b/fs/exec.c
index 768843477a49..990891c5d8fe 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -840,16 +840,13 @@  int setup_arg_pages(struct linux_binprm *bprm,
 	 * will align it up.
 	 */
 	rlim_stack = bprm->rlim_stack.rlim_cur & PAGE_MASK;
+
+	stack_expand = min(rlim_stack, stack_size + stack_expand);
+
 #ifdef CONFIG_STACK_GROWSUP
-	if (stack_size + stack_expand > rlim_stack)
-		stack_base = vma->vm_start + rlim_stack;
-	else
-		stack_base = vma->vm_end + stack_expand;
+	stack_base = vma->vm_start + stack_expand;
 #else
-	if (stack_size + stack_expand > rlim_stack)
-		stack_base = vma->vm_end - rlim_stack;
-	else
-		stack_base = vma->vm_start - stack_expand;
+	stack_base = vma->vm_end - stack_expand;
 #endif
 	current->mm->start_stack = bprm->p;
 	ret = expand_stack(vma, stack_base);