Message ID | 20200505115543.1660-2-thunder.leizhen@huawei.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | eliminate SECTOR related magic numbers and duplicated conversions | expand |
On Tue, May 05, 2020 at 07:55:40PM +0800, Zhen Lei wrote: > +#ifndef SECTORS_PER_PAGE_SHIFT > +#define SECTORS_PER_PAGE_SHIFT (PAGE_SHIFT - SECTOR_SHIFT) > +#endif > +#ifndef SECTORS_PER_PAGE > +#define SECTORS_PER_PAGE (1 << SECTORS_PER_PAGE_SHIFT) > #endif I find SECTORS_PER_PAGE_SHIFT quite hard to read. I had a quick skim of your other patches, and it seems to me that we could replace '<< SECTORS_PER_PAGE_SHIFT' with '* SECTORS_PER_PAGE' and it would be more readable in every case.
On 2020/5/5 20:10, Matthew Wilcox wrote: > On Tue, May 05, 2020 at 07:55:40PM +0800, Zhen Lei wrote: >> +#ifndef SECTORS_PER_PAGE_SHIFT >> +#define SECTORS_PER_PAGE_SHIFT (PAGE_SHIFT - SECTOR_SHIFT) >> +#endif >> +#ifndef SECTORS_PER_PAGE >> +#define SECTORS_PER_PAGE (1 << SECTORS_PER_PAGE_SHIFT) >> #endif > > I find SECTORS_PER_PAGE_SHIFT quite hard to read. I had a quick skim > of your other patches, and it seems to me that we could replace > '<< SECTORS_PER_PAGE_SHIFT' with '* SECTORS_PER_PAGE' and it would be > more readable in every case. OK, I will delete SECTORS_PER_PAGE_SHIFT, and replace the shift with {*|/} SECTORS_PER_PAGE if it's not suitable to be replaced by sectors_to_page()/page_to_sectors(). > > . >
diff --git a/drivers/block/zram/zram_drv.h b/drivers/block/zram/zram_drv.h index f2fd46daa760..12309175d55e 100644 --- a/drivers/block/zram/zram_drv.h +++ b/drivers/block/zram/zram_drv.h @@ -21,8 +21,6 @@ #include "zcomp.h" -#define SECTORS_PER_PAGE_SHIFT (PAGE_SHIFT - SECTOR_SHIFT) -#define SECTORS_PER_PAGE (1 << SECTORS_PER_PAGE_SHIFT) #define ZRAM_LOGICAL_BLOCK_SHIFT 12 #define ZRAM_LOGICAL_BLOCK_SIZE (1 << ZRAM_LOGICAL_BLOCK_SHIFT) #define ZRAM_SECTOR_PER_LOGICAL_BLOCK \ diff --git a/include/linux/blkdev.h b/include/linux/blkdev.h index 32868fbedc9e..a752e1c80bf0 100644 --- a/include/linux/blkdev.h +++ b/include/linux/blkdev.h @@ -904,10 +904,16 @@ static inline struct request_queue *bdev_get_queue(struct block_device *bdev) * multiple of 512 bytes. Hence these two constants. */ #ifndef SECTOR_SHIFT -#define SECTOR_SHIFT 9 +#define SECTOR_SHIFT 9 #endif #ifndef SECTOR_SIZE -#define SECTOR_SIZE (1 << SECTOR_SHIFT) +#define SECTOR_SIZE (1 << SECTOR_SHIFT) +#endif +#ifndef SECTORS_PER_PAGE_SHIFT +#define SECTORS_PER_PAGE_SHIFT (PAGE_SHIFT - SECTOR_SHIFT) +#endif +#ifndef SECTORS_PER_PAGE +#define SECTORS_PER_PAGE (1 << SECTORS_PER_PAGE_SHIFT) #endif /*
This is similar to commit 233bde21a ("block: Move SECTOR_SIZE and SECTOR_SHIFT definitions into <linux/blkdev.h>"), prepare to clear dozens of duplicated codes. Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com> --- drivers/block/zram/zram_drv.h | 2 -- include/linux/blkdev.h | 10 ++++++++-- 2 files changed, 8 insertions(+), 4 deletions(-)