diff mbox series

[RESEND,v2,1/4] mm/mremap: format the check in move_normal_pmd() same as move_huge_pmd()

Message ID 20200626135216.24314-2-richard.weiyang@linux.alibaba.com (mailing list archive)
State New, archived
Headers show
Series mm/mremap: cleanup move_page_tables() a little | expand

Commit Message

Wei Yang June 26, 2020, 1:52 p.m. UTC
No functional change, just improve the readability and prepare for
following cleanup.

Signed-off-by: Wei Yang <richard.weiyang@linux.alibaba.com>
Tested-by: Dmitry Osipenko <digetx@gmail.com>
---
 mm/mremap.c | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Kirill A . Shutemov July 6, 2020, 10:06 a.m. UTC | #1
On Fri, Jun 26, 2020 at 09:52:13PM +0800, Wei Yang wrote:
> No functional change, just improve the readability and prepare for
> following cleanup.

It's pretty much redundant. It doesn't provide any meaningful
readability improvement. Please drop the patch.
diff mbox series

Patch

diff --git a/mm/mremap.c b/mm/mremap.c
index 5dd572d57ca9..97bf9a2a8bd5 100644
--- a/mm/mremap.c
+++ b/mm/mremap.c
@@ -200,8 +200,9 @@  static bool move_normal_pmd(struct vm_area_struct *vma, unsigned long old_addr,
 	struct mm_struct *mm = vma->vm_mm;
 	pmd_t pmd;
 
-	if ((old_addr & ~PMD_MASK) || (new_addr & ~PMD_MASK)
-	    || old_end - old_addr < PMD_SIZE)
+	if ((old_addr & ~PMD_MASK) ||
+	    (new_addr & ~PMD_MASK) ||
+	    old_end - old_addr < PMD_SIZE)
 		return false;
 
 	/*