diff mbox series

[09/94] virt/kvm: Use vma_lookup() instead of find_vma_intersection()

Message ID 20210428153542.2814175-10-Liam.Howlett@Oracle.com (mailing list archive)
State New, archived
Headers show
Series Introducing the Maple Tree | expand

Commit Message

Liam R. Howlett April 28, 2021, 3:35 p.m. UTC
Use the new vma_lookup() call for abstraction & code readability.

Signed-off-by: Liam R. Howlett <Liam.Howlett@Oracle.com>
---
 virt/kvm/kvm_main.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/virt/kvm/kvm_main.c b/virt/kvm/kvm_main.c
index 383df23514b9..aedb642cb4be 100644
--- a/virt/kvm/kvm_main.c
+++ b/virt/kvm/kvm_main.c
@@ -2019,7 +2019,7 @@  static kvm_pfn_t hva_to_pfn(unsigned long addr, bool atomic, bool *async,
 	}
 
 retry:
-	vma = find_vma_intersection(current->mm, addr, addr + 1);
+	vma = vma_lookup(current->mm, addr);
 
 	if (vma == NULL)
 		pfn = KVM_PFN_ERR_FAULT;