diff mbox series

[RFC,3/7] mm/headers: change emun order of MM_COUNTERS

Message ID 20220728204511.56348-4-ryncsn@gmail.com (mailing list archive)
State New
Headers show
Series Replace per-task RSS cache with per-CPU RSS cache | expand

Commit Message

Kairui Song July 28, 2022, 8:45 p.m. UTC
From: Kairui Song <kasong@tencent.com>

get_rss reads MM_FILEPAGES, MM_ANONPAGES, MM_SHMEMPAGES. Make them
continues so it's easier to read in a loop in following commits.

Signed-off-by: Kairui Song <kasong@tencent.com>
---
 include/linux/mm_types_task.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/include/linux/mm_types_task.h b/include/linux/mm_types_task.h
index a00327c663db..14182ded3fda 100644
--- a/include/linux/mm_types_task.h
+++ b/include/linux/mm_types_task.h
@@ -43,8 +43,8 @@  struct vmacache {
 enum {
 	MM_FILEPAGES,	/* Resident file mapping pages */
 	MM_ANONPAGES,	/* Resident anonymous pages */
-	MM_SWAPENTS,	/* Anonymous swap entries */
 	MM_SHMEMPAGES,	/* Resident shared memory pages */
+	MM_SWAPENTS,	/* Anonymous swap entries */
 	NR_MM_COUNTERS
 };