diff mbox series

[v2] mm/page_alloc: Consolidate unlikely handling in page_expected_state

Message ID 20250321062053.607044-1-ye.liu@linux.dev (mailing list archive)
State New
Headers show
Series [v2] mm/page_alloc: Consolidate unlikely handling in page_expected_state | expand

Commit Message

Ye Liu March 21, 2025, 6:20 a.m. UTC
From: Ye Liu <liuye@kylinos.cn>

This patch consolidates the handling of unlikely conditions in the
page_expected_state function, reducing code duplication and improving
readability.

Previously, the check_new_page_bad function contained logic to handle
__PG_HWPOISON flags, which was called from check_new_page. This patch
moves the handling of __PG_HWPOISON flags into the page_expected_state
function and removes the check_new_page_bad function. The check_new_page
function now directly calls bad_page if the page has unexpected flags.

This change simplifies the code by reducing the number of functions and
centralizing the unlikely condition handling in one place.

Signed-off-by: Ye Liu <liuye@kylinos.cn>

---
V2: return true instead of false in the PageHWPoison branch.
---
---
 mm/page_alloc.c | 24 ++++++++----------------
 1 file changed, 8 insertions(+), 16 deletions(-)

Comments

Sidhartha Kumar March 21, 2025, 4:23 p.m. UTC | #1
On 3/21/25 2:20 AM, Ye Liu wrote:
> From: Ye Liu <liuye@kylinos.cn>
> 
> This patch consolidates the handling of unlikely conditions in the
> page_expected_state function, reducing code duplication and improving
> readability.
> 
> Previously, the check_new_page_bad function contained logic to handle
> __PG_HWPOISON flags, which was called from check_new_page. This patch
> moves the handling of __PG_HWPOISON flags into the page_expected_state
> function and removes the check_new_page_bad function. The check_new_page
> function now directly calls bad_page if the page has unexpected flags.
> 
> This change simplifies the code by reducing the number of functions and
> centralizing the unlikely condition handling in one place.
> 
> Signed-off-by: Ye Liu <liuye@kylinos.cn>
> 
> ---
> V2: return true instead of false in the PageHWPoison branch.
> ---
> ---
>   mm/page_alloc.c | 24 ++++++++----------------
>   1 file changed, 8 insertions(+), 16 deletions(-)
> 
> diff --git a/mm/page_alloc.c b/mm/page_alloc.c
> index 2842da893eea..e8b95c6a96c2 100644
> --- a/mm/page_alloc.c
> +++ b/mm/page_alloc.c
> @@ -903,6 +903,12 @@ static inline bool page_expected_state(struct page *page,
>   			(page->flags & check_flags)))
>   		return false;
>   
> +	if (unlikely(PageHWPoison(page))) {
> +		/* Don't complain about hwpoisoned pages */
> +		if (PageBuddy(page))
> +			__ClearPageBuddy(page);
> +	}
> +
>   	return true;
>   }
>   
> @@ -1586,29 +1592,15 @@ static __always_inline void page_del_and_expand(struct zone *zone,
>   	account_freepages(zone, -nr_pages, migratetype);
>   }
>   
> -static void check_new_page_bad(struct page *page)
> -{
> -	if (unlikely(PageHWPoison(page))) {
> -		/* Don't complain about hwpoisoned pages */
> -		if (PageBuddy(page))
> -			__ClearPageBuddy(page);
> -		return;
> -	}
> -
> -	bad_page(page,
> -		 page_bad_reason(page, PAGE_FLAGS_CHECK_AT_PREP));
> -}
> -
>   /*
>    * This page is about to be returned from the page allocator
>    */
>   static bool check_new_page(struct page *page)
>   {
> -	if (likely(page_expected_state(page,
> -				PAGE_FLAGS_CHECK_AT_PREP|__PG_HWPOISON)))
> +	if (likely(page_expected_state(page, PAGE_FLAGS_CHECK_AT_PREP)))
>   		return false;
>   
> -	check_new_page_bad(page);
> +	bad_page(page, page_bad_reason(page, PAGE_FLAGS_CHECK_AT_PREP));
>   	return true;
>   }
>   

Reviewed-by: Sidhartha Kumar <sidhartha.kumar@oracle.com>
Anshuman Khandual March 24, 2025, 4:29 a.m. UTC | #2
On 3/21/25 11:50, Ye Liu wrote:
> From: Ye Liu <liuye@kylinos.cn>
> 
> This patch consolidates the handling of unlikely conditions in the
> page_expected_state function, reducing code duplication and improving
> readability.
> 
> Previously, the check_new_page_bad function contained logic to handle
> __PG_HWPOISON flags, which was called from check_new_page. This patch
> moves the handling of __PG_HWPOISON flags into the page_expected_state
> function and removes the check_new_page_bad function. The check_new_page
> function now directly calls bad_page if the page has unexpected flags.
> 
> This change simplifies the code by reducing the number of functions and
> centralizing the unlikely condition handling in one place.
> 
> Signed-off-by: Ye Liu <liuye@kylinos.cn>
> 
> ---
> V2: return true instead of false in the PageHWPoison branch.
> ---
> ---
>  mm/page_alloc.c | 24 ++++++++----------------
>  1 file changed, 8 insertions(+), 16 deletions(-)
> 
> diff --git a/mm/page_alloc.c b/mm/page_alloc.c
> index 2842da893eea..e8b95c6a96c2 100644
> --- a/mm/page_alloc.c
> +++ b/mm/page_alloc.c
> @@ -903,6 +903,12 @@ static inline bool page_expected_state(struct page *page,
>  			(page->flags & check_flags)))
>  		return false;
>  
> +	if (unlikely(PageHWPoison(page))) {
> +		/* Don't complain about hwpoisoned pages */
> +		if (PageBuddy(page))
> +			__ClearPageBuddy(page);
> +	}
> +
>  	return true;
>  }
>  
> @@ -1586,29 +1592,15 @@ static __always_inline void page_del_and_expand(struct zone *zone,
>  	account_freepages(zone, -nr_pages, migratetype);
>  }
>  
> -static void check_new_page_bad(struct page *page)
> -{
> -	if (unlikely(PageHWPoison(page))) {
> -		/* Don't complain about hwpoisoned pages */
> -		if (PageBuddy(page))
> -			__ClearPageBuddy(page);
> -		return;
> -	}
> -
> -	bad_page(page,
> -		 page_bad_reason(page, PAGE_FLAGS_CHECK_AT_PREP));
> -}
> -
>  /*
>   * This page is about to be returned from the page allocator
>   */
>  static bool check_new_page(struct page *page)
>  {
> -	if (likely(page_expected_state(page,
> -				PAGE_FLAGS_CHECK_AT_PREP|__PG_HWPOISON)))
> +	if (likely(page_expected_state(page, PAGE_FLAGS_CHECK_AT_PREP)))
>  		return false;
>  
> -	check_new_page_bad(page);
> +	bad_page(page, page_bad_reason(page, PAGE_FLAGS_CHECK_AT_PREP));
>  	return true;
>  }
>  

Reviewed-by: Anshuman Khandual <anshuman.khandual@arm.com>
Markus Elfring March 25, 2025, 7:40 p.m. UTC | #3
> This patch consolidates the handling of …

See also:
https://web.git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?h=v6.14#n94

Regards,
Markus
diff mbox series

Patch

diff --git a/mm/page_alloc.c b/mm/page_alloc.c
index 2842da893eea..e8b95c6a96c2 100644
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
@@ -903,6 +903,12 @@  static inline bool page_expected_state(struct page *page,
 			(page->flags & check_flags)))
 		return false;
 
+	if (unlikely(PageHWPoison(page))) {
+		/* Don't complain about hwpoisoned pages */
+		if (PageBuddy(page))
+			__ClearPageBuddy(page);
+	}
+
 	return true;
 }
 
@@ -1586,29 +1592,15 @@  static __always_inline void page_del_and_expand(struct zone *zone,
 	account_freepages(zone, -nr_pages, migratetype);
 }
 
-static void check_new_page_bad(struct page *page)
-{
-	if (unlikely(PageHWPoison(page))) {
-		/* Don't complain about hwpoisoned pages */
-		if (PageBuddy(page))
-			__ClearPageBuddy(page);
-		return;
-	}
-
-	bad_page(page,
-		 page_bad_reason(page, PAGE_FLAGS_CHECK_AT_PREP));
-}
-
 /*
  * This page is about to be returned from the page allocator
  */
 static bool check_new_page(struct page *page)
 {
-	if (likely(page_expected_state(page,
-				PAGE_FLAGS_CHECK_AT_PREP|__PG_HWPOISON)))
+	if (likely(page_expected_state(page, PAGE_FLAGS_CHECK_AT_PREP)))
 		return false;
 
-	check_new_page_bad(page);
+	bad_page(page, page_bad_reason(page, PAGE_FLAGS_CHECK_AT_PREP));
 	return true;
 }